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 Software Installation 

Software Installation 

Running Environment 

To ensure the optimal performance of Kompass FX3 Pro, the following minimum system 

requirements must be met: 

 Processor: Intel i7 9th generation or above 

 Memory: 16 GB or above DDR4 2666 

 Graphics card: Recommend NVIDIA P2200 or higher-level discrete graphics card, or AMD 

W5100 or higher-level discrete graphics card 

 Storage: 512 GB or larger SSD 

 Operating system: Windows 10 Enterprise LTSC 

Notes 

 It is recommended to disable the antivirus software and firewall in advance. 

 During the installation process, if antivirus software or a firewall prompts to block the 

installation, please choose to allow it. 

Installation Procedure 

 

The following installation pictures are for illustration purposes only. The actual pictures may 

vary. 
 

Step 1 Double click Kompass FX3 Pro installer, and the program will automatically enter the installation 

interface. 

Step 2 Check I've read and agreed to the NovaStar Software License Agreement. 

Click the installation path below to modify the software installation location. 
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Figure 1-1 Software installation 

 

Step 3 Click Install Now to enter the software installation interface. 

Figure 1-2 Automatic software installation 

 

Step 4 Once the software installation is complete, click Try Now to exit the installation interface and 

automatically launch the software. 
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Figure 1-3 Installation completed 

 

Upon successful installation of the software, the following three shortcuts will appear on the 

desktop: 

 : The software main application 

 : The display end application 

 :NDI sender, which acts as an NDI (Network Device Interface) sender, providing an NDI 

video source for the local machine or other devices on the same local area network 

Software Licensing 

Kompass FX3 Pro supports two licensing modes: Temporary and permanent. 

 Temporary license: The license remaining days is displayed at the top right. 

 Permanent license: No expire message is displayed at the top right. 

 Not license: Trial is displayed at the top right. 

If you want to obtain the license, please contact our sales engineer for purchasing the dongle or 

registration code. 

In trial mode, the Kompass FX3 Pro text is displayed on the output. 

Dongle detection rules are as follows: 

 When the inserted dongle is recognized, Trial will disappear automatically and the output 

will not display the Kompass FX3 Pro text. 

 Within 3 seconds after the dongle is removed, the software knows the dongle has been 

removed and prompts you that no dongles have been detected, and the software will again 

display the Kompass FX3 Pro text on the output in 5 seconds. 
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 When the dongle is inserted and recognized normally, the above window and the Kompass 

FX3 Pro text on the output will disappear automatically. 

Figure 1-4 Dongle detection 

 

Please scan the QR code and send the copied content to your sales representative to obtain the 

registration code. Once obtained, enter the registration code into the text box below the QR 

code and click Register to complete the software licensing. 
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 Applications 

Figure 2-1 Application scenarios 

 

 

It is not recommended to use Windows remote access tools in multimedia playback and control 

scenarios. 
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 User Interface Introduction 

User Interface 

Run the software, and the main user interface is as shown below. 

Figure 3-1 User interface 

 

Menu Bar 

Figure 3-2 Menu bar 

 

 File: Perform the project-related operations. 

− New: Create a new project. 

− Open: Open the saved project file. 

− Save: Save the current project file. 

− Save As: Save the currently edited project file as a new project file. 

− Package Project: Package and store the used media files currently being edited or all 

media files in the project package. 
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− Exit: Exit the software with the option to save the current project before exiting. 

 Resource: Add and delete local media. 

− Add Local Media: Add the local media files. 

− Add Local folder: Add a local media folder and all supported media within the folder. 

− New Folder: Add an empty folder to the library. 

− Clear Library: Delete all imported local media files. 

 Output: Manage the output screens, link configurations, and edge blending settings. Click 

the shortcut icon  below to open the output management window. 

 Window: Show or hide the specific user interface areas, including the media library, input 

sources, editing area, global control, timecode, properties, program management, playback 

progress, timeline, and output control. 

 Link: Configure the master-slave or primary-backup connections. 

 Settings: Configure the system settings, including the configuration of system general 

information, display, Office files, communication, audio, and the management of clients. 

 Tools: Use Playback Control Assistant for media transcoding, employ Play Log to view and 

export playback logs, and utilize Port Check to check system port information. 

 Help: Check the software documentation, device ID and software information, as well as 

switch preferred language. 

 : Open AI Assistant to perform AI chat and text-to-image operations. 

 : Create a new project. 

 : Save the currently edited project. 

 : Package the current project. 

 : Restore the user interface layout to the default layout style. 

 : Save the adjusted layout as a new layout. 

 : Load or delete a saved layout. 

 : Shortcuts are hidden. Click to show the shortcut keys. Show or hide binding 

information for keyboard shortcuts, MIDI, DMX, OSC, and Kompass FX3 Pro functions. 

 : Shortcuts are shown. Click to hide the shortcut keys. 
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 : Click to enter the output management interface. 

 : Reserved 

 : Click to access the page turning control and view its instructions; when enabled, the 

icon changes to . 

 : Click to enter the scheduled playback interface; when activated, the icon changes to 

. 

 : Click to open the management console to centrally manage multiple software instances 

on the local area network. 

Modify Layout 

The main interface can be adjusted according to user preferences. 

Step 1 Click  at the top-left corner of the layout you wish to modify to unlock the layout. 

Step 2 Place the mouse cursor on the edge of any area. When the cursor changes to a double-headed 

arrow, hold down the left mouse button and drag to resize the area. 

Step 3 Position the mouse cursor on the title bar of any area. Hold down the left mouse button and 

drag to reposition the area. 

Step 4 Click  at the top-left corner of the layout to lock it. Once locked, the icon will change to 

. 

 

 Click  at the top left corner of the user interface to restore the adjusted layout to the 

default one. 

 After completing the layout modification, click  and enter the new layout name in the 

pop-up dialog box to save the current layout. 
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Load Layout 

You can quickly load and apply a layout style via this function, without needing to adjust each 

area individually. 

Step 1 Click  at the menu bar to open the layout management window. 

Figure 3-3 Load layout 

 

Step 2 In the layout list, select the target layout. 

Step 3 Click Load. 

Here, the following actions can also be performed. 

 Delete: Remove the selected layout template from the layout list. 

 Cancel: Cancel layout loading and exit the layout loading interface. 

Lock User Interface 

Locking the user interface prevents unauthorized access to the editing environment, particularly 

when the operator is away. 

Step 1 Click  at the top right of the main interface to open the UI locking window. 
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Figure 3-4 Lock user interface 

 

Step 2 Enter the password in the text box next to Password. 

Clicking  or  next to Password allows you to show or hide the password. 

Step 3 Adjust the opacity of the lock screen. 

An opacity setting of 100% means it is completely opaque, obscuring the editing interface and 

showing only the lock screen background. 

Step 4 Define the duration of inactivity after which the system will automatically lock itself. 

Options include Never, 3 minutes, 5 minutes, 10 minutes, and 30 minutes, with Never 

indicating no automatic screen locking. 

Step 5 Decide whether to lock the user interface upon software launch. 

 Select Lock user interface on startup to default to the lock screen when the software starts 

up. 

 Deselect it to display the main software interface after startup. 

Step 6 Confirm the settings by clicking OK. 

By clicking Lock, the system enters to the lock screen mode, and the screen lock settings take 

effect. 

 

 To unlock, enter the previously set password and click  to access the software editing 

interface. 

 If the password is forgotten, please contact our technical support engineer for assistance. 
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View System Messages 

The system will provide alarms or messages in Message Center. 

 Upon opening the project, the system will verify the status of the EDID lock and sync card, 

issuing an immediate warning in the message center if any issues arise. 

− If the EDID is not locked, click Lock on the right of the message, and the system will lock 

the device EDID using the EDID shortcut tool. 

− If not synchronized, clicking Sync on the right of the sync message will direct the system 

to the graphics card control panel for synchronization settings. 

 While the software is in operation, the system will continuously monitor the usage of CPU, 

GPU, and memory. If usage reaches or exceeds 85% for 30 consecutive seconds, an alert will 

be issued. 

In the event of an abnormal graphics card usage alert, clicking View on the right of the alert 

will navigate to the Task Manager to examine and address the abnormal processes. 

Click  at the top right corner to open the Message Center interface. 

Figure 3-5 Message center 

 

 Clear: Clear all messages. 

 Read All: Set all messages as read. 

 Do Not Disturb: Toggle message notifications on or off. When enabled, the system will not 

display message alerts, but will log them in the message center. 
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 : Click the icon next to each message to delete it. Click  next to Message Center to 

close the message center window. 

Preview Output 

The function is designed for previewing and monitoring screen output, as well as providing 

global control over playback status. 

To display or hide the preview output window: Navigate to Window > Preview Output. 

Figure 3-6 Preview output 

 

You can perform operations using the following controls: 

 / Start or pause program playback. 

 : Stop program playback. 

 : Adjust the output volume level. 

 / Switch the window to or from fullscreen display mode. 

Global Control 

Control the output display, volume and more. 

Table 3-1 Global control descriptions 

Area Function Description 

Output control 
 : Output connected. Click to disconnect the output. 

 : Output disconnected. Click to restore the output 

connection. 
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Area Function Description 

 

Test pattern 
 : Test pattern enabled. Click to close the test pattern. 

 : Test pattern disabled. Click to open the test pattern. 

Once the test pattern is enabled, the screen will display the test 

pattern. 

FTB 
 : Normal output. Click to make the screen gradually fade 

to black. 

 : FTB enabled. Click to gradually transition the black 

screen to normal display. 

 0.5 s: The time duration from normal display to a black screen. 

This can be manually input with a range from 0 to 5, with a 

default value of 0.5 seconds. 

 
Adjust the output brightness gain by moving the slider. The value 

ranges from -100 to 100. 

 
Adjust the output volume. Click to mute all outputs. 

Stage Editing Area 

Preview the output screen or output slices. 

Figure 3-7 Stage editing area 

 

 The sequence number in the upper left corner of the slice indicates the layer slice in program 

management. This number corresponds one-to-one with the layer number, which can be 

modified in the Bind Input section of the properties. 

 The Tx number in the upper left corner of the slice, where x is a digit, represents the timeline 

layer slice. Slices on the timeline do not support layer binding modifications. 
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Control Mode 

Click  in the top right corner of the editing area to select the control mode, which 

supports both Live and Pre-Edit. 

Mode Name Description 

 

Live After this mode is selected, the stage area displays the live image 

of the current program. 

 

Pre-Edit After this mode is selected, the stage area displays a preview of the 

program to be played. Only after clicking Take can the playing 

program be output to the screen. 

 Cut: Send the currently previewed program to the screen using 

the direct cut mode. 

 Take: Send the currently previewed program to the screen using 

a fade-in, fade-out mode. 

 Keep progress: When sending programs, determine whether the 

program should play from the beginning of the media. 

− On: The program starts playing from the current progress in 

the preview area after you click Take or Cut. 

− Off: The program starts playing from the beginning after 

you click Take or Cut. 

Editing Area Control 

 / : Unlock or lock the stage editing area. Once locked, any additions, modifications, 

or movements of slices are not allowed. 

 : Capture the current playback frame of the selected slice and automatically add the 

captured image to the media library. 

 : Fill the selected layer across the connectors. 

 : When the screen is moved, click to automatically move the screen back to the origin. 

 / : Zoom in or zoom out the editing area. 
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 / : Show or hide all text displays in the stage editing area or screen management 

interface. 

When hidden, only images are shown without any text on slices or sub-outputs. Click  

to show text again. 

 : Revert the last actions and restore the previous state. 

 : Reapply the most recently undone action. 

 After hiding text, press and hold the ALT key to temporarily display text, or release the ALT 

key to continue showing text. 

Program Management 

Manage the programs and layers. 

Figure 3-8 Program management 

 

 Program n/50: Displays the number of edited programs and the total number of programs in 

the current group. 

− n: Indicates the number of programs that contain media. 

− 50: The default number of programs in the system, which will increase as more 

programs are added. 

 Program: The program name 

 Layer control: Manage the display image and output audio of the layers. 

− : The layer image is displayed normally. Click to hide the layer image. 

− : The layer does not display any image. Click to show the layer image. 

− : The layer audio is output normally. Click to disable the layer audio. 

− : The layer audio is disabled. Click to enable the layer audio. 
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− : The layer is not locked, allowing for adding media and other operations. Click to 

lock the layer. 

− : The layer is locked. Once the layer is locked, you cannot add programs, delete 

media, or perform other operations on this layer. Click to unlock the layer. 

− : Click at the leftmost of the layer management area to add a layer. At most 20 

layers are supported. 

 Program media jump playback: When the media is set to jump playback, different status 

icons will be displayed in the upper right corner of the media in the program. 

− : The media plays in a loop, and it loops before transitioning to the next media. 

− : Before the media jumps, and after the media finishes playing, freeze on the last 

frame. 

− : Before the media transitions, and after the media finishes playing, it stops. 

− : After the current media loop, all media within the program will play on loop. 

− : After the media finishes playing, switch to the next program for playback. 

− : After the media finishes playing, it will switch to the designated program. 

− : The media loops continuously and plays a specified number of times before it 

moves on. 

 Program control: Includes the program positioning, program addition, and program playback 

control. 

− : Click this icon on the left of the program name to start playing or resume the 

current program. 

− : Click this icon on the left of the program name to stop playing the current 

program. 

− : Click this icon to enable the layout retaining feature. When enabled, the icon 

changes to  and all slice information remains consistent across programs. 

− : Click this icon to clear media from all programs. 

− : Navigate the program list to the first program. 
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− : Navigate the program list to the currently playing program. 

− : Add a program to the end of the program list. 

Timeline 

Manage the timeline and the layers on it. 

Figure 3-9 Timeline management 

 

 Add layers 

In the Library on the right, select a media and drag it to the blank area of the timeline to 

create a layer and complete the media addition to the layer. 

 Replace media 

Replace the selected media on the timeline. In the media library, select the target media and 

drag it onto the media in the timeline to open the media replacement popup, allowing the 

following actions: 

− Keep: Retain the original media's properties, including start time and duration, when 

replacing. 

− Don't Keep: Replace the selected media on the timeline without retaining the original 

properties. 

− Cancel: Do not replace the media on the timeline. 

 Delete layers 

After all media on the timeline layer is deleted, the timeline layer will be automatically 

deleted. 

 Lock timeline 

− Click  above all layers in the timeline area to lock all layers. Once locked, adding 

layers and media is not allowed. 
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− Click  next to each timeline to lock it. Once locked, adding and removing media 

from the current timeline is not allowed. 

 Control timeline playback 

− : Stop the timeline playback. 

− : Start the timeline playback. 

− : When the playback position is within a clip, play it once, then pause at the end. 

− : When the playback position is within a clip, loop the playback. 

− : Click to jump to and play the previous clip. 

− : Click to jump to and play the next clip. 

− : Click to jump to the beginning of the timeline and restart the playback. 

− : Turn on or turn off the layer media audio. 

− : Click this icon next to the layer to lock the layer. 

− : Hide the media image of the layer. 

− : Click to zoom in the timeline. 

− Click to zoom out the timeline. 

− Layer stacking order determines display priority. The topmost layers have the highest 

priority and appear foremost. 

Playback Control 

Control the playback of a single media or all media of the currently playing program. 

Figure 3-10 Playback control 

 

 Overall control: Manage the playback of all media in the current program. 

− : After the icon is clicked, all media start playing. 
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− : After the icon is clicked, all media pause. 

− : After the icon is clicked, all media stop playing. 

 Single media control: Control the playback for the selected media in the current program. 

− : Click this icon in front of the playing media to continue playing the media. 

− : Click this icon in front of the playing media to pause playback of the media. 

 Playback timers: Counting up, counting down, and synchronized playback control for media 

− : Start the count up display, showing the duration of all media that has been played. 

− : Start the countdown display, showing the remaining playback time for all media. 

− : Start the synchronized playback control. Click and drag the media playback 

progress bar to synchronize the playback time. 

Media Library and Properties 

Figure 3-11 Media library and properties 

 

Media Library 

Add and manage the added media. 

 Delete media: After selecting the media that has not been added to any programs, click  

in the top right corner to delete the selected media. 

When selecting media, press and hold Ctrl or Shift to select multiple media. 

 Manage media: Add and manage media in the media library. 
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− Click  in the top right corner to enter the local media addition interface. 

− Right click a blank area in the media library to perform actions such as Add Local 

Media, Add Local Folder, New Folder, Add Collection, and Clear Library. 

− By dragging the added media into the newly created folder, you can categorize and 

manage the media. 

− By clicking All at the top and choosing different types, you can view the added media 

by categories. 

 Single media operations: Right click a media in the media library to expand the media 

context menu. 

Figure 3-12 Media context menu 

 

− Add Local Media: Add the media files saved locally. 

− Media Optimization: When the size of added media files exceeds the processing 

capability of the graphics card, the media type will display Optimizable. For the specific 

processing capability each graphics card supports, please refer to the table below. Once 

optimized, the media will display Optimized. 

Graphics Card Image Video 

P2200 Width or height > 16384 

pixels 

Width or height > 8192 pixels, or 

bandwidth > 8192×4320@60Hz 

T400 Width or height > 8192 

pixels 

Width or height > 8192 pixels, or 

bandwidth > 8192×4320@30Hz 

RTX 4000 Width or height > 16384 Width or height > 8192 pixels, or 
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Graphics Card Image Video 

RTX5000 

RTX A4000 

RTX A5000 

RTX A5500 

RTX A6000 

pixels bandwidth > 8192×8192@60Hz 

Other graphics cards Width or height > 8192 

pixels 

Width or height > 8192 pixels, or 

bandwidth > 8192×4320@60Hz 

 

Media in hap format will not display Optimizable even if they exceed the maximum 

recommended resolution. 
 

− Cancel Optimization: Reverts optimized media back to its pre-optimized state. 

− Add Collection: Arrange and combine multiple videos or images to create a new video 

playlist, where the videos and images will automatically loop based on the set mode. 

− Add Local Folder: Add the local folders and media within the folders. 

− Insert Folder: Insert a new folder and add the selected media to the inserted folder. 

− More Tools: Add the OSDs and custom test patterns. 

− Rename: Modify the name of the selected media. 

− Replace Media: Replace the media in the material library and meanwhile replace this 

media in all programs together. 

− Access File Location: Open the local storage location of the media file. 

− Delete: Delete the selected media. If the media has already been added to the program, 

it cannot be deleted. 

− Properties: View the basic properties of the selected media. 

Properties 

 Click the media in the program to view and modify the properties of the individual media in 

the program. 

 Click the slice in the editing area to view and modify the output slice properties. 

 Click the layer to view and modify the layer properties, and change the output of all media in 

the layer by adjusting the layer property values. 
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 Click the program to view and modify the program properties. 

Input Sources 

Add and manage the capture device sources, streaming media, NDI input sources and webpage 

sources. 

Output Control 

Manage the backend device by adding control commands. 

 

It is recommended that only personnel with professional training perform this operation. 
 

Effects Library 

Kompass FX3 Pro offers a collection of preset or custom visual effects, letting users swiftly 

apply them during program setup to boost visual impact. 

Simply drag an effect onto a slice or into the program media to add it. 

Exit Software 

Click  in the upper right corner of the software interface, or choose File > Exit. A 

confirmation dialog will appear. 

Figure 3-13 Exit confirmation 

 

Close Display Terminal 

 Check Close display terminal to ensure the output interface closes with the main interface. 
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 Leave it unchecked to keep the output display running according to the program 

management even after the main interface is closed. 

Save Project File 

 Save: Save the current project file when the software closes. 

 Don't save: Close without saving the current project file. 

 Cancel: Cancel the software close. 
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 Project 

Create New Projects 

There are three methods for creating a new project: 

 After launching the software, click New Project on the startup screen, select the storage 

location for the new project, and then click Save. The system will automatically create a 

project file. 

 Navigate to File > New, choose the new project's storage location, and click OK to create a 

new project file. 

 Click  in the menu bar to create a new project file. 

Manage Media 

Kompass FX3 Pro supports processing and playing images, videos, PowerPoint files, and audio 

files. 

The supported media formats are as follows: 

 Video: mp4, avi, mkv, flv, mov, mpeg, mpg, ts, wmv, 3gp, nvf 

 Image: jpg, jpeg, bmp, png, gif, ico 

 Audio: mp3, aac, flac, amr, ape, wav, wma, ogg 

 Office: ppt, pptx 

ppt and pptx decoding supports up to a 4K resolution size. 

 Other formats: exe 

 

Recommended video encoding formats: 

 4K < resolutions ≤ 8K, width and height ≤ 8192 pixels, H.265 (HEVC) or VP9 recommended 

 Resolutions ≤ 4K: H.264 (AVC) recommended 
 

For a better image quality experience, the following video bitrates are recommended. 

 Recommended video bitrates for SDR uploads - single media server and single graphics 

card: 
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Type Video Bitrate Standard Frame Rate (24 

Hz, 25 Hz, 30 Hz) 

Video Bitrate High Frame Rate 

(48 Hz, 50 Hz, 60 Hz) 

4320 (8K) 75 to 90 Mbps 110 to 135 Mbps 

2160p (4K) 35 to 45 Mbps 53 to 68 Mbps 

1440p (2K) 16 Mbps 24 Mbps 

1080p 8 Mbps 12 Mbps 

Video Media Requirements 

The video playback performance varies depending on the graphics card. To ensure optimal 

compatibility and smooth playback, please prepare and add media materials according to the 

following specifications: 

 Requirements for single graphics card scenario: 

− 4K video: Resolution ≤ 4096 pixels (width/height), encoded in H.264 

− 8K video: Resolution ≤ 8192 pixels (width/height), encoded in H.265 

− Super 8K video: Resolution > 8192 pixels and ≤ 16384 pixels (width/height), encoded in 

HAP 

 Requirements for multi-graphics card scenario: 

− 4K video: Resolution ≤ 4096 pixels (width/height), encoded in H.264 

− 8K video: Resolution ≤ 8192 pixels (width/height), encoded in H.265 

− Super 8K video: Requires segmentation, with all segments of equal duration. 

 

Video playback must utilize hardware decoding, with a frame rate of 30/60 fps, and a 

recommended video bitrate under 200 Mbps to ensure synchronization. 
 

Graphics Card Resolution Frame Rate Encoding 

Format 

Pixel Format Bitrate Range 

AMD 4096×4096 60 H.264 YUV4:2:0/YUV4:2:2 0 to 300 Mbps 

3840×2160 60 H.264 (HDR) YUV4:2:0/YUV4:2:2 0 to 300 Mbps 

MPGT400 8192×4320 60 H.265 (HDR) YUV4:2:0/YUV4:2:2 0 to 300 Mbps 

HPGA4000 8192×4800 60 H.265 (HDR) YUV420/YUV422 0 to 450 Mbs 
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Graphics Card Resolution Frame Rate Encoding 

Format 

Pixel Format Bitrate Range 

7680×4320 60 Prores422 

HQ 

YUV420/YUV422 No 

requirements 

3840×2160 60 Prores422 

HQ 

YUV420/YUV422 No 

requirements 

HPGA5000 8192×8192 60 H.265 (HDR) YUV420/YUV422 0 to 150 Mbs 

3840×2160 60 Prores422 

HQ 

YUV420/YUV422 No 

requirements 

HPGA6000 8192×8192 60 H.265 (HDR) YUV420/YUV422 0-150Mbs 

3840×2160 60 H.265 (HDR) YUV420/YUV422 No 

requirements 

HPGA4000 

HGPA5000 

HPGA6000 

16384×4320 60 HAP YUV420/YUV422 No 

requirements 

Add Media 

Import a single media file or multiple media files. 

Import Files 

Step 1 On the right pane, click the Library tab to enter the media library interface. 

Step 2 Right click the blank area and select Add Local Media. 

Step 3 Select the target media and click Open. The software will automatically import the selected 

media files into the media list. 

 To import a single file, simply select the file and click Open to complete the import. 

 To import multiple files simultaneously, press and hold Shift or Ctrl click the target files, and 

then click Open to complete the import. 
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Import Folders 

There are two methods for importing folders. 

Import Folders 

Step 1 Right click the blank area in the media library area, and select Add Local Folder. 

Step 2 Select the folder where you save the media files and click Open. 

The system will automatically import the folder with its original name and the media files within 

the folder into the media library. 

Replace Folders 

Step 1 Right click the blank area in the media library area, and select Insert Folder. The system will 

automatically create a new folder. 

Step 2 Right click the folder and select Replace. 

Step 3 Select the folder you want to import in the pop-up dialog box. 

Step 4 Click Open to import the selected folder and its contents into the media library simultaneously. 

Add Media Collections 

This function allows you to sort and combine multiple videos or images to form a new kind of 

video source. Videos and images within the collection will automatically play in turn based on 

the set mode. 

Step 1 In the Library area, right click and select Add Collection. 
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Figure 4-1 Add media collections 

 

Step 2 Enter the name of the media collection in the Name section. 

Step 3 In the Playback section, select the media playback order within the media collection. The 

options include Sequential and Shuffle. 

 Sequential: The collection media is played sequentially according to the arrangement in the 

collection. 

 Shuffle: The collection of media plays in a random order. 

Step 4 In the Transition section, set the transition effect for the media in the collection. 

Currently, only Cut is supported. 

Step 5 Select the media for which you need to create a collection from All Media. 

If the media have been organized into folders, the folder name will be displayed here. Double 

click the folder to expand it and show the media within. 

Step 6 Click  in the middle to add the selected media to the Collection Media on the right. 

Step 7 In the Collection Media area, select the desired media. 

Step 8 Set the playback duration. 

Double click the playback duration section of the media to set the playback duration of the 

media in the collection. 
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 If the set playback duration is longer than the media duration, the media will automatically 

loop until the playback duration is complete. 

 If the set playback duration is shorter than the media duration, the media will automatically 

stop playing once it reaches the playback duration. 

Step 9 Set the number of media playbacks. 

Double click the count section of the media to adjust the playback times of the media in the 

collection. 

Step 10 Click Save to complete the media collection setup. 

Other Operations 

 Delete media 

In the Collection Media area, select the media you want to delete, and then click the Delete 

button or press the Delete key on the keyboard to remove the selected media. 

 Sync duration 

Select the media with a set playback duration, click Sync and you can set the playback of 

other media to match the selected media's duration. 

 Export List: Export the playlist to an Excel file. 

Select Export List. In the dialog that appears, review the playlist information and click 

Export. 

Add OSDs 

Kompass FX3 Pro supports the OSD as a kind of media. 

Step 1 In the Library area, right click the blank area and select More Tools > Add OSD. 
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Figure 4-2 Add OSDs 

 

Step 2 Enter the desired content in the Text area. 

Step 3 Adjust the font and style. 

You can set the following attributes. 

 : Make the text bold or not. 

 : Italicize the text or not. 

 : Underline the text or not. 

 : Align the text to the left. 

When the display area width is larger than the text width and the moving is set to Static, 

align the text to the left of the display area. 

 : Center the text horizontally. 

When the display area width is larger than the text width and the moving is set to Static, 

center the text horizontally to the display area. 

 : Align the text to the right. 
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When the display area width is larger than the text width and the moving is set to Static, 

align the text to the right of the display area. 

 : Align the text to the top. 

 : Center the text vertically. 

 : Align the text to the bottom. 

Step 4 Enter a name next to Name. 

Step 5 Set the font and font size. 

Select the desired font from the drop-down list and the default font is Arial. 

Select the desired font size from the drop-down list and the default size is 48. You can only 

select a number from the drop-down list and you cannot enter a number manually. 

Step 6 Set the font color. 

Gradient and Solid Color are supported. 

 Solid Color: Select Solid Color from the drop-down list and select the desired color block 

next to Presets. 

When you are not interested in any of the preset colors, click  to open the Select Color 

window to customize your own color, and then click OK to complete the pure color settings. 

After selecting the input text, you can individually set the color of the selected text, but it can 

only be set to a solid color. 

 

 Gradient: Select Gradient from the drop-down list and the default gradient color is 

displayed. 

Click two color blocks at the both ends of the gradient color to customize your own gradient 

colors. Set the gradient angle to complete the gradient color settings. 

 

Step 7 Set the character spacing, line spacing, and text direction. 

 Char Space: Set the horizontal distance between adjacent characters. A larger value results 

in looser spacing, and a smaller value makes it tighter, ranging from 0 to 30 pixels. 

 Line Space: Set the vertical distance between consecutive lines of text. A larger value results 

in looser spacing, and a smaller value makes it tighter. 
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Step 8 Direction: Set the orientation of the OSD text. The options include Horizontal and Vertical. 

Step 9 Set the typography information for text captions. The options include Adaptive, Word Wrap, 

Collapsed, or Custom. 

 Adaptive: The text displays responsively. 

Selecting this option ensures the text display area adjusts automatically according to the text 

size, facilitating a complete and coherent presentation. 

 Word Wrap: Continuous text naturally wraps according to display width, maintaining content 

coherence. 

The display width must be set here. Once configured, the text display area wraps according 

to this width, ensuring the text is presented fully and aligns with expected layout. 

 Collapsed: Segments text strictly according to specified collapse width, possibly truncating 

text and leaving space, suitable for structured layout needs. 

The text will be forcibly trimmed according to the subsequent Display Width setting, even if 

it may truncate text and leave blank spaces, satisfying specific formatting requirements. 

− When Collapse Width ≤ Display Width, the text displays normally. 

− When Collapse Width > Display Width, the text is trimmed to the set display width, 

retaining only the text within that width. 

− When Collapse Width is less than text width, the text wraps naturally.   

 Custom: Text is trimmed according to predefined Display Width and Display Height. 

− When Display Width < text width, the text is trimmed to the set display width, retaining 

text within that width. 

− When Display Width ≥ text width, the text displays normally. 

− When Display Height < text height, the text is trimmed to the set display height, 

retaining text within that height. 

− When Display Height ≥ text height, the text displays normally.   

 

For Collapsed and Custom settings, trimming the text is related to the text alignment. 
 

Step 10 Set the moving effect and speed. 

 Scrolling: The options include Static, Left to Right, Right to Left, Top to Bottom and 

Bottom to Top. 



 
Kompass FX3 Pro Multimedia Playback Software Basic Edition 

User Manual 

 

 

www.novastar.tech 38 
 

 Speed: Set the moving speed. This parameter is available when the moving effect is not 

Static. 

 Infinite Scroll: Set whether the scrolling text should seamlessly connect. 

− Checked: The scrolling text will seamlessly connect the end of one sequence with the 

beginning of the next. If selected, you must also set Space, which defines the spacing 

between the end of one scroll and the start of the next. 

− Unchecked: The text will complete one scroll before starting the next. 

Step 11 Click OK to complete the OSD settings. 

Once the OSD is added, it appears as Tools in the media library.   

 Right click the added OSD and select Edit to modify the created OSD. 

 Right click the added OSD and select Create Copy to make a duplicate of the OSD. 

Add Virtual Lights 

A virtual light source can be played as independent media. 

Step 1 In the Library area, right click the blank area and select More Tools > Add Virtual Light 

Step 2 In the dialog box that appears, configure the relevant parameters for the virtual light source 

and click OK. 

After successful addition, the virtual light source will be displayed in the library. 
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Figure 4-3 Add virtual lights 

 

Add Test Patterns 

The Kompass FX3 Pro offers robust functionality for adding custom test patterns. Users can 

flexibly generate precise test patterns based on the actual condition of the current display. 

These patterns include precise geometric shapes (such as lines, grids, and circles), detailed color 

and brightness presentations, ideal for on-site screen debugging. 

Step 1 In the media library area, right click the blank area or a specific media item, choose More 

Tools > Add Test Pattern to enter the test pattern addition interface. 
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Figure 4-4 Add test patterns 

 

Step 2 In the Layer Settings and Display Content Personalization sections on the right, you can 

configure the properties of the custom test pattern and change the style of the test pattern. 

Each setting will display a real-time test effect image on the left. 

Step 3 Click OK to complete the settings and add the custom test pattern. After the addition, the test 

pattern will appear in the media library. 

Media Optimization 

When the size of the added media file exceeds the graphics card processing capabilities, the 

media type will display as Optimizable. For convenience in subsequent use, you can use this 

function to modify the media resolution in advance. 

 

Only videos and images can be optimized, and the resolution must be even numbers. 
 

Step 1 In the media library, select the image or video you need to optimize. 

Step 2 Right click the media file and select Media Optimization. 

Step 3 Set the media optimization options based on the interface instructions. 
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Figure 4-5 Media optimization 

 

 Coding: Set the video encoding format, supporting Adaptive, h264, h265, vp9, and hap 

formats. When set to Adaptive, transcoding follows the original video encoding. 

 Quality: The image quality after video transcoding can be set to Low, Medium, or High. 

− Low: The transcoded video is more blurred compared to the original. 

− Medium: The transcoded video quality is between high and low. 

− High: The transcoded video is close to the original quality. 

 Code Rate: Set the video bitrate after transcoding, supporting Adaptive and Custom. 

− Adaptive: Consistent with the original video bitrate 

− Custom: Input the desired bitrate for transcoding. 

 Frame Rate: Set the frame rate of the media after optimization. The options include 

Adaptive, 24, 25, 29.97, 30, 50, 59.94, 60, and 120. 

Adaptive: Matches the original video frame rate. 

 Audio: Set the audio transcoding mode, supporting AAC, Copy, or No Audio. 

− AAC: Re-encode the original audio in AAC format. 

− Copy: Retain the original audio in the video. 

− No Audio: Output video without audio. 

 Resolution: Set the resolution size of the transcoded video. 

− W: Set the horizontal size. Default: 1920; recommended maximum: 8192. 
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− H: Set the vertical size. Default: 1080; recommended maximum: 8192. 

− If set resolution exceeds the original media, it defaults to the original resolution. 

 GPU Acceleration: Toggle GPU acceleration during media optimization. 

Step 4 Click Optimize to automatically perform optimization. 

Manage Media 

Rename Media 

 Right click the media file or folder you want to rename, select Rename to activate the editing 

for the media or folder name, and enter a custom name. 

 Double click the media or folder name area to activate the media or folder name editing, and 

enter a custom name. 

Delete Media 

There are the following ways to delete the media. 

 In the media library, select the target media and click . 

 In the media library, right click on the media you want to delete and select Delete. 

 When deleting a folder, all media within the folder will be deleted as well. 

Manage Media 

You can create folders to categorize and manage the imported media. 

 Right click the media library area, select Insert Folder and enter a folder name to create a 

folder. 

 Select the media files and drag them into the folder to categorize and manage them. 

 Hold down the Shift key or Ctrl key, select the files you want to manage in a new folder. 

Right click and select Insert Folder, and enter a name for the newly inserted folder to 

complete the file categorization and folder creation. 

 Drag the file or folder to sort it. 
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Manage Input Sources 

The input sources support streaming media sources, NDI input sources, capture card input 

sources and more. The system automatically recognizes and adds capture card input sources, 

which can be disabled as needed. 

Add Capture Card Sources 

The software supports acquiring input source images and audio via capture cards. The capture 

cards listed in the following table have undergone rigorous compatibility testing to ensure a 

stable and reliable experience. 

Table 4-1 Recommended capture cards 

Brand Model Connector Type 

Blackmagic 

Design (BMD) 

DeckLink·8K·Pro·Mini 4x 12G-SDI 

DeckLink·Mini Recorder 4K 1x 6G-SDI, 1x HDMI 1.4, choose one 

YUAN High-Tech SC542N4 4x HDMI 1.3 

Chuangshi Zhixing CSZX-8002HDMI_20220430 2x HDMI 1.3 

Tianchuang 

Hengda 

TC-410N2 2x HDMI 1.4 

TC542N2 2x HDMI 1.3 

Baoshi SC0720 4x HDMI 2.0 

Figure 4-6 Capture card connection 

 

Prerequisites 

 The capture card and its drivers are installed on the media server with Kompass FX3 Pro. 

 Connect the input source to the capture card using the appropriate video cable. 
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Operating Procedure 

Step 1 Select the Input Sources tab on the right pane to enter the input source interface. 

Step 2 Click Capture Device to expand all input sources connected to the capture card. 

The system will automatically recognize and name all connected input sources. You can double 

click the name to modify it. 

Step 3 Click the video format dropdown below the name to modify the video format captured by the 

card. 

Video format: 3840×2160@60.00, yuyv422, where 3840×2160@60.00 is the input resolution, 

and yuyv422 is the video sampling rate. 

Table 4-2 Sampling rate description 

Format Description Common Uses 

yuyv422 YUV4:2:2 format, with interlaced 

storage of brightness (Y) and chroma 

(UV) components, sharing a set of UV 

values for every two pixels 

Camera capture, video conferencing, 

video capture cards 

rgb32 32-bit RGB format (with Alpha 

channel), where each pixel occupies 4 

bytes (R, G, B, A) 

Graphics processing, screen capture, 

image editing 

rgb24 24-bit RGB format, with each pixel 

occupying 3 bytes (R, G, B), no Alpha 

channel 

Image storage, video rendering, 

computer vision 

nv12 YUV4:2:0 format, with separate storage 

of brightness (Y) and interlaced 

storage of UV components (half 

resolution) 

Video codec H.264/H.265, GPU 

accelerated processing 

uyvy422 YUV4:2:2 format, similar to YUYV422 

but with a different byte order (UYVY 

instead of YUYV) 

Video capture, digital video interfaces 

(e.g., HDMI capture) 

Click  or  at the top right of the capture source to enable or disable the capture card 

thumbnail view. Click the icons next to Capture Device to enable or disable all capture card 

thumbnail views. 
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Add Streaming Media 

The streaming media can be added as an input source. RTSP and RTMP formats are supported. 

Step 1 Click the Input Sources tab on the right pane to enter the input source configuration interface. 

Step 2 Click  next to Streaming Media or right click the blank area and select Add Steaming 

Media to pop up the streaming media adding dialog box. 

Figure 4-7 Add streaming media 

 

Step 3 Enter the name of the streaming media. 

Step 4 Enter the media path. 

The media path must start with rtsp:// or rtmp://. 

Step 5 Click OK to complete adding the streaming media. 

Add NDI Sources 

After the successful installation of Kompass FX3 Pro, it includes the installation of the NDI 

configuration tool - NDI Sender. Once NDI Sender is enabled, Kompass FX3 Pro will 

automatically search for all computers with NDI senders enabled on the current network 

segment. 

Prerequisites 

 The computer with the NDI sending device must be on the same network segment as the 

media server or host where Kompass FX3 Pro is located. 

 Ensure that the computer with the NDI sender can communicate normally with the media 

server or host where the Kompass FX3 Pro is located. 
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NDI Configuration 

Step 1 Double click NDI Sender.exe to enable the NDI sender. 

Figure 4-8 NDI Sender interface 

 

Step 2 Set the position and size of the screen on the computer to be used as NDI. 

There are two ways to set the position and size of the NDI image. 

 Click Select ROI and hold down the left mouse button to make a selection on the screen. 

 In the Sent ROI area, precisely set it using the region coordinates and region size. 

− x: The horizontal starting position of the top left corner of the NDI image relative to the 

screen. 

− y: The vertical starting position of the top left corner of the NDI image relative to the 

screen. 

− w: The horizontal width of the NDI image. 

− h: The vertical height of the NDI image. 

After setting up, click Show ROI to view the NDI output screen. 

Step 3 Enter the name of the NDI source in the Name section. 

Step 4 When the computer outputs to multiple screens, select the screen you want to use as the NDI 

display from the dropdown menu in the Screen section. 

Step 5 Enter the frame rate of the NDI image in the FPS section, with a default value of 25. 

Step 6 Click Start to complete the NDI Sender configuration. 

Add NDI Sources 

Step 1 Click the Input Sources tab on the right pane to enter the input source configuration interface. 
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Step 2 Click  next to NDI or right click the blank area and select Add NDI Media to pop up the 

NDI adding dialog box. 

The system will automatically search for all sources with NDI sending enabled on the current 

network and open the NDI network screen list. 

Figure 4-9 NDI network screen 

 

Step 3 Select the NDI network screen you want to add. 

Step 4 Modify the name of the NDI source in the Receiver section. 

Step 5 Click OK to complete adding the NDI input source. 

Click Refresh to retrieve the list of NDI sources on the current network segment again. 

Add Webpage Sources 

Kompass FX3 Pro supports adding the webpages as input sources. 

Prerequisites 

The computer running the software is connected to the network. 

Operating Procedure 

Step 1 In the Media Library area, select the Input Sources tab. 

Step 2 Click  next to Webpage to open the webpage adding window. 
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Figure 4-10 Add webpages 

 

Step 3 Enter the desired webpage name in the Resource area. 

Step 4 Select the display mode for the added website in the Mode area. The options include Native 

and Screenshot. 

 Native: During playback, the stage editing area does not provide a preview. Instead, it is 

displayed directly on the extended screen, and the output image can be controlled using the 

mouse. 

When the resolution of the added webpage exceeds the processing capability of the media 

server's graphic card, it is NOT recommended to use the native mode. Moreover, in native 

mode, the same webpage media should not be added to multiple layers within the same 

program. 

 Screenshot: During playback, the software captures the image from the webpage window 

and renders it onto the display screen connected to the connector, and allows for the image 

to be cropped if needed. 

Step 5 Enter the tab name in the left text box in the Website URL area. 

Step 6 Enter the complete domain name in the right text box. 

Step 7 Click Add Tab to add a new tab page. 

Step 8 Enter the tab name and domain name of the new tab page. 

Step 9 Click OK to enter the added website. 
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Figure 4-11 Website page (native mode) 

 

If the screenshot mode is selected, when a super-large browser image is added, which exceeds 

the processing capacity of a single graphics card on the media server, you can crop the browser 

image to several parts and then mosaic them together in the program to finally display the 

whole webpage content. 

You can complete the webpage cropping configuration using the following parameters: 

 X: Sets the starting horizontal coordinate for the cropping, based on the top-left corner. 

 Y: Sets the starting vertical coordinate for the cropping, based on the top-left corner. 

 W: The horizontal width of the cropped image. 

 H: The vertical height of the cropped image. 

 Apply: Click Apply to make the parameters take effect. 

 Webpage Output: Adjust the size of the output webpage by selecting an output resolution. 

 Inspection: Click Inspection in the upper right corner. The system will automatically analyze 

the current webpage, and upon completion, the detection results will open automatically. 

 

If the webpage resolution is too large, drag the thumbnail in the bottom right to select the crop 

area. 

 Hold the spacebar to drag the bottom right canvas. 

 Hold the Ctrl key and scroll the mouse to zoom in or out of the bottom right canvas. 
 

Step 10 Click × at the top right corner to close the website. 
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 When multiple tabs are opened, the tab where you stay on before closing the website will be 

used as the input source. 

 If you opened other website pages and the new page is displayed on the new tab, the 

system automatically adds the new tab page. 

 If you require long-time webpage playback, it is advisable to configure software to 

automatically restart at scheduled intervals via Settings > System Settings, in order to 

periodically clear the webpage cache. 
 

Add Spout Media 

Spout is a video frame sharing technology for Microsoft Windows. It enables the output of one 

application to serve as the input source for another application on the same computer. 

Prerequisites 

The Spout sender and receiver must be running on the same computer and must use the same 

discrete graphics card. 

Operating Procedure 

Step 1 In the main interface, select the Input Sources tab on the right side. 

Figure 4-12 Input sources 

 

Step 2 Click  next to Spout Media. 

Step 3 In the dialog box that appears, select the desired Spout sender from the list and click OK. 

If necessary, click Refresh to update the list of available senders. 
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Figure 4-13 Add Spout media 

 

Clear Input Sources 

Step 1 Click the Input Sources tab on the right pane to enter the source configuration interface. 

Step 2 Right click the blank area and select Clear Input Sources. 

Figure 4-14 Clear input sources 

 

Step 3 (Optional) Select Clear the input sources in use. 

Step 4 Click OK to clear all input sources except the capture card. 

Output Control 

Kompass FX3 Pro allows backend device control through control commands. It is recommended 

that only trained professionals perform the operation. 

Add Output Control 

Step 1 Click the Output Control tab on the right pane. 
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Step 2 Click  in the upper right corner or right click in the blank area and select Add Output 

Control. 

Figure 4-15 Add output control 

 

Step 3 Enter the command name in the text box next to Name. 

Step 4 Choose the target device to be controlled in Device. 

Step 5 Enter the IP address of the device to be controlled in IP. 

After completing the entry, click Test to test the network connection and verify connectivity. 

 A green box indicates a normal network connection between Kompass FX3 Pro and the 

target device. 

 A red box indicates a network connectivity issue, necessitating troubleshooting of the 

network configuration or hardware. 

Step 6 Select the communication protocol, either TCP or UDP. 

When Custom Device is selected, the communication protocol can be configured. 

Step 7 Enter the external control port number in Port. 

Step 8 Choose the command's control type in Type. 

Step 9 Select the encoding format of the command in Encoding. Options include HEX, ASCII, and 

JSON. 

When Custom Device is selected, the communication protocol can be configured. 

 HEX: The command is in hexadecimal format. 

 ASCII: The command is text-based. 

 JSON: The command is in json format. 
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Step 10 Enter the specific command corresponding to its type in Command. 

For the JSON encoding type, click Browse to upload a JSON file. 

Step 11 Click OK to complete adding a command. 

Once added, drag the output control to the program or timeline to add and send commands. 

Edit Output Control 

Once output control has been added, it can be edited and modified as needed. 

Modify Output Control Command Information 

Step 1 Right click the output control command to be modified and select Edit Output Control to open 

the editing interface. 

Alternatively, double click the control command to access the interface. 

Figure 4-16 Edit output control 

 

Step 2 Make the necessary modifications to the information of the command. 

Step 3 Click OK to complete the command modification. 

Rename Output Control Commands 

The name of an output control command can be changed in the following ways: 

 In the modification interface, give a new name in the Name field. 

 Right click the command to be renamed in the Output Control tab interface, select Rename, 

and enter the new name. 
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Delete Output Control 

Delete Single Command 

 Click the output control command to be deleted in the Output Control tab interface, then 

click  at the top right to delete it. 

 Right click the command and select Delete to delete it. 

Delete Multiple Commands 

 Right click the blank area in the Output Control tab interface and choose Clear Output 

Control to delete all added commands. 

 Press and hold Ctrl or Shift while selecting multiple commands, then click  to delete the 

selected commands. 

Edit Outputs 

Before editing the outputs, in order to ensure synchronization of the outputs, please refer to 

the procedure described in Graphics Card Mosaic to complete the graphics card output mosaic 

configuration. 

Kompass FX3 Pro supports output editing, allowing you to mosaic multiple output connectors 

for seamless output. 

In the menu bar, navigate to Output > Screen to enter the output management interface. 
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Figure 4-17 Screen management 

 

 : The output connection for the selected connector is already enabled. Click to 

disconnect the current connector's output connection. 

 : The output connection of the selected connector is disabled. Click to connect the 

current connector. 

 : The output identify function is enabled. Click to disable it. 

 : The output identify function is disabled. Click to enable it. 

 : Delete the selected output. 

 : Revert the most recent or multiple actions to restore the content to its previous state. 

 : Reinstate actions that were just undone. 

 : Click to hide text display in the stage editing area or screen management. After hiding, 

the icon changes to . At this time, the slices in the stage editing area will only show 

images, with no text. Click it again to display the text information. 

 : Click to display the output screens in the editing area with the best perspective. 

 : Click to restore the editing area to the top left corner. 
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 : Click to zoom in the editing area. 

 : Click to zoom out the editing area. 

 Press and hold the mouse wheel and drag to move the canvas. 

Add and bind outputs automatically 

When the software starts, it automatically detects the graphics card connectors, automatically 

adds the corresponding outputs, and completes the output and connector binding in sequence, 

displaying them all in the Output List area on the left. 

When changing the connection order of the computer output connectors and the backend 

devices, you can edit the output name, the binding relationship of the physical connector, and 

the output resolution in the Properties area on the right. 

Add and bind outputs manually 

When more graphics cards are installed on the control PC or you want to change the connector 

quantity in a saved project file, you can select to add the outputs manually. 

 

At most one screens can be bound. 
 

Click  at the top right of the output list. After the output is added, modify the relevant 

information in the Properties section on the right. 

 Name: Modify the current output name. 

 Bind Output: Configure the relationship between the currently edited output and the 

physical output connector of the actual device. 

When binding to a graphics card connector, it will display the graphics card name, 

connector, and connector output resolution. 

− 1: Indicates the connector number of the graphics cards, where 1 is the first connector 

of the card.  

− G1: Refers to the graphics card 1.  

− Graphics card model: Indicates the model of the current device's graphics card.  

− Not Recommended: Indicates that this connector is being used for the software 

interface display. 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− NDI Video Output: Outputs the current connector display via NDI. 

− Spout Video Output: Outputs the current connector display via Spout. 

 

When Bind Output is set to NDI Video Output or Spout Video Output, the current connector 

does not support output. 
 

 Resolution: Displays the output resolution of the connector. When Bind Output is set to a 

graphics card connector, this shows the physical resolution of the graphics card connector. 

 Size: Modify the output size. 

 Dynamic Range: Configure the video output format, supporting both SDR and HDR. When 

set to SDR, the video is output in the SDR format; when set to HDR, it is output in the HDR 

format. 

Split Outputs 

Output Segmentation 

Output segmentation divides an output into multiple sub-outputs, enabling the splitting and 

reassembly of the display image, which facilitates the construction and management of irregular 

screens. 

Step 1 Navigate to Output > Screen, then select the output in the output list on the left or click an 

output in the Edit area. 

Step 2 In the Output Segmentation section on the right, select the desired segmentation method from 

the listed ones. 
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Figure 4-18 Output segmentation 

 

 Layout: 

− : 1x sub-output 

− : 2x sub-outputs in horizontal direction 

− : 3x sub-outputs in horizontal direction 

− : 4x sub-outputs in horizontal direction 

− : 2x sub-outputs in vertical direction 

− : 4x sub-outputs in a grid pattern 

− : 3x sub-outputs in vertical direction 

− : 4x sub-outputs in vertical direction 

− : Custom sub-outputs 

− : Add a sub-output. Add one sub-output with each click, and use the size of the first 

sub-output for the addition. 

− : Delete the selected sub-output. 

 Output segmentation control: 
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− : Revert the most recent or multiple actions to restore the content to its previous 

state. 

− : Reinstate actions that were just undone. 

− : After moving the canvas, click this button to reset the canvas to the top-left 

corner. 

− : Click to zoom in the output area display. 

− : Click to zoom out the output area display. 

− : Click to enlarge the sub-output and expand it to the editing area. After expansion, 

click  in the top-right corner of the editing area or click Restore Canvas to revert 

the zone. 

 Press and hold the mouse wheel and drag to move the position of the canvas. 

Sub-Output Rearrangement 

Sub-output rearrangement refers to reorganizing the output segmentations as needed. 

Under the Screen tab, drag the sub-outputs to rearrange them. 

Figure 4-19 Rearrange sub-outputs 
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In the Sub-Output Properties section on the right, modify the relevant information for the 

selected sub-output. 

 Name: Modify the sub-output name. 

 Bind Input: Bind the current output or sub-output to the corresponding layer. Once bound, 

the sub-output will consistently display the content from the associated layer. 

Apply to All: Apply the layer from the current bound input to all sub-outputs of the current 

output. 

 Position: Adjust the position of the sub-output on the screen based on the top left corner of 

the stage. 

− X: The horizontal starting coordinate of the sub-output or output on the entire stage 

− Y: The vertical starting coordinate of the sub-output or output on the entire stage 

 Size: Set the size of the sub-output. 

− W: The width of the sub-output or output 

− H: The height of the sub-output or output 

 Rotate: Adjust the rotation angle of the sub-output or output in a clockwise direction. 

EDID Quick Tool 

Once the output configuration is complete, use the EDID Quick Tool to lock and export all 

output EDIDs.   

Right click the EDID Quick Tool  icon in the desktop's lower-right toolbar to open the 

menu. 

Figure 4-20 EDID tool 

 

 Lock EDID: Instantly lock all connected output connector EDIDs to prevent display order 

confusion or resolution anomalies due to connector reconnection, signal interruption, or 

system reboot. Shortcut: Ctrl+Alt+Shift+L. 
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 Unlock EDID: Unlock all previously locked connector EDIDs. Shortcut: Ctrl+Alt+Shift+U. 

 Export EDID: Instantly export EDIDs from all connected output connectors to the local 

desktop, automatically creating an EDID folder. Shortcut: Ctrl+Alt+Shift+E. 

 Language: Switch the EDID Quick Tool menu interface language between English and 

Simplified Chinese. Shortcut: Ctrl+Alt+Shift+S. 

 About: View version information for the EDID tool. 

 Exit: Exit the EDID Quick Tool. 

Edit Program Layers 

Before starting program editing, media files need to be imported into the layers. 

Add Program Media 

Layers are used to store media files in the program. Click  in the top right corner of the 

Program area to add a layer. 

 

At most 20 layers can be added. 
 

Select the target media file in the media library, click and hold the left mouse button to drag it 

to the corresponding layer of the program to add the layer to the program. 

Figure 4-21 Edit program layers 
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If an encrypted video (.nvf) file is added to the media library, entering a decryption password is 

required to play the video when adding it to a program. If the encrypted video exceeds its 

encryption duration, it will not be playable. 
 

Configure Program Media Properties 

Configure the basic media properties, playback method, display settings, and image quality 

parameters. 

Step 1 Click the media in the program to select it. 

Step 2 Select the Properties tab on the right pane to enter the media properties interface. 

Basic 

Figure 4-22 Media properties - basic 

 

 Name: View or modify the media name. 

 Media: View the media duration. 

 Duration: Set the playback duration for this media. 

− If the playback duration is longer than the media duration, the media will automatically 

replay. 

− If the playback duration is shorter than the media duration, the media will play for the 

set duration, and any unplayed content will not be shown. 

 Start Time: Set the start time for media playback. The start time value cannot be greater 

than the media duration value. 

 End Time: Set the end time for media playback. The end time value must be greater than the 

start time value and cannot be greater than the media duration value. 
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 Delay Start: Set the delay duration for media playback, meaning how long after the program 

starts the media will begin to play. 

 Click  next to each parameter to reset the value to default. 

Playback 

Figure 4-23 Media properties - playback 

 

 End Action: Set how the current media plays after the program ends. 

− Loop: Loop the media in the current layer, with an icon  displayed in the top right. 

− Last Frame: Stop at the last frame after one playback, with an icon  displayed in 

the top right.  

− Stop: Stop playing after one playback, with an icon  displayed in the top right. 

− Loop Count: Set the loop count for the current media, with an icon  displayed in 

the top right. 

 Jump: Set how the current media plays after finishing. 

− No Jump: Do nothing after the media finishes playing. 

− Program Loop: The media plays in a loop. 

− Next: Jump to the next program after playback, with an icon  displayed in the top 

right. 

If a specific program is set for jumping, here the group's name and the program name 

after jumping will be displayed, with an icon  displayed in the top right of the 

media. 

 Transition: Set the transition effect for switching media in the program layer. Currently only 

supports Cut. 

 Media Keep: When on, the program resumes from the last played position; when off, the 

media restarts from the beginning. 
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 Volume: Adjust the output volume of the media. Click  to mute the media. 

Graphics Card Mapping 

Figure 4-24 Media properties – GPU mapping 

 

 Device: The media is output from this device. 

 In Use: View the graphics card currently used by the media. 

 GPU: Set the graphics card for rendering the selected media. 

Check Auto Select for the system to choose automatically, or uncheck to manually select a 

graphics card. Click Apply to complete the graphics card switching. 

Image 

Figure 4-25 Media properties - image 

 

 Flip: Configure the media image flipping. 

Uncheck the checkboxes for H and V and the output image will be displayed normally 

without flipping. 

− H: Flip the output image horizontally. 

− V: Flip the output image vertically. 

 Fill: Select the way how the content of a layer is displayed. 

− Fill: The media image fills the entire layer. 

− Proportional: The layer image is scaled proportionally and displayed within the layer. 
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 Accurate Seek: Enable this feature to quickly jump to a specific time point in a video or audio 

file without needing to gradually drag the progress bar to search. 

 Y/C Stretch: When enabled, the bright areas of the output image become brighter, and the 

dark areas become darker. 

 AI Super-Resolution: When the media's original resolution is lower than the output 

resolution, enabling this feature utilizes AI super-resolution processing to enhance the 

image's resolution and clarity. Currently supports upscaling content with a maximum native 

resolution of 4K to 8K output. 

 

The following graphics card models support the AI super-resolution feature: RTX 4000, RTX 

5000, RTX A4000, RTX A4500, RTX A4500 Ada, RTX A5000, RTX A6000, and RTX A6000 Ada. 
 

Color 

Figure 4-26 Media properties - color 

 

 Brightness: Adjust the overall brightness of the output image. The value range is -100 to 

100, with a default value of 0. 

 Contrast: Adjust the overall contrast of the output image. The range of values is -100 to 100, 

with a default value of 0. 

 Opacity: Adjust the opacity of the output image, with 0% being completely transparent and 

100% being opaque. The default value is 100%. 

 Hue: Adjust the color offset of the output image. The range of values is -100 to 100, with a 

default value of 0. 

 Saturation: Adjusts the vividness of colors of the output image. The value range is -100 to 

100, with a default value of 0. 

 Click  next to each parameter to reset the value to default. 
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AI Quality 

Figure 4-27 Media properties - AI quality 

 

 Enhanced Mode: Optimizes the color, brightness, and contrast to produce a higher-quality 

image. 

 Fidelity Mode: Optimizes the textures such as skin, hair, and edges to achieve a more realistic 

representation. 

 

The following graphics card models support the AI quality feature: RTX 4000, RTX 5000, RTX 

A4000, RTX A4500, RTX A4500 Ada, RTX A5000, RTX A6000, and RTX A6000 Ada. 
 

Crop 

Figure 4-28 Media properties - crop 

 

 Mode: Select the cropping method. 

− Stretch: Scale up or down the output image. 

− Crop: Crop the output image. 

− Proportional: Scale down the output image proportionally. 

 Crop By: Set the parameter unit for cropping. 

− Proportional: The proportion of the image cropped from the entire image 

− Pixel: The pixel dimensions for cropping the image 

 T: Set the size of the area at the top of the media image that is cropped. 

 B: Set the size of the area at the bottom of the media image that is cropped. 

 L: Set the size of the area at the left of the media image that is cropped. 
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 R: Set the size of the area at the right of the media image that is cropped. 

Borders 

Figure 4-29 Media properties - borders 

 

 Color: Configure the border color of the media. 

Toggle the switch to activate the border function for the media. 

Set the border color using the following four methods. 

− Click the color picker tool and click to select the desired color. 

− Click the color block and select a color in the pop-up box. 

− Enter the color code value after the # symbol. 

− Double click the values next the RGB values and enter the value for each RGB 

component to precisely specify the color. 

− Modify the value next to A to adjust the opacity of the borders. 

100 is fully opaque, and 0 is completely transparent. 

 Unit: Set the size unit of the border. 

− Proportional: The border size as a percentage of the media size 

− Pixel: The border size in pixels 

 Width: Set the width of the borders. 

− Proportional: Adjust the border width by setting the border size as a percentage of the 

media size, ranging from 0% to 100%. 

− Pixel: Adjust the border by specifying how many pixels it occupies to set the border 

width, ranging from 0px to half the minimum of either the width or height of the media. 
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Keying 

Figure 4-30 Media properties - keying 

 

 Color: Key out the specified color from the selected media. 

Toggle the switch to activate the keying function for the media. 

There are four methods for specifying the keying color. 

− Click the color picker tool and click to select the desired color. 

− Click the color block and select a color in the pop-up box. 

− Enter the color code value after the # symbol. 

− Double click the values next the RGB values and enter the value for each RGB 

component to precisely specify the color. 

 Matte Strength: The higher this value, the stronger the keying range/color correction. When 

you need to accurately key out a color in an image, it is recommended that this value is set 

to smaller than 10%; in other cases, more than 50% is recommended. 

 Shadow Adjust: The higher this value, the cleaner the noise areas in the shadow of the 

foreground are keyed out. 

Configure Program Layer Properties 

Select a layer, and navigate to the Properties tab on the right side to configure the layer 

properties. 

In the layer properties, the properties of all media within the layer can be adjusted. 
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Figure 4-31 Layer properties 

 

Area Function Description 

Basic Layer name View and modify the layer name. 

Layer control Set whether the layer is visible or locked 

 Close: Close all media visuals in the layer and only play the 

media audio. 

 Lock: Once the selected layer is locked, you cannot add 

programs to, delete media from, or perform other actions 

on that layer for other programs. 

Layer volume Adjust the media output volume of this layer. 

Click  to mute the all media in that layer. 

GPU Mapping Device The media is output from this device. 

GPU Set the graphics card for rendering the selected media. 

Check Auto Select for the system to choose automatically, or 

uncheck to manually select a graphics card. Click Apply to 

complete the settings. 
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Area Function Description 

Image Flip Configure the all media image flipping within this layer. 

Uncheck the checkboxes for H and V and the media image 

will be displayed normally without flipping. 

 H: Flip the media image horizontally. 

 V: Flip the media image vertically. 

Fill Select the way how the content of a layer is displayed. 

 Fill: The media image fills the entire layer. 

 Proportional: The layer image is scaled proportionally and 

displayed within the layer. 

Color Brightness Adjust the overall brightness of the layer image. The value 

range is -100 to 100, with a default value of 0. 

Contrast Adjust the overall contrast of the layer image. The range of 

values is -100 to 100, with a default value of 0. 

Opacity Adjust the opacity of the layer image, with 0% being 

completely transparent and 100% being opaque. The default 

value is 100%. 

Hue Adjust the color offset of the layer image. The range of values 

is -100 to 100, with a default value of 0. 

Saturation Adjusts the vividness of colors of the layer image. The value 

range is -100 to 100, with a default value of 0. 

AI Content 

Violation 

Detection 

Enable  On: Turn on the detection feature, and the system performs 

illegal and non-compliant content detection on media. 

 Off: Turn off the detection. 

Safe Image When illegal or non-compliant content is detected, a safe 

image is displayed in full screen. 

 Preset Image: Display a pre-defined safety image provided 

by the software. 

 Custom Image: Display a custom safety image uploaded by 

the user. When this option is selected, an Upload button 

will appear on the interface. 

 Black Screen: Display a black screen. 

Sound Channel 

Mapping 

Passthrough When the backend audio device is a surround sound system, 

Passthrough must be enabled. Once set, restart the software 

for changes to take effect. 

 On: In program management, select the media and choose 
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Area Function Description 

the audio track under Properties > Sound Channel 

Mapping > Sound Track. Once turned on, non-Dolby audio 

media will be unable to output audio. 

 Off: No need to set the sound track, and audio output 

proceeds directly. In this case, Dolby audio media will not 

output properly through the surround sound system. 

Layer Channels Set the number of audio signal tracks in the layer. 

Sound Card Choose which sound card on the current device to use for 

audio output. 

Channel Control the signal mapping and mixing between channels. 

Click the corresponding cells in the audio matrix to map input 

and output channels. 

Insert Layer Above Insert a layer above the current layer. 

Insert Layer Below Insert a layer below the current layer. 

Delete Layer Delete the current layer and the data within it. 

Clear Media Clear all data in the layer. 

Context Menu of Program Layer Media 

Right click the layer media to display the context menu. 
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Figure 4-32 Layer media context menu 

 

 Play: Play the media in the current layer. 

 Pause: Pause the media playback. 

 Stop: Stop the media playback. 

 Cross Program Continuation: The same media file plays on the same layer across multiple 

consecutive programs. When switching programs within the continuous program range, the 

media plays normally without interruption or restarting. 

 Cancel Continuation: Once Cross Program Continuation is set, this function becomes 

available, cancel media continuation across programs. 

 Rename: Change the name of the media in the program. 

 Jump: Set the switch mode after the current media has finished playing. 

− Media Loop: Loop the media in the current layer, with an icon  displayed in the 

upper right corner of the layer. 

− Last Frame: When the current media playback is completed once, it stops at the last 

frame. After the setting is completed, an icon  is displayed in the upper right corner 

of the layer. 

− Stop: After the current media plays once, stop playback and display an icon  in the 

upper right corner of the layer. 
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− Program Loop: When the media playback ends, the program restarts. 

− Next Program: After the current media finishes playing, it will automatically jump to the 

next program, with an icon  displayed in the upper right corner of the layer. 

− Jump to Specific Program: After the current media finishes playing, automatically jump 

to the specified program, with an icon  displayed in the upper right corner of the 

layer. 

− Apply to All: Apply the current media jump mode to all other media in the current layer. 

 

When a program has multiple media with different skip modes set, the skip mode of the media 

that finishes playing first will take precedence. 
 

 Media Keep: Once enabled, when switching back to the program, this media will resume 

playing from where it left off. 

 Cancel Media Keep: After cancelling the media keep, when switched to this program, the 

media will restart from the beginning. 

 Copy: Copy the currently selected media and media properties. Shortcut key: Ctrl+C. 

 Cut: Cut the currently selected media or media properties. After cutting, the layer media in 

this program will be deleted. Shortcut key: Ctrl+X. 

 Paste: Paste the copied or cut media and media properties into the selected program. 

Shortcut key: Ctrl+V. 

 Copy Properties: Copy the currently selected media properties, including media properties 

and media slice properties. 

 Paste Properties: Quickly modify media properties in other programs by pasting the selected 

media properties to the media in other programs. 

 Locate Media: Find the media in the media library. 

 Access File Location: Open the storage location of the current media on the media server. 

 Delete Media: Delete the currently selected media. 

Configure Program Properties 

In the program management area, select the desired program. On the right pane under 

Properties, you can modify the program properties. 
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Figure 4-33 Program properties 

 

Table 4-3 Program properties 

Area Function Explanation 

Basic Program name View or modify the program name. 

Play Keep media After enabled, when the program switches back, it will continue 

playing from the last position; after disabled, when the program 

switches back, the media will start playing from the beginning. 

Transition effect Set the transition effect for program switching. The options 

include Cut and Fade. For the fade in and fade out transitions, 

you can set the fade duration, with the default value of 0.5s. 

Slice layout  Lock: Lock the slice layout style in the selected program. 

 Apply to All: Apply the slice layout style from the selected 

program to all other programs. 

 Create Copy: Duplicate the slice properties from the current 

program, allowing other programs to load the slice by 

selecting the program. 

Image Brightness Adjust the brightness of the output image in the program. The 

value range is -100 to 100, with a default value of 0. 

Contrast Adjust the contrast of the output image in the program. The 

value range is -100 to 100, and the default value is 0. 

Insert Program Before Insert a program before the current program. 

Insert Program After Insert another program after the current program. 

Delete Program Delete the currently selected program. 
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Cross Program Continuation 

When the same media needs to be played at the same layer position for multiple consecutive 

programs, adding the same media to each program individually will cause the media file to start 

over upon switching programs. By using this feature, this issue can be perfectly resolved, 

allowing the continued media to play normally without restarting when switching programs. 

Step 1 In the program management area, right click the media that needs to be continued, and select 

Cross Program Continuation. 

Figure 4-34 Cross program continuation 

 

Step 2 Click and hold the left mouse button on the media, then slide left or right to the target program 

where you want to continue. 

 

After completing the media cross program continuation setup, right click the media across 

programs and select Cancel Continuation to remove the continuation setup. 
 

Program Context Menu 

Right click the program to display the program context menu. 
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Figure 4-35 Program context menu 

 

 Play: Play the current program. 

 Stop: Stop the program playback, and when played again, the media in the program will 

start from the beginning. 

 Pin Program: Place the selected program on the left most of the program list. The pinned 

program always remains displayed on the left side of the program list. 

 Cancel Pin to Top: Remove the current pinned program. 

 Apply to All: Apply the configured properties of the current program to other programs. 

 Enable Program Keep: After enabled, when switching back to the program, the program will 

continue playing from where it left off. 

 Disable Program Keep: After disabled, when switching to this program, the program plays 

again from the beginning. 

 Lock Slice Layout: Lock the current program's slice layout. Once locked, the slices in the 

editing area cannot be moved. 

 Unlock Slice Layout: Unlock the slice layout in the current program, allowing the slice in the 

editing area to be freely moved once unlocked. 

 Insert Current Program: Immediately play the current selected program and automatically 

pause the program that is currently playing. Once the interrupted program finishes, the 

paused program will automatically resume. 

− In the pre-edit mode, this function is not supported. 
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− This function is not supported during media collection playback. 

− This function is not supported during cross program continuation playback. 

− When multiple insertions are made, after the interrupted program finishes, it resumes 

playing from the program just before the last insertion, rather than returning to the 

program before the first insertion. 

− After the insertion, the program will display the currently playing content and the 

program name area of the interrupted program will be marked with a different color. 

 Rename: Change the name of the program. 

 Cut: Cut the currently selected program, including media from all layers within the program. 

Shortcut key: Ctrl+X. 

 Copy: Copy the currently selected program, including media from all layers within the 

program. Shortcut key: Ctrl+C. 

 Paste: Paste the copied or cut content into the selected program. Shortcut key: Ctrl+V. 

 Insert Program Before: Insert a program on the left side of this program. 

 Insert Program After: Insert a program on the right side of this program. 

 Delete Program: Delete the currently selected program. 

 Clear Media: Clear all media in the selected program. 

Edit Timeline Layers 

Add Timeline Media 

Step 1 Click Timeline to enter the timeline media management interface. 

Step 2 Select the target media file in the media library, click and hold the left mouse button, then drag 

it to the media area below the timeline to add the layer and media to the timeline. 
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Figure 4-36 Add timeline media 

 

The timeline will show the current media start time. Drag leftward or rightward to quickly adjust 

the media playback start time. 

Edit Control Commands 

Add Control Commands 

Adding control commands allows timeline positions to trigger playback control command. 

After adding timeline media, right click the timeline layer and select Add Control Command to 

open the control command interface. 

Figure 4-37 Add control command 

 

 Timeline Position: Set the specific time point on the timeline for the command trigger. 

 Execute Action: When reaching the trigger point, initiate the next playback control. Options 

include Jump to Next Clip, Jump to Specific Clip, Jump to Specific Time, Pause Playback, 

Loop Playback, and Play from Start. 

Modify Control Commands 

After adding a control command, a shortcut icon appears on the timeline layer. Different actions 

show different icons. Right click the shortcut icon and select Edit to open the control command 

editing interface. 
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Modify command details and click OK to complete the changes. 

Delete Control Commands 

 Delete single command: Right click the shortcut icon and select Delete to delete the selected 

control command. 

 Clear all commands: 

− Press and hold Ctrl, and select the shortcut icons on the timeline layer to select multiple 

command. Right click and select Delete to delete them. 

− Right click a shortcut icon on the timeline layer and select Clear All Commands to clear 

all commands. 

Configure Timeline Properties 

Step 1 Click Timeline to enter the timeline interface. 

Step 2 Right click the timeline and select Timeline Properties to enter the timeline properties interface. 

Figure 4-38 Timeline properties 

 

 Time Position: Set the start position for the first play in the timeline. 

 Total Duration: Set the overall length of the timeline. 

 : Reset the time value to default. 

Configure Timeline Media Properties 

Step 1 In the Timeline area, select the media. 

Step 2 In the Properties area on the right pane, configure the timeline media properties. 
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Basic 

Figure 4-39 Media properties - basic 

 

 Name: View or modify the media name. 

 Duration: View the media duration. 

 Playback: Set the playback duration for this media. 

− If the playback duration is longer than the media duration, the media will automatically 

replay. 

− If the playback duration is shorter than the media duration, the media will play for the 

set duration, and any unplayed content will not be shown. 

 Start Time: Set the start time for media playback. The start time value cannot be greater 

than the media duration value. 

 End Time: Set the end time for media playback. The end time value must be greater than the 

start time value and cannot be greater than the media duration value. 

 Time Position: Set the start playback time for the media on the timeline. 

 Click  next to each parameter to reset the value to default. 

Playback 

Figure 4-40 Media properties - playback 

 

 Transition: Set the transition effect for switching media in the timeline layer. Currently only 

supports Cut. 

 Volume: Adjust the output volume of the media. Click  to mute the media. 
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Graphics Card Mapping 

Figure 4-41 Media properties - GPU mapping 

 

 Device: The media is output from this device. 

 In Use: View the graphics card currently used by the media. 

 GPU: Set the graphics card for rendering the selected media. 

Check Auto Select for the system to choose automatically, or uncheck to manually select a 

graphics card. Click Apply to complete the graphics card switching. 

Image 

Figure 4-42 Media properties - image 

 

 Flip: Configure the media image flipping. 

Uncheck the checkboxes for H and V and the output image will be displayed normally 

without flipping. 

− H: Flip the output image horizontally. 

− V: Flip the output image vertically. 

 Fill: Select the way how the content of a layer is displayed. 

− Fill: The media image fills the entire layer. 

− Proportional: The layer image is scaled proportionally and displayed within the layer. 

 Accurate Seek: By enabling the function, users can quickly jump to a specific timestamp in a 

video or audio file without manually dragging the progress bar to search. 

 Y/C Stretch: When enabled, the bright areas of the output image become brighter, and the 

dark areas become darker. It is turned off by default. 
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 AI Super-Resolution: When the media's original resolution is lower than the output 

resolution, enabling this feature activates AI super-resolution processing, enhancing the 

image's resolution and clarity during playback. 

 

The following graphics card models support the AI super-resolution feature: RTX 4000, RTX 

5000, RTX A4000, RTX A4500, RTX A4500 Ada, RTX A5000, RTX A6000, and RTX A6000 Ada. 
 

Color 

Figure 4-43 Media properties - color 

 

 Brightness: Adjust the overall brightness of the layer image. The value range is -100 to 100, 

with a default value of 0. 

 Contrast: Adjust the overall contrast of the layer image. The range of values is -100 to 100, 

with a default value of 0. 

 Opacity: Adjust the opacity of the layer image, with 0% being completely transparent and 

100% being opaque. The default value is 100%. 

 Hue: Adjust the color offset of the layer image. The range of values is -100 to 100, with a 

default value of 0. 

 Saturation: Adjusts the vividness of colors of the layer image. The value range is -100 to 100, 

with a default value of 0. 

 Click  next to each parameter to reset the value to default. 

AI Quality 

Figure 4-44 Media properties - AI quality 
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 Enhanced Mode: Optimizes the color, brightness, and contrast to produce a higher-quality 

image. 

 Fidelity Mode: Optimizes the textures such as skin, hair, and edges to achieve a more realistic 

representation. 

 

The following graphics card models support the AI quality feature: RTX 4000, RTX 5000, RTX 

A4000, RTX A4500, RTX A4500 Ada, RTX A5000, RTX A6000, and RTX A6000 Ada. 
 

Crop 

Figure 4-45 Media properties - crop 

 

 Mode: Select the cropping method. 

− Stretch: Scale up or down the output image. 

− Crop: Crop the output image. 

− Proportional: Scale down the output image proportionally. 

 Crop By: Set the parameter unit for cropping. 

− Proportional: The proportion of the image cropped from the entire image 

− Pixel: The pixel dimensions for cropping the image 

 T: Set the size of the area at the top of the media image that is cropped. 

 B: Set the size of the area at the bottom of the media image that is cropped. 

 L: Set the size of the area at the left of the media image that is cropped. 

 R: Set the size of the area at the right of the media image that is cropped. 
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Borders 

Figure 4-46 Media properties - borders 

 

 Color: Configure the border color of the media. 

Toggle the switch to activate the border function for the media. 

Set the border color using the following four methods. 

− Click the color picker tool and click to select the desired color. 

− Click the color block and select a color in the pop-up box. 

− Enter the color code value after the # symbol. 

− Double click the values next the RGB values and enter the value for each RGB 

component to precisely specify the color. 

− Modify the value next to A to adjust the opacity of the borders. 

100 is fully opaque, and 0 is completely transparent. 

 Unit: Set the size unit of the border. 

− Proportional: The border size as a percentage of the media size 

− Pixel: The border size in pixels 

 Width: Set the width of the borders. 

− Proportional: Adjust the border width by setting the border size as a percentage of the 

media size, ranging from 0% to 100%. 

− Pixel: Adjust the border by specifying how many pixels it occupies to set the border 

width, ranging from 0 px to half the minimum of either the width or height of the media. 

Keying 

Figure 4-47 Media properties - keying 
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 Color: Key out the specified color from the selected media. 

Toggle the switch to activate the keying function for the media. 

There are four methods for specifying the keying color. 

− Click the color picker tool and click to select the desired color. 

− Click the color block and select a color in the pop-up box. 

− Enter the color code value after the # symbol. 

− Double click the values next the RGB values and enter the value for each RGB 

component to precisely specify the color. 

 Matte Strength: The higher this value, the stronger the keying range/color correction. When 

you need to accurately key out a color in an image, it is recommended that this value is set 

to smaller than 10%; in other cases, more than 50% is recommended. 

 Shadow Adjust: The higher this value, the cleaner the noise areas in the shadow of the 

foreground are keyed out. 

Edit Timeline 

Edit Clips 

Split Clips 

Kompass FX3 Pro supports splitting the timeline for playback, with individual clip looping 

supported. 

Step 1 Place the mouse on the timeline, right click to select the start point, and choose Split Clip to set 

the clip start time. 

Step 2 Right click to select the end point, choose Split Clip to set the end time. 

Step 3 Repeat the above steps to split additional clips. 

Merge Clips 

Merge adjacent clips. 

 Merge Forward: Right click the clip, and select Merge Forward to combine it with the 

previous clip. 
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 Merge Backward: Right click the segment, select Merge Backward to combine it with the 

next clip. 

Lock Clips 

Lock split clips. The clips cannot be merged after locked. 

Right click the clip, select Lock to lock the clip. 

Add Cue Tags 

Kompass FX3 Pro allows adding Cue tags on the timeline for visualizing specific points or 

events, aiding in navigation and timing control. 

Step 1 Right click the timeline and select Add Cue Tag to enter the tag addition interface. 

Figure 4-48 Add Cue tags 

 

Step 2 Enter the start time for the tag in the Time field, configuring the Cue tag position. By default, 

the timeline time at the mouse-click position is displayed by default. 

Step 3 Enter the tag name in the Marker field. The name can contain 1 to 10 characters. 

Step 4 Enter the comments in the Comment field. The comment support 1 to 50 characters. 

 

 After adding a Cue tag, it appears on the timeline. Right click the tag and select Edit or 

Delete as needed. 

 Press and hold the Alt key to move the tag left or right. Changes will sync automatically to 

the Cue table. 

 The Cue table displays the tag type, marker, and comment in real time. 

 If the timeline is locked, tags cannot be deleted or moved. 
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Configure Cue Tables 

Import and export tag configuration tables. 

Import Cue Tables 

Step 1 Right click the timeline, and select Configure Cue Table to access the Cue table interface. 

Figure 4-49 Configure Cue tables 

 

Step 2 Click Import, choose a pre-existing configuration file (.txt), and click Open to import. 

Export Cue Tables 

In the Cue table interface, click Export, select the storage path and file (.txt), and Save. 

Switch Cue Tags 

In the Cue table interface, click  to switch playback between Cue tags. The Cue table 

provides real-time feedback, such as the remaining time. 

 

 Only one Cue table can be active per project file. 

 Only one Cue table can be imported or exported at a time. 
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Configure Offset Time 

Time offset allows adjusting a media's starting position on the timeline by specifying a time 

value and offset direction (left/right). This operation provides accurate control over media 

placement by increasing or decreasing the defined offset time. 

Step 1 Right click the timeline, and select Offset Time. 

Figure 4-50 Configure offset time 

 

Step 2 Set the specific time in Cursor Position. 

Step 3 Select Backward or Forward in the Offset Direction section. 

 Backward: Media to the right of the cursor position moves to the right. 

 Forward: Media to the left of the cursor position moves to the left. 

Step 4 Set the offset time. 

Step 5 Click OK to apply the offset time settings. 

Configure Clip Properties 

Right click a clip, and select Clip Properties to view properties on the right. 

Figure 4-51 Configure clip properties 

 

 Name: Enter or change the clip name. 
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 Duration: View the clip duration time. The value updates automatically when the start time or 

end time of the clip is modified. 

 Start Time: The start time of the clip 

 End Time: The end time of the clip 

 

On the timeline, you can also drag the left or right ends of a clip to adjust its start time and end 

time. 
 

Configure Timecode 

The Kompass FX3 Pro supports external timecode for controlling timeline media playback, with 

LCT and MTC timecodes available. 

Navigate to Window > Timecode to open the timecode configuration interface. 

Figure 4-52 Configure timecode 

 

 Format: 00:00:00:00 represents HH:MM:SS:FF, meaning Hours: Minutes: Seconds: Frames. 

 Type: Configure the timecode type, supporting LTC and MTC. 

 Device: Choose the device in the system for playback control. After selection, the frame rate 

of the timecode will be automatically read. 

 Offset: Set the timecode offset in milliseconds (ms). 

 Follow: Enable or disable the follow function between the timecode and timeline. 

− When enabled, playback controls on the timeline are disabled, and the system 

automatically follows the timecode time for playback. 

− When disabled, playback and control via the timeline are possible. 
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Configure Effects 

Add Effects 

Click Effects Library on the right to open the effects interface. Drag an effect onto the media in 

slices, programs, or the timeline to add the effect. You can modify the effects in 

Properties >Effects.   

Figure 4-53 Add effects 

 

 Hover the mouse over an effect icon to preview its visual effect. 

 When applying multiple effects to the same object, the final result is affected by the order in 

which the effects are applied. 

 

Audio media and native-mode webpage media do not support the addition of effects. 
 

Configure Effect Properties 

After adding effects, click the media with effects in the Program area. In Properties > Effects, 

you can set and modify detailed effect parameters.   

 Uncheck the box before the effect name to stop showing the effect. 

 Click  next to the effect's name to delete the effect. 

 Click  next to the effect name to reset all effect parameters to their default values. 
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Fisheye 

The fisheye distortion effect allows the display to mimic the ultra-wide-angle, edge-distorted 

visuals of a fisheye lens, suitable for spherical screens. 

Figure 4-54 Fisheye effect 

 

 Center X: Adjusts the horizontal center position of the fisheye effect on the selected media 

for precise effect placement. 

The value range is 0% to 100%, and it defaults to 50%. 

 Center Y: Adjusts the vertical center position for precise effect placement. 

The value range is 0% to 100%, and it defaults to 50%. 

 Radius: Control the fisheye effect's area size, with a default value of 20%, meaning the effect 

impacts 20% of the object's width and height. 

The value range is 0% to 50%, with 0% indicating no effect and 50% indicating it covers half 

the width or height. 

 Distortion: This calculates the embossing effect for the fisheye special effect, controlling its 

strength and visual impact. By adjusting this parameter, the fisheye effect can manifest 

varying degrees of concavity or convexity, enhancing the image's three-dimensionality and 

visual appeal. 

The value range is 0.00 to 5.00, and it defaults to 3.00. The larger the value, the more 

pronounced the concavity and convexity. 

Strobe 

This create a flickering effect through rapid on-and-off imagery, designed to capture attention 

and create a dynamic atmosphere. 
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Figure 4-55 Strobe effect 

 

 Color: Set the strobe color. 

− : Click the eyedropper to select the desired color. 

− Click the default white color block to open the color picker and choose a color. 

− Enter a hexadecimal color code in the text box to set a precise color. 

− Set the color by adjusting the RGB values in the text box. 

 Freq/min: Configure how many times the strobe occurs per second. 

The higher the value, the faster the strobe. The value range is 1 to 100, and it defaults to 10. 

 Duration: Determine how long the opacity change lasts for the strobe color. 

The value range is 0 to 100, and it defaults to 50%. 

 Gradient: Set the proportion of time that the color fades in and out during the duration. 

The value range is 0 to 100, and it defaults to 50%. 

Jitter 

Jitter is a visual effect that adds a dynamic feel to the image through slight or rapid vibration, 

enhancing vitality and realism. 

Figure 4-56 Jitter effect 
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 Freq/min: Set the default speed of movement per unit time. 

The value range is 1 to 200, and it defaults to 100. 

 X Offset: Set the horizontal displacement for the jitter based on the original media width. 

The value range is 0 to 100, and it defaults to 20%, meaning a single displacement value is 

20% of the media's original width or height. 

 Y Offset: Set the vertical displacement for the jitter based on the original media width. 

The value range is 0 to 100, and it defaults to 20%, meaning a single displacement value is 

20% of the media's original width or height. 

Scroll 

During playback, media scrolls according to the configured direction, and the scrolling speed is 

adjustable. 

Step 1 Select the media layer in the program that you wish to configure for scrolling playback. 

Step 2 In Direction, set the media scrolling direction. The options include Left to Right, Right to Left, 

Top to Bottom, and Bottom to Top. 

Step 3 In Speed, set the media scrolling speed. The value range is 1 to 100, and it defaults to 5.   

Scrolling speed can be adjusted by dragging the slider left or right, or by entering a specific 

number in the textbox on the right. 

Mask 

A layer mask uses a specific shape (such as a heart, triangle, oval, or rectangle) to obscure parts 

of the image, displaying only the content within the mask shape, creating a uniquely 

personalized visual effect. 

Figure 4-57 Mask effect 
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 Shape: Choose the mask shape. The options include Heart, Circle (Ellipse), Triangle, and 

Custom Image. 

If you check Invert, the image outside the shape is displayed, while the inside is not. 

When the mask shape is set to Custom Image, click Upload to manually choose a custom 

mask image. 

 Center X: Set the X coordinate for the center of the mask's bounding rectangle based on the 

original media width. 

The value range is 0 to 100, and it defaults to 50, meaning 50% of the media's original width 

or height. 

 Center Y: Set the Y coordinate for the center of the mask's bounding rectangle Based on the 

original media width. 

The value range is 0 to 100, and it defaults to 50, meaning 50% of the media's original width 

or height. 

 Width: Set the width of the mask's bounding rectangle. 

 Height: Set the height of the mask's bounding rectangle. 

Border 

Figure 4-58 Border effect 

 

 Color: Configure the media's border color. 

Enabling the checkbox activates the border. You can set the border color in four ways: 

− Click the color pick tool next to Color and select the desired color on the screen.  

− Click the color block next to Color, and choose a color from the pop-up color selection.  

− Enter a hexadecimal color code next to #. 
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− Enter values for the Red, Green, and Blue components to precisely set the color. 

 Opacity: Adjust the border's opacity. 100 is fully opaque, and 0 is fully transparent.   

 Unit: Set the size unit for the border. 

− By Percentage: Border size as a percentage of media size.  

− By Pixels: Border size in pixels. 

 Width: Adjust the border's width. 

Keying 

Figure 4-59 Keying effect 

 

 Key Color: Remove a specific color from the selected media. 

Enabling the checkbox activates the keying function to remove the selected color. 

The selection methods include: 

− Click the color pick tool  to select the unwanted color on the screen.  

− Click the color block and choose a color.  

− Enter the hex code of the color to be removed next to #. 

− Input specific values for the Red, Blue, or Green components for precise color setting. 

 Strength: Higher values increase the range and correction strength. For precise color keying, 

use an intensity below 10%. In other cases, above 50% is recommended. 

 Shadow: Higher values clean noise areas in shadows more effectively. 



 
Kompass FX3 Pro Multimedia Playback Software Basic Edition 

User Manual 

 

 

www.novastar.tech 96 
 

Feather 

Figure 4-60 Feathering effect 

 

Strength: Set the intensity of the feathering effect on the media edges. A higher value results in 

a stronger feathering effect. 

Other Settings 

 Enable or disable effects 

Check or uncheck the box to enable or disable the added effect. 

 Delete effects 

Click  next to the effect's name to delete the effect. 

 Restore defaults 

− Click  next to the effect name to reset all effect parameters to their default values. 

− Click  next to a single effect parameter to reset it to the default value. 

Edit Output Slices 

The output of Kompass FX3 Pro is in the form of slices, with the slice replicating the 

corresponding layer image for output. 

In the stage editing area, select the slice, and then you can make adjustments to it. Drag the 

slice to different outputs to adjust its output position. 
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Figure 4-61 Slices 

 

 The top left corner number, such as 1, 2, or 3, indicating that this slice is a layer slice in the 

program. 

 The top left corner identifier T+number, such as T1, T2, indicating that this slice is a layer 

slice in the timeline. 

 The bottom left corner number, such as G1 or G2, indicating that this slice is bound to the 

layer. If the graphics card number is not displayed, it means the slice is not bound to the 

layer. 

 Adjust the slice size: Hover the mouse over the slice edges, hold the left mouse button and 

drag to resize the slice. 

 When the slice is within an output, click  in the bottom right corner or double click the 

slice, and the slice will fill the entire output connector. 

 When the slice crosses multiple output connectors, click  in the bottom right corner, 

and the slice will fill the output connectors it crosses. 

 When you select a slice, click  in the bottom right corner to capture the current 

playback image and save the captured image into the media library. 

 Right click the slice to access the following options: 

Context Menu Menu Item Description 

 

Rectangle Slice Add a rectangular slice. Please refer to Add Slices for 

instructions. 

Polygon Slice Add a polygon slice. Please refer to Add Slices for 

instructions. 

Delete Media Delete the media on the current slice. 
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Context Menu Menu Item Description 

Lock Slice Lock the selected slice. 

Delete Slice Delete the selected slice. 

Clear All Slices Remove all slices from the editing area. 

Clear All Media Clear the media from all slices. 

Add Slices 

 

 The slices can be added to the timeline automatically only, but cannot be manually added or 

removed. 

 The slices added to the timeline will automatically bind to the timeline layer, and modifying 

the binding between the slices and the timeline layer is not supported. 

 If all media in a timeline layer are deleted, the current timeline layer will be automatically 

removed, and the corresponding timeline layer slice will also be automatically deleted. 
 

Add Rectangular Slices 

Each time a layer is added, an output slice is automatically added. When a layer needs to be 

displayed on multiple output screens and the output needs to be synchronized, multiple output 

slices can be used for output. 

Step 1 In the stage editing area, right click the blank area and select Rectangle Slice to add a slice. 

Step 2 Select the newly added slice. 

Step 3 Select Properties on the right to enter the slice properties interface. 

Step 4 Select the layer for the slice from the drop-down menu next to Bind Input. 

Add Polygon Slices 

The editing area supports adding polygon slices, including triangular and trapezoidal slices, with 

a default size of 1920x1080. It also supports custom shapes using the mouse. 

Step 1 In the stage editing area, right click the blank area and select Polygon Slice. 

 Select the triangle or trapezoid next to Polygon Slice to directly add a polygon slice. 
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 Click Polygon Slice and the cursor will change to . You can customize anchor points by 

clicking in the editing area, with a minimum of 3 anchor points. 

Step 2 After drawing a polygon, double click the left mouse button or press Enter to finish. The 

polygon will automatically close and display a bounding rectangle, with the slice number shown 

in the top-left corner. 

 

 Polygon slice drawing can be canceled by pressing the Esc key. 

 Polygon slices support advanced editing, and advanced editing automatically exits when the 

mouse clicks the layer or non-editing area. 

 During the advanced editing, double click the anchor line to add anchor points and press the 

Delete key to remove anchor points. 

 During the advanced editing, press and hold the Ctrl key to select multiple anchor points, 

and drag the mouse to edit multiple anchors simultaneously. 
 

Slice Properties 

Select a slice and make precise adjustments in the Properties area on the right pane. 
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Figure 4-62 Slice properties 

 

Table 4-4 Slice properties 

Area Function Description 

Basic Slice name View and modify the slice name. 

Bind input Select the input source for the slice. The input sources only include 

the layer media in the current program. 

Position Set the position of the output slice on the current screen using the 

top-left corner of the screen as the reference point. 

 X: The horizontal distance from the top-left corner of the slice to 

the top-left corner of the screen output area. 

 Y: The vertical distance from the top-left corner of the slice to 

the top-left corner of the screen output area. 

Size Set the slice size. 

 W: The horizontal width of the slice 

 H: The vertical height of the slice 
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Area Function Description 

Slice ratio Quickly adjust the aspect ratio of the slice. The options include 

16:9, 16:10, 5:4, and 4:3. 

Rotate Rotate the slice clockwise, using the center point of the slice as the 

reference for rotation. 

Flip Flip the output slice image. The options include Horizontal and 

Vertical. 

 Horizontal: The slice image is flipped horizontally. 

 Vertical: The slice image is flipped vertically. 

 If neither option is selected, the slice image is displayed without 

flipping, playing normally. 

Priority View and adjust the slice priority. 

 View: Display the slice priority using a number. The larger the 

number, the higher the priority. Slices with higher priority are 

displayed first. 

 Adjustment: Click the arrow icons to adjust the slice priority. 

Color Opacity Adjust the opacity of the output image. 0% is fully transparent, 

100% is opaque, and the default value is 100%. 

Red Adjust the output image quality by modifying the red color. 

Green Adjust the output image quality by modifying the green color. 

Blue Adjust the output image quality by modifying the blue color. 

Advanced Anchor edit Enable or disable the anchor point editing function. 

Live update Enable or disable the live update feature. 

 

Only when Anchor edit is enabled, this function can be turned on or 

off. 

Adjustment Set the adjustment mode of the polygon slice. The options include 

Flat and Linear. 

Position Set the coordinates of the currently selected anchor point, with X 

representing the horizontal coordinate and Y representing the 

vertical coordinate, and support four adjustment methods. 

 Select and drag the anchor point with the mouse. X, Y values 

change in real time. 

 Select the anchor point, and press the arrow keys on the 
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Area Function Description 

keyboard. X, Y values change in real time, with stepping value 

consistent with the vertex stepping. 

 Select the anchor point, double click the values in the X, Y 

sections to manually input the coordinates, ranging from -65535 

to 65535. 

 Select the anchor point, click  next to X, Y to adjust the 

coordinates, with stepping value consistent with the vertex 

stepping. 

Anchor Enable or disable the on screen display function of anchors. Set 

whether the anchor point editing process is simultaneously 

displayed on the output screen. 

Anchor count Split the connector screen horizontally and vertically, and after 

splitting, you can edit the anchor points in each direction 

respectively. 

Line color Set the color of the lines between the anchor points. The default 

color is , and the color switching takes effect in real time. 

Anchor step Adjust its position using the arrow keys on the keyboard. Each 

keystroke moves the anchor point a distance ranging from 1 to 10, 

with a default value of 10. 

Guideline Enable or disable the guideline between the anchor point and its 

adjacent anchor points. 

 Set the line color using the following methods. 

− Click the color block and select a color from the pop-up 

window. 

− Enter the color code value in the text box next to the color 

block. 

 Set the line width. The value range is 1 to 10 and with a default 

value of 1. One-click reset to default value is supported. 

Grid lines Display the grid lines on the slice. The options include Canvas 

Display and Screen Display. 

Play Programs 

Once the program editing is completed, you can play the programs. 

 Control the program playback 
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− Click  on the program name to start playing. 

− After the program is being played, click  to pause the program, and  will show 

when the program is paused. 

− Click  to resume playback from the paused position. 

 During the program playback, it is possible to switch the content of the layers being played. 

For example, while program 1 is being played, you can switch the content of the layer by 

double clicking the media in Program 2 > Layer 2, as shown below. 

Figure 4-63 Control program playback 

 

 In the playback control area, you can control the playback of individual media or the entire 

set. 

Figure 4-64 Control media playback 

 

− Click  or  on the left to play or pause all media in the program. 

− Click  on the left to stop all media playback in the current program. 

− Click  or  before each media name to play or pause the selected media 

playback. 

− Click  in the top right corner, and the program media timer will display the 

playback in forward timing. 

− Click  in the top right to display the program media timer countdown playback. 

− Click  in the top right corner, select the programs you need to synchronize, drag 

the media progress bar, and complete the synchronized playback of the media. 

 Control the timeline playback. 



 
Kompass FX3 Pro Multimedia Playback Software Basic Edition 

User Manual 

 

 

www.novastar.tech 104 
 

Figure 4-65 Control timeline playback 

 

− : Click to stop timeline playback, and once stopped, the timeline position will 

automatically move to the start position on the far left. 

− : Click to start timeline playback. Once the timeline is playing,  will be 

displayed, and you can click to pause playback. 

− : Click to replay from the beginning of the timeline. 

 Turn pages. 

When media files such as PowerPoint slides are added to the program, you can control 

playback using keyboard arrow keys. Click  on the menu bar to enable keyboard page-

turning playback; once enabled, the icon changes to . 

Click  on the menu bar to view key prompt information for page-turning. 

Figure 4-66 Page turning 

 

Configure Scheduled Playbacks 

After the program editing, you can realize automatic playback of the programs according to the 

scheduled time and times. 

Step 1 Navigate to  > Edit Scheduled Playback to open the scheduled playback interface. 
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Figure 4-67 Scheduled playbacks 

 

Step 2 Click New Task at the top right of the window to create a new playback task. 

Figure 4-68 Playback tasks 

 

Step 3 Set the start date and end date of the task in the Effective area. 

Step 4 Click  next to the effective time to add a new playback task. 
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Figure 4-69 Configure scheduled programs 

 

1. Select the desired programs in the Program List area on the left. 

2. Click  to add the selected programs to Plan List. 

The programs will be played according to the sequence (from the top to the bottom) in the 

Plan List area. If you want to adjust the playback sequence, check the box next to the 

desired program and click  or  to adjust the sequence of the selected program. 

Only one program sequence can be adjusted at a time. 

3. Double click the play count on the right side of the program to set the playback count. 

After the setting, the software will automatically rearrange the program playback order 

according to the set count to minimize consecutive playbacks of the same program. 

The play count range is 1 to 999. 

If a program play count exceeds 1, the system will first play programs in order. After 

completion, for programs with a play count greater than 1, the system will automatically loop 

through the list until the set play count is reached. 

After the setting, the system will automatically calculate the total duration of the planned 

programs. If the total duration exceeds 24 hours, program configuration cannot be 

completed. 

4. Click OK to complete the settings. 

Step 5 Click OK to return to the scheduled playback interface. 
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Figure 4-70 Configure playback tasks 

 

Step 6 Select the program playback mode next to Mode. The options include Time and Count. 

 Time: The programs will be played by the set duration circularly. 

 Count: The programs will be played according to the set playback count. 

Step 7 Set the start and end time within the schedule range. 

1. Set the automatic start time of the program in the From section. 

2. Set the automatic end time of the program in the to section. 

When the playback mode is set to Count, the end time of the program playback is 

determined by the start time plus the total duration of the current scheduled program. This 

end time cannot be modified. 

Step 8 Set the program playback count. 

Click the number next to Count to activate the function. Enter the desired value and then the 

program will be played automatically according to the set count. When the playback mode is 

set to Time, the playback count of the program is 1 by default and cannot be changed. 

Step 9 Set the program playback date. The options include Every day, Monday, Tuesday, Wednesday, 

Thursday, Friday, Saturday and Sunday. 

 Every day: The plan will be played every day automatically according to the schedule within 

the effective time range. 
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 Monday to Sunday: The plan will be active on the selected days of the week within the 

specified time range, and the content will be automatically played according to the 

configured schedule and playback plan. 

Step 10 Set the action after the program stops. The options include FTB and Current Frame. 

 FTB: After the program playback ends or the playback time reaches the end, the output 

image fades to black. 

 Current Frame: FTB: After the program playback ends or the playback reaches the end time, 

the output image displays the frame when the program stops. 

Step 11 Repeat Step 4 to Step 10 to add more plans under the current task. 

Step 12 Repeat Step 2 to Step 10 to add more tasks and plans. 

Step 13 Click OK to finalize the program scheduling. 

Click Enable to activate the current program schedule. Once the program schedule is enabled, 

the scheduled playback icon on the menu bar changes to . 

Step 14 Navigate to  > Enable Scheduled Playback to enable the function. 

 

 Different plans cannot have the overlapping time slots. 

 Different tasks cannot have the overlapping time slots. 
 

Insert Programs 

Once the scheduled playback is activated, it supports the program insertion. This insertion can 

be executed either immediately or with a delay. 

 Immediate Insert: Play the next selected program instantly. 

 Delayed Insert: Wait for the current program to finish before playing the selected program. 

Step 1 Navigate to  > Edit Scheduled Playback to enter the scheduled playback interface. 
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Figure 4-71 Edit scheduled playbacks 

 

Step 2 Click the program name next to the plan that requires insertion to open the program selection 

window. 

Figure 4-72 Select programs 

 

Step 3 Right click the desired program name in Plan List and select either Immediate Insert or Delay 

Insert to proceed with the program insertion. 
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Figure 4-73 Insert programs 

 

Rules for program insertion: 

 Only programs that are currently being played or have not yet begun support program 

insertion. The programs that have already been played do not support insertion. 

 For a schedule plan that is being played, the insertion can alter the order of the program 

sequence. 

 If an insertion spans different plans, after the insertion, the playback will switch to the plan 

that contains the inserted program and continue until the end of the new plan. 

 If an insertion spans different tasks, after the insertion, the inserted task will play first; once 

completed, the playback will revert back to the pre-insertion plan and continue. 

More Operations 

 Delete plans 

In the Scheduled Playback interface, click  next to the desired plan to delete the plan. 

 Delete tasks 

In the Scheduled Playback interface, click  next to the desired task to delete the task. 

 Edit plans 

Navigate to  > Edit Scheduled Playback. You can add, edit or delete the plans or tasks 

in the pop-up. 
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 Create task copies 

Click  next to the task to create a task copy. By expanding the copied task, you will be 

able to modify the related information. 

 Create plan copies 

Click  next to the plan to create a plan copy. By expanding the copied plan, you will be 

able to modify the related information. 

 Disable scheduled playbacks 

Navigate to  > Disable Scheduled Playback to halt the scheduled playback. 

Save Projects 

Once the project editing is complete, it can be saved as a separate file for easy access and use 

in future projects. 

 Navigate to File > Save/Save As to save the current project file locally. 

 Click  in the top left corner of the main interface to create a new project. 

 Click  in the top left corner of the main interface to save the current project file. 

 Click  in the top left corner of the main interface to package the media in use or all 

media and project files. The packaged project files can be used directly. 
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 Link 

Link Settings 

Application Scenarios 

 Primary and backup output: When the primary control device encounters issues or its 

connection lines fail, the backup device takes over the role, ensuring uninterrupted work and 

preventing anomalies such as a black screen. 

 Primary and secondary output: If the primary control device cannot independently drive the 

display, one or more secondary devices can be configured to assist, with unified settings 

managed by the primary device, ensuring seamless display management. 

Figure 5-1 Application scenarios 

 

Prerequisites 

 The devices (primary, secondary, and backup) must be on the same network segment. 

 The sync card must be installed in all devices. 
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On the primary device's Kompass FX3 Pro interface, navigate to Link > Link Management to 

access the link settings interface. 

Figure 5-2 Link settings 

 

Add Secondary Devices 

Step 1 In the device list, select the IP address of Kompass FX3 Pro device to be used as the secondary. 

Step 2 Click and drag the selected IP address to the blank area on the right to configure it as a 

secondary device. 
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Figure 5-3 Add secondary devices 

 

Once added, the secondary device's interface will display secondary information, and the 

secondary device will be locked from editing. 

Figure 5-4 Secondary device interface info 

 

 Disconnect: Click to disconnect the Primary and secondary devices. 

 Unlock: Click to disable the current interface lock, allowing edits to the secondary device’s 

interface. To lock again, navigate to Link > Lock. 

Add Backup Devices 

Step 1 In the device list, select the IP address of Kompass FX3 Pro device to be used as the backup. 

Step 2 Click and drag the selected IP address to the blank area on the right to configure it as a backup 

device. 
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Figure 5-5 Add backup devices 

 

Once added, the backup device's interface will display backup information, and the backup 

device will be locked from editing. 

Figure 5-6 Backup device interface info 

 

 Disconnect: Click to disconnect the primary and backup devices. 

 Unlock: Click to disable the current interface lock, allowing edits to the backup device’s 

interface. To lock again, navigate to Link > Lock. 

 Switch to Primary: Switch the backup device to the primary. 

Manage Devices 

On the topology, select the secondary or backup device. Right click it to open the context menu. 

 Connect: Manually connect the devices if they are not properly connected. 

 Disconnect: Manually disconnect the devices as needed. 

 Power On: Remotely start a powered-off secondary or backup device. 

Ensure that the hardware and network of the media server support and are properly 

configured for remote wake-up. 
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 Power Off: Remotely power off the secondary or backup device. 

 Restart: Remotely restart the secondary or backup device.  

 Restart Application: Remotely restart the software on the secondary or backup device. 

 Retrieve Logs: Obtain running logs of the software from the secondary or backup device. 

 Start VNC: Enable VNC remote connection for the secondary or backup device. The 

connection password is 123456. 

 Delete: Remove the binding relationship between the devices. 

 

To disconnect all linked devices, right click Editing (Local) and select Disconnect All. 
 

Update to Secondary or Backup 

On the primary device's Kompass FX3 Pro interface, navigate to Link > Update to Secondary or 

Link > Update to Backup to manually synchronize all data from the primary and secondary 

devices or the primary and backup devices. 

At the bottom right of the primary device's Kompass FX3 Pro interface, click Update to view the 

update progress. 

Unlock 

Locking the local device secures the interfaces of both the slave and backup devices, making 

them inoperable. 

 Slave Device: Navigate to Link > Lock, and the main interface of the secondary device will 

display the information seen in Figure 5-4. 

 Backup Device: Navigate to Link > Lock, and the main interface of the backup device will 

display the information seen in Figure 5-6. 
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 Settings 

System Settings 

Set the status after the system starts. Navigate to Settings > System to enter the system 

settings interface. 

Figure 6-1 System settings 

 

General 

Startup/Shutdown 

 Auto start 

− Checked: The software automatically starts after delay when the system boots. Set 

delay if USB sound card is added. 
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− Unchecked: The software does not automatically start on boot. 

 Auto restart: Set a time for the software to automatically restart. If the software runs for an 

extended period, it is recommended to schedule a restart to ensure its optimal long-term 

performance. 

− Checked: The software automatically restarts at set time. 

− Unchecked: The software does not automatically restart. 

 Shutdown: Set the automatic shutdown time. 

− Checked: The software shuts down at the set time. 

− Unchecked: The software does not automatically shut down. 

 Auto enable all output connections on startup: Enable all the output connections 

automatically once the software is started. 

Project file 

 Open recent project on startup 

− Checked: The software opens the last edited project on start. 

− Unchecked: The software shows default interface on start. 

 Play project after opened 

− Checked: The software automatically plays content on opening the project file. 

Last: The software plays last closed content. 

Program List: The software plays selected content from the list. 

− Unchecked: Manual play required after software startup. 

 Auto save project: Set the save interval and max number of auto-saved project files. The 

save interval ranges from 1 to 30 minutes and defaults to 5 minutes. The auto-saved files 

range from 1 to 20 and defaults to 5. 

− Checked: Enable auto-save at set intervals. 

− Unchecked: Disables auto-save. 

 Auto save path: Set the path for auto-saved projects. 

− Browse: Select the save path. 

− Open: Access the save location. 

− Clear: Clear the save location info. 
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 No save prompt on close 

− Checked: The software closes without a save prompt. 

− Unchecked: The software prompts for save on close. 

 Reset all outputs when creating a new project 

− Checked: Automatically reset the output configuration from the previous project to 

default parameters when creating a new project. 

− Unchecked: Automatically use the output configuration from the previous project when 

creating a new project. 

File 

 Log Storage: Set the storage duration for playback logs. Options include Permanent, 1 

Month, 3 Months, 6 Months, and 12 Months. 

 Storage Path: Set the storage location for playback logs. 

− Click Browse to select a storage location. 

− Click Open to open the folder where logs are stored. 

− Click Clear to delete all cached playback logs. 

 Cache Path: Set the storage location for media files downloaded from the primary device. 

− Click Browse to select a storage location. 

− Click Open to open the folder where cache files are stored. 

− Click Clear to delete cached information. 

Undo/Redo 

Undo Steps: Set the maximum number of undoable and restorable steps. Exceeding this limit 

prevents further undo or redo actions. This feature requires a restart to take effect. 

General 

Configure the background and text color information for the stage editing area. 

 In the Canvas Color section, modify the background color by selecting a preset color or 

customizing a color. 
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 In the Text Color section, modify the text color by selecting a preset color or customizing a 

color. 

 For custom colors, you can set color information in the following ways: 

− Use the color picker next to Canvas Color to select a color from the screen. 

− Click the color block to open the color picker and choose a color. 

− Enter the hexadecimal color information in the text box on the right. 

− Input the color values in the R, G, and B text boxes to set the color. 

Link 

Set whether the primary device information automatically updates to the secondary or backup 

devices. 

 Checked: All configuration information on the primary device is automatically synchronized 

to the secondary and backup devices. 

 Unchecked: After configuring the primary device, the system will not automatically 

synchronize. Manual synchronization is required via Link > Update to Secondary/Update to 

Backup. 
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Display 

Figure 6-2 Display settings 

 

Codec 

Local Control Window: Set the graphics card for rendering the software main interface. After 

the configuration, a software restart is required. 

Display Control 

 Mute FTB 

− Checked: Mute all audio when the screen goes black. 

− Unchecked: Audio continues when the screen goes black. 

 MFPS: 

− Checked: The software shows the real-time frame rate at bottom left of preview window 

in the stage editing area. 



 
Kompass FX3 Pro Multimedia Playback Software Basic Edition 

User Manual 

 

 

www.novastar.tech 122 
 

− Unchecked: No frame rate display 

 EFPS: 

− Checked: The frame rate is shown at bottom left of output. 

− Unchecked: No frame rate display 

 Fade In: Set the time length for transitioning between programs, from the start of the 

transition to the full display of the program. The default is 0.5 seconds, with a range of 0 to 

10 seconds. A value of 0 means a direct cut. 

 Fade Out: Set the time length during the program transition, from the start of the program 

switch to the point where the program is no longer displayed. The default is 0.5 seconds, 

with a range of 0 to 10 seconds, where 0 represents a direct cut. 

 Apply to all: Clicking this will apply the set fade in and fade out durations to all the programs. 

If you set the fade in and fade out durations and do not click Apply to All, it will only affect 

programs without added media; programs with added media will not be affected. 

 Layer Overlay: Set the display order for program layer slices and timeline slices. Changes 

take effect after restarting the software. 

− Show timeline on top: Timeline slices are displayed over program layer slices. 

− Show program on top: Program layer slices are displayed over timeline layer slices. 

Playback 

Default duration: Set different default playback durations for various media. 

Office 

The software supports the playback of PowerPoint documents, but you need to configure the 

basic information of the PowerPoint document before playing it. 

In the System interface, click Office to enter the Office settings interface. 
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Figure 6-3 Office settings 

 

PowerPoint Settings 

 Auto play: Set whether the PowerPoint file in the program plays automatically. 

 Interval: Set the time interval for automatic PowerPoint playback. 

 Playback: Set the transition method for each slide in the file. 

− Animation: Display the animations within the slide during playback. 

− Picture: Do not display the animations within the slide, but display them during slide 

switching. 

 Resolution: Configure according to the resolution displayed in the PowerPoint document, 

supporting individual width and height settings, or setting through preset resolutions. 

 

 After modifying the PowerPoint settings, the changes only apply to newly added files, and 

not to those already added to the program. 

 If the media server has WPS Office, the resolution settings are not supported. 
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Communication 

The software supports remote control or control through a central control device, allowing 

users to play and control the software more conveniently. 

Navigate to Settings > System > Communication to enter the communication interface. 

Figure 6-4 Communication 

 

UDP/TCP 

In the text field, enter the port number for UDP/TCP communication with the peer device, then 

click Open or Close. 

Once opened, the software will automatically check if the entered port number is already in use. 

MIDI 

Check Enable MIDI to activate MIDI control. Once enabled and connected to the media server, 

the system will automatically detect and list MIDI devices. 
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Navigate to Settings > MIDI Binding to enter the MIDI binding interface and assign functions to 

MIDI buttons. 

DMX 

Before controlling via DMX, complete the DMX configuration. 

Step 1 Check Enable DMX to activate DMX control. 

Step 2 Select the node name for DMX control under Node. 

Step 3 Set the offset in Channel Offset. 

Step 4 Configure the subnet information for DMX devices in Subnet. 

Step 5 Set the domain information in Universe, ensuring it matches the media server's domain. 

Step 6 Click Send to complete the configuration between DMX and the media server. 

Navigate to Settings > DMX Binding to enter the DMX binding interface and assign functions 

to DMX buttons. 

OSC 

After enabling OSC input, connect and configure the OSC device. 

Step 1 Check OSC Input to activate OSC control. 

Step 2 Set the input port to match the port in the touchOSC control software (default 8001). 

Audio 

Sound card mapping refers to creating a mapping relationship between virtual and physical 

sound cards. One virtual sound card (i.e., sound card mapping) can be bound to multiple 

physical sound cards, and the same physical sound card can be bound to multiple sound card 

mappings simultaneously. 

Step 1 Navigate to Settings > System > Audio to access the audio settings interface. 
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Figure 6-5 Audio settings 

 

Step 2 Click New Mapping to create a new sound card mapping. 

Figure 6-6 Add sound card mappings 

 

Step 3 Click  next to Sound Card Mapping 1 to rename the sound card mapping. 

Step 4 Click the dropdown menu below the sound card mapping to select the corresponding sound 

card. 

Step 5 Select the number of channels for the current sound card in Channels. 

 Click  on the right to add a sound card to the current mapping and configure its 

channel count. 
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 Click  next to an added sound card to delete it. 

Once sound card mapping is configured, select a layer and choose the newly added sound 

card mapping in the Sound Card Mapping option in the layer properties. 

Click  next to Sound Card Mapping to delete the added sound card mappings. 

User Management 

When the management console connects to the client, the connection password is required. 

The connection will only be successful after the password is verified. 

Navigate from the menu bar to Settings > System. In the dialog box that appears, select the 

Client tab, where you can enable or disable the verify password requirement and set the 

specific password. 

Click  or  show or hide the entered characters. 

Figure 6-7 User management 
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Shortcut Binding 

The software supports adding custom shortcuts, allowing users to operate it quickly through 

personalized shortcuts. By navigating to Settings > Shortcut Binding, you can access the 

shortcut binding settings interface, and the function areas where shortcuts can be added will be 

highlighted. 

Figure 6-8 Shortcut binding interface 

 

 Click the target function area, then press the desired letter or number key combination on 

the keyboard to add the shortcut key. 

 After adding the shortcut, navigate to Settings > Complete Binding or use the built-in 

shortcut Ctrl+Shift+K to activate the set shortcut and exit the shortcut binding interface. 

 

When setting function shortcuts, the system built-in global shortcuts cannot be used. 
 

For example, set the shortcut for Program 1 to "w". 

1. In the shortcut binding interface, click P 1 to select the program 1. 

2. Pressing W on the keyboard will display the shortcut on the program 1. 
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Table 6-1 Built-in shortcuts 

Keys Description 

Ctrl+H The mouse quickly returns to the center of the software interface. 

Ctrl + Left/Right arrow keys In the case of multiple monitors, adjust which monitor displays the 

main interface. 

Arrow keys, PgUp, PgDn When playing the PowerPoint slides, flip through the slides up and 

down. 

Configure MIDI and DMX Shortcuts 

Prerequisites 

 For MIDI control, complete the MIDI configuration in section Communication. 

 For DMX control, complete the DMX configuration in section Communication. 

Procedure 

Step 1 Navigate to Settings > MIDI Binding or Settings > DMX Binding to enter the MIDI or DMX 

binding settings interface. The areas where shortcut binding can be applied will be highlighted. 

Step 2 Click the highlighted area to select the function to be bound. 

Step 3 Press the corresponding button on the MIDI or DMX device panel to complete the shortcut 

binding configuration. 

Step 4 Repeat the above steps to bind additional functions. 

Configure OSC Bindings 

Step 1 Ensure the PC has TouchOSC Editor and TouchOSC Bridge installed, and the mobile device has 

TouchOSC installed. 
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Step 2 Run TouchOSC Editor and TouchOSC Bridge on the PC. 

Step 3 Open TouchOSC on the mobile device. 

Step 4 In TouchOSC Editor on the PC, design a shortcut keyboard and save it. 

Step 5 In Kompass FX3 Pro, navigate to Settings > OSC Binding to enable OSC binding. 

Highlighted areas for shortcut binding will appear. 

Step 6 Click a highlighted area to select the function to be bound. The OSC Parameter will appear in 

the bottom right corner, and copy the parameter. 

Figure 6-9 Select binding functions 

 

Step 7 In TouchOSC Editor on the PC, select the designed shortcut and paste the copied OSC 

parameter into the corresponding button's URL in the TouchOSC software. 
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Figure 6-10 OSC parameter settings 

 

Step 8 Repeat steps 6 and 7 to bind additional functions. 

Step 9 Sync the designed keyboard from TouchOSC Editor to the mobile device. 

Step 10 Open the designed keyboard and input the shortcut to send control commands to Kompass 

FX3 Pro. 

Clear Shortcut Bindings 

The clear shortcut function allows you to remove all configured shortcuts. 

 Navigate to Settings > Clear Binding > Clear Shortcuts to delete all keyboard shortcuts at 

once. 

 Settings > Clear Binding > Clear MIDI to delete all MIDI shortcuts at once. 

 Settings > Clear Binding > Clear MIDI to delete all DMX shortcuts at once. 

Signal Monitoring 

In the main interface, click MIDI, DMX, or OSC in the upper right corner to enter the signal 

monitoring interface. Click the peripheral control name on the left to view the execution process 

of different peripheral control commands, including the time, url and value. 
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Figure 6-11 Signal monitoring 

 

 Time: The timestamp of peripheral control 

 Url: The control command executed 

 Value: The final adjusted parameter value 
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 Tools 

Playback Control Assistant 

Kompass FX3 Pro supports transcoding, encryption, optimization, cropping, and splitting of 

videos and images to meet various playback scenario requirements. 

Prerequisites 

If configuring AI-related parameters, the system requires a graphics card model from the 

following series: RTX 4000, RTX 5000, RTX A4000, RTX A4500, RTX A4500 Ada, RTX A5000, RTX 

A6000, or RTX A6000 Ada, with the corresponding graphics driver installed. 

Operating Procedure 

Step 1 Navigate to Tools > Playback Control Assistant to access the interface. 

Step 2 In the window shown below, click Add at the bottom or click the icon in the middle area. 
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Figure 7-1 Playback control assistant 

 

 

At the top right corner, you can switch the preferred language. 
 

Step 3 In the dialog box, select video or image files and click Add, or drag and drop selected files into 

the file list. 

To delete a specific file, select it and click Delete. To clear the entire list, click Clear. 
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Figure 7-2 File list 

 

Step 4 Click to select the video or image you wish to transcode. 

Step 5 On the right side, click Change. In the new dialog, select the output path for the files and click 

Change. 

Step 6 Configure the transcoding parameters for the image or video as needed. 

Table 7-1 Image transcoding parameters 

Name Description 

Coding The image encoding format 

When set to Self-Adaptive, the original image encoding is used. 

Quality The image quality 

When set to AI Quality, the following parameters are available: 

 Enhanced Mode: Optimize the color, brightness, contrast, etc., for higher 

image quality. 

 Fidelity Mode: Optimize the textures like skin, hair, and edges for more 

realistic rendering. 

Resolution The image resolution, which must be an even number 

 If AI Super-Resolution is disabled and the value is greater than the original 

resolution, the output resolution remains unchanged. 
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Name Description 

 If AI Super-Resolution is enabled and the value is greater than the original 

resolution, AI upscaling is applied to enhance clarity. Currently supports 

upscaling up to 4K source to 8K. 

Table 7-2 Video transcoding parameters 

Name Description 

Coding The video encoding format 

 When set to Self-Adaptive, the original image encoding is used. 

 If set to hap, the related parameter Keep Alpha Channel appears. 

Keep Alpha Channel Configure how to handle the source video's alpha channel. 

This parameter is available only when Coding is set to hap. 

 Checked: Keep the alpha channel from the source video. 

 Unchecked: Discard the alpha channel, and the system fills it automatically. 

Keep HDR Configure how to handle the source video's HDR data. 

 Checked: Keep the HDR data. 

 Unchecked: Discard the HDR data, converting the video to SDR. 

Copyright The copyright protection strategy 

 Checked: Encrypt the video into an .nvf file, playable only in Kompass FX3 

Pro. Parameter priority (high to low): Device ID > Auth Expire > Password. 

− Password: Set a video password. Playback requires password 

verification. 

− Auth Expire: Set a valid duration. Videos expire afterward. 

− Device ID: Enter a device ID (found via Help > Device ID). Limits playback 

to the specified device. 

 Unchecked: No encryption is applied. 

Quality The image quality 

When set to AI Quality, the following parameters are available: 

 Enhanced Mode: Optimize the color, brightness, contrast, etc., for higher 

image quality. 

 Fidelity Mode: Optimize the textures like skin, hair, and edges for more 

realistic rendering. 

Code Rate The video bitrate 

 Self-Adaptive: Match the source video's bitrate. 

 Custom: Use a user-defined bitrate. 
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Name Description 

Frame Rate The video frame rate 

 Self-Adaptive: Match the source video's frame rate. 

 24/30/60: Convert to 24 Hz, 30 Hz, or 60 Hz. 

 Custom: Use a user-defined frame rate. 

Resolution The video resolution, which must be an even number or a multiple of 4 if 

Coding is hap 

 If AI Super-Resolution is disabled and the value is greater than the original 

resolution, the output resolution remains unchanged. 

 If AI Super-Resolution is enabled and the value is greater than the original 

resolution, AI upscaling is applied to enhance clarity. Currently supports 

upscaling up to 4K source to 8K. 

Audio Configure how to handle the video's audio track. 

 AAC: Encode audio to AAC format. 

 Copy: Copy the original audio stream without re-encoding. 

 No Audio: Remove all audio. 

Step 7 Click Apply to All to use the current parameter settings for all images/videos in the file list for a 

quick, batch setup. If not needed, just skip this step. 

Step 8 Configure the following parameters as needed. 

 Crop: Enable cropping and define the starting position and size (width/height) of the crop 

area. 

 Split: Enable splitting and set the number of rows and columns to divide a single 

video/image into multiple parts. 

 Enable GPU Acceleration: once enabled, uses the GPU to speed up the transcoding process. 

Step 9 After configuring all parameters, click Optimize. Upon completion, a checkmark will appear in 

the Progress column, and the converted files will be saved to the output path automatically. 

Step 10 Click Open below the output path to access the transcoded files. 

Play Log 

Kompass FX3 Pro automatically logs media playback statistics, including start time, end time, 

total duration, and playback count for a selected period. 

Step 1 Navigate to Tools > Play Log to open the interface. 
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Figure 7-3 Play log - 1 

 

Step 2 Select a time range for log data statistics. Options include Today, 7 Days, 1 Month, and 3 

Months. 

 

To ensure complete playback logs, set the Log Storage duration in Settings > System to a 

value greater than the selected time range. 
 

Step 3 Set the start time and end time for the playback logs. 

Step 4 Enter a media name in the Media Name field to query logs for a specific media file. Leave it 

blank to view all logs. 

Step 5 Click Search to search and display the playback logs. 
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Figure 7-4 Play log - 2 

 

Step 6 Click Export to save the playback logs locally. 

Runtime Log 

Export the software's runtime logs to facilitate troubleshooting and issue diagnosis. 

Step 1 Navigate to the menu bar and select Tools > Runtime Log. 

Step 2 In the dialog box that appears, select the desired export path and click OK. 

Port Check 

The port check tool is used to scan and query the port information of Kompass FX3 Pro. 

Navigate to Tools > Port Check to enter the port check interface and view the port details of 

the software. 
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Figure 7-5 Port check 

 

TCP and UDP ports can be modified and configured in the Settings > System > Peripheral. 

System Restore 

This feature allows you to create a system restore point, enabling quick system recovery at a 

later time. 

Step 1 Navigate to the menu bar and select Tools > System Restore. 

Figure 7-6 System restore 
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Step 2 In the dialog box that appears, perform one of the following operations as needed. 

 Create restore points 

Click Start Creation and wait for the process to complete. 

 View restore points 

Click View Restore Points to display a list of existing restore points in the text box. 

 Restore system 

Click System Restore. In the Windows System Restore dialog that opens, follow the on-

screen instructions to select a restore point and complete the restoration process. 

GPU Configuration Assistant 

For NVIDIA professional graphics cards, this assistant supports resolution settings, EDID 

management, connector mosaic, as well as viewing graphics card information and authorization 

status. Users don’t need to open third-party tools, and they can directly complete graphics 

card-related operations through our software. 

Configure Resolution 

Customize the resolution and frame rate for the GPU's output connectors. Supports modifying 

settings individually or in bulk. Setting the resolution of the mosaic monitor is not supported. 

Step 1 Navigate to Tools > GPU Configuration Assistant to open its dialog box. 

Step 2 In the Resolution Settings tab, select one or multiple connectors. 

The software will automatically query and display the connector information. If you need to 

retrieve the information again, you can click Query Connector. 

Monitors that are in a mosaic state are not shown in the list. Only the mosaic monitors are 

shown. In the Monitor Name column, a mosaic monitor refers to the mosaic monitor, and 

Mosaic-n is the monitor identifier. 



 
Kompass FX3 Pro Multimedia Playback Software Basic Edition 

User Manual 

 

 

www.novastar.tech 142 
 

Figure 7-7 Configure resolution 

 

Step 3 Set the target connector resolution and frame rate, and click Create. 

The target resolution must be set to a resolution supported by all selected connectors. If the 

connector does not support the target resolution, setting failures or black screens may occur. 

Manage EDID 

Navigate to Tools > GPU Configuration Assistant to open its dialog box. Select the EDID 

Management tab to perform the operation as needed. 

 

For NVIDIA graphics cards, the driver version must be 531 or later. 
 

Export EDID 

Save the EDID as a .txt file to a specified path. Exporting the EDID of the mosaic monitors is not 

supported. 

Step 1 Select the Export tab. 

The software will automatically query and display the connector information. If you need to 

retrieve the information again, you can click Query Connector. 
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In the query result, a File status indicates the connector has an EDID loaded. In the Monitor 

Name column, Mosaic-n is the monitor identifier. 

Figure 7-8 Export EDID 

 

Step 2 Select the connectors and click Export EDID. 

Step 3 In the dialog box that appears, select the export path and click Save. 

Load EDID 

The EDID is loaded by default to the connector located closer to the front in physical position. 

Please prepare the EDID file before loading. If you need to load to a specified connector, you 

can load the EDID in NVIDIA Control Panel. 

Step 1 Select the Load tab. 
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Figure 7-9 Load EDID 

 

Step 2 Click Browse, select the EDID file in the dialog box, and click Open. 

Step 3 Click Query Connector to query the connector EDID information. 

Step 4 Set the number of target connectors and the video signal type, then click Load EDID. 

1 ≤ Number of EDID connectors must be ≤ Number of physical connectors 

Unload EDID 

Restore the EDID to factory defaults for connectors, whether the EDID was loaded via this 

assistant or a third-party tool. 

Step 1 Select the Unload tab. 

The software will automatically query and display the connector information. If you need to 

retrieve the information again, you can click Query Connector. 
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Figure 7-10 Unload EDID 

 

Step 2 Select the connectors and click Unload EDID to restore factory settings. 

Configure Connector Mosaic 

Output connectors of the same type on a GPU support mosaic on a single large display surface. 

The mosaic can be within a single GPU or across multiple GPUs. 

Step 1 Navigate to Tools > GPU Configuration Assistant to open its dialog box. 

Step 2 Select the Connector Mosaic tab and click Query Connector to query connector information. 

 If multiple graphics cards are detected, options for Internal GPU and Cross GPU will appear. 

 If a single graphics card is detected, Internal GPU is used by default. 
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Figure 7-11 Query connectors 

 

Step 3 Select the connectors to be mosaicked and select the target resolution from the dropdown 

menu. 

 For the internal GPU mosaic, if configuring one graphics card, select all its desired 

connectors. For the cross-GPU mosaic, the number of selected connectors must be identical 

for each graphics card. 

 The connector resolution applies to all selected graphics card. In cross-GPU mosaic, the 

resolution is determined by the first graphics card selected. 

Step 4 Set the grid layout (rows x columns) and click Create Mosaic. 

The product of rows and columns must be less than or equal to the number of selected 

connectors. 
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Figure 7-12 Create mosaic 

 

 

To remove the mosaic, click Disable Mosaic. 
 

View GPU Information 

View the graphics card details, such as name, driver version, memory capacity, temperature, 

and power consumption. 

Step 1 Navigate to Tools > GPU Configuration Assistant to open its dialog box. 

Step 2 Select the GPU Info tab and click Query GPU to query GPU information. 
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Figure 7-13 GPU info 

 

View License Status 

This assistant is fully functional after the software is successfully licensed. 

Step 1 Navigate to Tools > GPU Configuration Assistant to open its dialog box. 

Step 2 Select the License tab to view the tool's authorization status. 
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Figure 7-14 License management 
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 Help 

User Manual 

Navigate to Help > User Manual to open the software user manual. 

Language 

Navigate to Help > 语言/Language to switch the software UI language. 

Device ID 

Navigate to Help > Device ID to obtain the device identification code. In the dialog box that 

appears, scan the QR code to retrieve the device ID, or click  to copy it to the clipboard. 

Figure 8-1 Device ID 

 

About Us 

View the software version, license duration, licensing agreement, and more information. 
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 AI Assistant 

AI Assistant 

AI Assistant is a versatile AI tool providing accurate AI chat services to quickly answer questions 

and offer software operation guidance. Additionally, it allows users to generate personalized 

images by entering prompts, selecting image ratios, and styles. The integrated web search 

feature enables users to access real-time internet information, catering to diverse needs. 

Prerequisites 

 You have completed the software authorization. 

 You have logged in the software. 

Limitations 

 Each account is limited to 100 AI chat operations and 10 image generation operations per 

day. 

 Only one image is generated per operation, consuming one image generation count. 

Register Account 

Step 1 Click Login at the top right to open the login window. 
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Figure 9-1 Login window 

 

Step 2 Click Select Server to enter the server selection interface. 

Step 3 Choose a server node, then click OK. 

Step 4 Click Register Now to enter the registration interface. 

Figure 9-2 VNNOX registration 

 

Step 5 Choose the registration method. The options include Phone and Email. 

Step 6 Enter your phone number or email. 

Step 7 Check I agree to Terms of Service and Privacy Policy. 

Step 8 Click Send Code and complete the slider verification in the pop-up. 

Step 9 Enter the received verification code into the text box. 
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Step 10 Click Next to enter the Complete Account Information interface. 

Figure 9-3 Complete account information 

 

Step 11 Fill in the user name, password, and enterprise information, then click Submit to complete 

registration. 

Log In Account 

Step 1 Click Login at the top right to open the login window. 
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Figure 9-4 Login interface 

 

Step 2 Click Select Server to enter the VNNOX server selection interface. 

Step 3 Choose a server node, then click OK. 

Step 4 Click Verification Code or Account to select login method. 

Step 5 Enter the account information. 

For verification code login, after entering your email, drag the slider to the far right and get a 

code, and then enter the received code into the text box on the left. 

For account login, after entering your user name and password, drag the slider to the far right 

to complete verification. 

Step 6 Check I agree to the Terms of Service and Privacy Policy. 

Step 7 Click Login to enter the device authorization verification interface. 

Step 8 Drag the slider to the far right to receive the verification code by email or phone. 

Step 9 Enter the received verification code in the text box. 

Step 10 Click OK to complete the login. 

AI Assistant Operations 

AI Chat 

Step 1 Click  to open the AI Assistant interface. 
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Figure 9-5 AI assistant 

 

Step 2 Click AI Chat to select the AI Q&A function. 

Step 3 Enter your question in the text box below. 

To ensure accurate answers, it is recommended to ask specific, clear, and unambiguous 

questions with sufficient context. A maximum of 200 characters is supported. 

Step 4 Set the AI thinking mode, supporting DeepSeek and Web Search modes. 

 DeepSeek: 

− On: If the user’s question is not found in the current product knowledge base, the 

system will use the DeepSeek model to provide suggestions. 

− Off: If the user’s question is not found in the current product knowledge base, the 

system will use the default model to provide suggestions. 

 Web Search: 

− On: Web search is enabled, and the system will search the internet based on the user’s 

question to provide suggestions. 

− Off: The system will not perform a web search and will rely on the current product 

knowledge base and the selected large model for reasoning. 

Step 5 Click Send to let the system process the question and provide an answer. 
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Image Generation 

Step 1 In the AI Assistant interface, click Generate Image to enable the text-to-image function. 

Figure 9-6 Image generation 

 

Step 2 Enter the basic requirements for the image in the text box below. 

When using AI to generate images, please provide clear and detailed text descriptions, 

including the theme, details, style, emotion, and any specific requirements, to help the AI 

accurately understand and create images that meet expectations. A maximum of 200 characters 

is supported. 

Step 3 Select the desired image aspect ratio from the default 16:9 options. 

Step 4 Select the desired image style from the default Portrait Photography options. 

Step 5 Click Send to let the system generate an image based on the input text. Only one image is 

generated per operation. 
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Figure 9-7 Generate images 

 

If generation is not needed, click Stop. 

View and Download Images 

After the image is generated, hover over the image to display the image tools. 

Figure 9-8 View images 
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 : Click to zoom in the image, and click Download Image to Media Library to save the 

generated image to the media library. 

 : Click to download the generated image directly to the media library. 

 : Click to automatically fill the description used to generate the image into the text box 

below, allowing for modifications and regeneration. 

More Operations 

 Copy: Copy the question or AI result. 

 Edit: Fill the description used to generate the image into the text box below. 

 Try Again: If no result is received, click Try Again to reattempt the question. 

 Clear: Clear all information in the dialog box. 
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 Other Control Options 

Event Controller Control 

The Kompass FX3 Pro supports control via an event controller, where the event controller's 

screen serves as the editing interface for Kompass FX3 Pro. 

Control Connections 

 

 Video cable: Connect the CONTROL UI connector of the media server to the event 

controller's input connector with a video cable for displaying the software editing interface. 

 USB cable: Use a USB Type-B to Type-A cable to connect the event controller and the media 

server. 

− Connect USB Type-B to the KVM connector on the event controller. 

− Connect USB Type-A to the media server's USB connector. 

 Keyboard and mouse connections: Connect the mouse and keyboard to the USB connectors 

of the event controller. 



 
Kompass FX3 Pro Multimedia Playback Software Basic Edition 

User Manual 

 

 

www.novastar.tech 160 
 

Event Controller Operations 

In the event controller's FUNCTION area, briefly press the MVR or MEDIA button, and the 

corresponding button lights turn green. At this time, the event controller screen functions as the 

editing interface for Kompass FX3 Pro. 

Move the mouse to the editing interface to begin editing. 

 

Control methods vary depending on the event controller. Please refer to the specific event 

controller user manual for detailed instructions. 
 

Management Console 

The management console is designed for centrally managing multiple multimedia playback and 

control software instances within a local area network. It enables operators to manage multiple 

screens simultaneously and perform one-click control of all displays. Any playback and control 

software on the same LAN can act as the management console, actively discovering and 

connecting to other instances (or clients). 

Prerequisites 

The management console and all clients must be on the same LAN with normal network 

communication. 

Notes 

 A single client can be discovered by multiple management consoles, but can only be 

connected to by one management console. 

 If a client's device operates in a primary/backup mode, the management console will only 

take over the client on the primary device.  

 The management console requires significant disk space to store project files and associated 

media assets. 

Operating Procedure 

Step 1 On the software startup interface, click Console on the right, or click the management console 

icon  in the main interface's toolbar. 



 
Kompass FX3 Pro Multimedia Playback Software Basic Edition 

User Manual 

 

 

www.novastar.tech 161 
 

Step 2 In the management console dialog box, locate and select the target clients you wish to manage 

from the client list, identifying them by name and IP address. 

Figure 10-1 Management console 

 

The console will automatically detect clients in the local area network and display them in the 

client list. On the right side of the name, Local indicates the local client used as the 

management console. 

Connection statuses: 

 : Not connected 

 : Connected 

 : Offline 

Related actions: 

 Rename clients: Right click the client, and select Rename from the pop-up menu. Enter a 

new name in the text box and press the Enter key, or click anywhere else in the interface. 

 Refresh list: Click  to retrieve the client information in the local area network again. 

 Delete clients: Select the connected clients and click  to remove them from the list and 

disconnect them from the management console. Select a client in the list and press the 

Delete key to delete the client. The software does not support deleting the local client. 
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 The interface language can be switched via the dropdown in the top-right corner of the 

dialog. 

 Right click the client to pop up the context menu and you can select to connect, rename, 

refresh or delete. 
 

Step 3 Click , enter the password and click Connect. 

Navigate from the menu bar to Settings > System. In the dialog box that appears, select the 

Client tab, where you can enable or disable the verify password and set the connection 

password. 

Click  or  to show or hide the entered content. 

For a client that has been taken over, its interface will display Connected to Management 

Console. 

Step 4 Perform the following operations as needed. 

 Control playback state 

 

Select the scope of control from the dropdown, then click the function icons (Play, Pause, 

Stop) to control playback. This supports batch operations on multiple selected clients. 

 Edit projects 

Select a project, click Edit to enter the client's project operation interface. 

 Create new projects 

Click New to create a new project. 

 Switch projects 

Select a project from the list and click Switch to change the client's currently playing project 

to the selected one. 

Step 5 After client management ends, click the close button. In the pop-up dialog box, check or 

uncheck Disconnect all connections simultaneously, and click OK. 

 Checked: Closing the dialog box will simultaneously disconnect all connections to the clients. 

 Unchecked: When the dialog box is closed, the console will maintain its connections to the 

clients. After reopening the dialog box, you can continue to manage the client without re-

entering the connection password. 
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Related Operations 

After the client is taken over, if you need to disconnect from the management console, you can 

perform any of the following operations: 

 Click Disconnect from Console in the client interface. 

 On the desktop taskbar, right click  and select Show Main Window from the pop-up 

menu. In the pop-up dialog box, click Disconnect from Console. 
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 Graphics Card Mosaic 

Set Main Display 

Step 1 Right click on your desktop and select Display settings. 

Figure 11-1 Display settings 

 

Step 2 Select a display to set it as the main display. 

Figure 11-2 Multiple displays-1 

 

 

When multiple displays are connected, you can click Identify to show the number at the bottom 

left corner on each display. 
 

Step 3 For the Multiple displays item, select Extend these displays. 
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Figure 11-3 Multiple displays-2 

 

Step 4 On the window that appears, select Keep changes. 

Figure 11-4 Confirmation 

 

Step 5 Check the box next to Make this my main display. 

Change Resolutions 

Set Standard Resolutions 

Step 1 Right click on your desktop and select Display settings. 

Figure 11-5 Display settings 

 

Step 2 Select a display to set it as the main display. 
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Figure 11-6 Multiple displays-1 

 

 

When multiple displays are connected, you can click Identify to show the number at the bottom 

left corner on each display. 
 

Step 3 For the Display resolution item, select the desired output resolution. 

Figure 11-7 Multiple displays-2 

 

Step 4 On the window that appears, select Keep changes. 
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Figure 11-8 Confirmation 

 

Step 5 Repeat the above steps to complete the resolution settings for other displays. 

Set Custom Resolutions 

Step 1 Right click on your desktop and select NVIDIA Control Panel. 

Figure 11-9 NVIDIA control panel 

 

Step 2 On the NVIDIA Control Panel interface, go to Display > Change resolution. 

Figure 11-10 Change resolutions 

 

Step 3 Select the desired display. 

Step 4 Click Customize to show the customize window. 
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Figure 11-11 Custom resolution-1 

 

Step 5 Click Create Custom Resolution. 

Step 6 Read the disclaimer information carefully and click Accept to show the Create Custom 

Resolution window. 

Step 7 Select the desired display. 
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Figure 11-12 Custom resolution-2 

 

Step 8 Set the horizontal pixels, vertical lines, refresh rate and scan type. 

Step 9 Click Test and then click Yes on the window that appears. 

Figure 11-13 Confirmation 
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Figure 11-14 Custom resolution-3 

 

Step 10 Click OK to complete the custom resolution settings. 

After a custom resolution is created successfully, it will appear in the custom area as shown in 

the figure below. 

Figure 11-15 Custom resolution-4 
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EDID Management 

After the display resolution settings, you need to manage the EDID for precise identification of 

display properties and to avoid the on-site screen display disorder. 

Load EDID 

The procedure of how to load the EDID is as follows. 

Step 1 Right click on your desktop and select NVIDIA Control Panel. 

Figure 11-16 NVIDIA control panel 

 

Step 2 On the NVIDIA Control Panel interface, go to Workstation > View system topology. 

Figure 11-17 NVIDIA control panel 

 

Step 3 Click EDID (Monitor) next to a desired output connector of the current graphics card to show 

the EDID management window. 
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Figure 11-18 EDID (Monitor) 

 

Figure 11-19 Manage EDID 

 

Step 4 Click Export EDID and then name the exported EDID file in the window that appears. 

Step 5 Select the Load tab to show the EDID loading window. 

Step 6 Click Browse and then select the EDID file exported in Step 4. 

Step 7 In the Select Connector to force EDID area, select the desired connector. 
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Figure 11-20 Load EDID 

 

Step 8 Click Load EDID. 

Step 9 On the dialog box that appears, click OK to complete loading the EDID. 

Figure 11-21 EDID loaded successfully 

 

Step 10 Go back to Workstation > View system topology to check the EDID status. If the original EDID 

(Monitor) changes to EDID (File), the EDID is loaded successfully. 

Figure 11-22 EDID loaded successfully 
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Unload EDID 

The procedure of how to unload the EDID is as follows. 

Step 1 On the NVIDIA Control Panel interface, go to Workstation > View system topology. 

Step 2 Click EDID (File) to show the EDID management window. 

Figure 11-23 EDID (File) 

 

Step 3 Select the Unload tab and then select the desired connectors. 

Figure 11-24 Unload EDID 

 

Step 4 Click Unload EDID. 

Step 5 After the EDID is unloaded successfully, click OK on the dialog box that appears. 
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Figure 11-25 EDID unloaded successfully 

 

Step 6 Go back to Workstation > View system topology to check the EDID status. If the EDID (File) 

changes to EDID (Monitor), the EDID is unloaded successfully. 

Output Mosaic 

The graphics card supports connector mosaic output. The output connector mosaic must 

observe the following rules. 

 The graphics card does not support irregular mosaic layouts. The mosaic layout must be 1×2, 

1×3, 1×4, 2×2, 2×1, 3×1 or 4×1. 

 The output resolutions of the graphics card connectors that are used for mosaic must be the 

same. 

Step 1 Right click on your desktop and select NVIDIA Control Panel. 

Figure 11-26 NVIDIA control panel 

 

Step 2 On the NVIDIA Control Panel interface, go to Workstation > Set up Mosaic. 
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Figure 11-27 Set up mosaic 

 

Step 3 Click Create new configuration to show the mosaic settings window. 

Figure 11-28 Mosaic settings 

 

Step 4 Select the screen number from the drop-down list of Number of displays. 

Step 5 Select the screen mosaic layout from the drop-down list of Topology (rows x columns). 

Step 6 Select the screen orientation from the drop-down list of Orientation of displays. 

Step 7 Click Next to proceed. 
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Figure 11-29 Select displays 

 

Step 8 Select the connected displays and then select their refresh rate and resolution. 

Step 9 Click Next to proceed. 

Figure 11-30 Arrange displays 

 

Step 10 Arrange the displays according to the screen arrangement and structure by dragging the 

available displays to the corresponding topology areas. 
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Figure 11-31 Arrange displays 

 

Step 11 Click Apply and then click Yes on the confirmation window. 

Step 12 Click Next to proceed. 

Figure 11-32 Adjust overlap and bezel correction 

 

You can perform overlapping adjustment or bezel correction to the vertical or horizontal edges 

of the display as needed. 
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1. Select whether to use the same settings for all the vertical or horizontal edges of the display 

in the Select how overlap/bezel correction is applied area. 

2. Select the desired edges and then enter the overlap or bezel correction values for the 

selected edges. Click Apply after the settings are done. 

Step 13 Click Finish to complete the mosaic settings. 

Figure 11-33 Mosaic completed 
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