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1 Software Introduction 

VMP, short for Vision Management Platform, is an application in the brand-new control system COEX series. 

Featuring innovative interaction design and plenty of practical functions, such as project management, screen 

configuration, input settings, display correction, color processing, screen settings, system backup, monitoring and 

maintenance, screen brightness schedule, and preset management, it provides users with an efficient and easy 

operation and control experience. 

 Easy and convenient management at screen level 

Devices of the same model and version can be added to the same screen for management, allowing for 

batch operations and greatly increasing work efficiency. 

 Fast and flexible configuration 

The cabinets can be quickly connected, flexibly arranged and aligned, significantly simplifying screen 

configuration. 

 Distinct topology area and properties areas 

The screen topology is clear at a glance, the input source can be previewed in real time in the topology area 

and various properties can be easily set. 
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2 UI Introduction 

Figure 2-1 UI Introduction 

 

Note: 

All the figures in this document use operations in Windows10 as examples. 
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3 Install VMP 

3.1 Windows 

Prerequisites 

 The VMP software package is prepared. 

 A computer meeting the following requirements is available. 

− OS: Windows 10 (64-bit) or later 

− CPU: i5 or later 

− RAM: 8 GB or greater 

Note: 

ARM-based Windows computers are not supported. 

Installation Method 

Run the Coex VMP Setup.exe and follow the setup wizard to complete the installation. If a firewall prompt 

appears, choose to allow the installation. 

Installation Result 

If the installation is successful, the VMP software shortcut  appears on the desktop. 

3.2 MacOS 

Prerequisites 

 The VMP software package is prepared. 

 A computer meeting the following requirements is available. 

− OS: MacOS 10.15 or later 

− CPU: Intel i5 or Apple M1 or later 

− Memory: 8GB and above 

Installation Method 

Step 1 After the installation package is downloaded, click Finder on the desktop, enter the Downloads page, 

and double-click the package to open VMP.dmg. 

Step 2 Hold down the control key, click  and select Open. 
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Figure 3-1 VMP for Mac 

 

Step 3 In the Install VMP window, follow the installation guide to complete installation. 

Figure 3-2 Install VMP 

 

Installation Result 

If the installation is successful, the following window is displayed and the VMP software shortcut  appears in 

Launchpad. 
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Figure 3-3 Successful installation 

 

4 Device Management 

4.1 Connect Online Controllers 

Via Ethernet Cable 

Connect the controller and the control PC directly via Ethernet cable and set a static IP address for the controller 

to let the controller and control PC be on the same network segment. The MX40 Pro LED display controller is 

used as an example in this section. 

Step 1 Follow Figure 4-1 to complete the hardware connection. 

Figure 4-1 Connecting devices via Ethernet cable 

 

Step 2 Press the knob of the controller to enter the menu and choose Communication Settings > Network Settings. 

Step 3 Set Mode to Manual. 

Step 4 Set IP Address, Subnet Mask and Default Gateway and ensure the controller and control PC are on the same 

network segment. 

To reset the network settings to the default values, please select Reset and press the knob. 
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Step 5 After the settings, select Apply and press the knob. 

Via LAN 

Connect the controller and the control PC to the same LAN via a router and set the controller to automatically 

obtain an IP address. The MX40 Pro LED display controller is used as an example in this section. 

Step 1 Follow Figure 4-2 to complete the hardware connection. 

Figure 4-2 Connecting devices via LAN 

 

Step 2 Press the knob of the controller to enter the menu and choose Communication Settings > Network Settings. 

Step 3 Set Mode to Auto. 

Step 4 Select Apply and press the knob. 

Related Information 

 If the controller and the control computer are on the same LAN but on different subnets, the controller may not 

appear in the project list after connecting. To resolve this, you can search for the controller by its IP address and 

add it to the project list. For detailed instructions, please refer to 4.3.2 Adding Controllers via IP Search. 

 The online controllers that are connected will be categorized according to the projects, screen groups, and 

individual screens of each controller. Any new controllers will be shown in the default project. 

 For card-based controllers like the MX6000 Pro and MX2000 Pro, you can install different models of output 

cards for the same controller. However, output cards with different Ethernet port bandwidths (1G/5G) do not 

support loading the same screen. 

4.2 Add Offline Controller 

Before the LED screen is constructed on-site, you can add offline controllers and pre-configure the screen 

settings. You can then easily import the pre-configured project settings for swift and hassle-free usage of the 

LED screen. 

Operating Procedure 

Step 1 From the menu bar, choose Tools > Offline Mode > Enter Offline Mode. 

Step 2 Click  at the top left and then select Add Controller to add offline controllers. 

Step 3 Add one or multiple devices as needed. 
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You can add up to 100 offline controllers in VMP and only 25 controllers can be operated at the same time. For 

card-based controllers, you can run up to 4 fully-configured MX6000 Pro or 12 fully-configured MX2000 Pro at 

the same time. 

When the number of controllers exceeds the limit, some controllers will enter sleep mode. You can wake them by 

clicking on the sleeping controller or its associated screen, which will also wake up any offline controllers linked to 

that screen. Meanwhile, the system will put the controllers that haven't been used for the longest time into sleep 

mode. 

Step 4 Click Add Controller in the pop-up window. 

To add multiple controllers of the same model, click Batch Add. 

Figure 4-3 Add controller 

 

Step 5 Enter the controller model, controller name, and IP address. 

For card-based controllers like the MX6000 Pro and MX2000 Pro, click  to enter the input/output card 

model. You can install different models of output cards for the same controller. However, output cards with 

different Ethernet port bandwidths (1G/5G) do not support loading the same screen. 

Click  to copy the current controller and click  to delete it. 

Step 6 Click OK once you are done. 

Related Information 

 The added offline controllers will be displayed at the bottom of the selected project/screen. 

 When no target is selected, added offline controllers will be displayed at the bottom of the Default Project. 

 In offline mode, when configuring the screen, it's possible to mix cabinets of different sizes with the same model 

receiving cards. 

 To exit offline mode, choose Tools > Offline Mode > Exit Offline Mode, or close VMP and reopen it. 

4.3 Manage Project List 

The project list is categorized into four levels: project, screen group, screen, and controller. Screen groups, 

screens, and controllers can be added to the project for centralized management and batch operations. 
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This chapter will introduce the operations related to the project list by using the example of creating a new 

project and screen. 

4.3.1 New Project/Screen Group/Screen 

Step 1 To create a project, click  and then select New Project from the pop-up menu. 

To delete a project, right-click the project and then select Close from the pop-up menu. 

Figure 4-4 Project list 

 

Step 2 To create a screen/screen group, click  and then select New Screen Group/New Screen. 

 When you have multiple screens in the project, you can drag a screen to overlap with another one and create a 

screen group. 

 You can drag and drop a screen group or screen to another project. 

Step 3 You can also drag and drop a controller to another screen. 

 Controllers and output cards of different models or firmware versions cannot be added to the same screen. 

 Dragging a controller to a new screen will apply all the sending card parameters of that screen. 

 Click the  icon at the top right of the list to hide controllers and only show projects, screen groups, and 

screens. 

4.3.2 Adding Controllers via IP Search 

If the controller and the control computer are on the same LAN but on different subnets, the controller may not 

appear in the project list after connecting. To resolve this, you can search for the controller by its IP address and 

add it to the project list. 

Step 1 Click  and then select Add Controller from the pop-up menu. 
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Step 2 Enter the IP address and verify the controller's status, name, and model. 

Step 3 Click OK to add the controller to the project list. 

4.3.3 Unified Settings Adjustment for Projects/Screen Groups 

By selecting a project or screen group, you can uniformly control the screens within the group/project and 

perform various batch operations. 

 View the number of screens, controllers, and cabinets, along with their current operating status. 

 Adjust image quality settings, such as brightness, color temperature, and color gamut. 

 Control the display, including functions like blacking out the screen or freezing the image. 

 Easily switch between saved preset configurations. 

 

4.3.4 Rick-click Menu 

Rename 

Right-click a project/screen group/screen/controller and then select Rename from the pop-up menu. 
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Screen Control 

Right-click a project/screen group/screen/controller and then select Blackout or Freeze from the pop-up 

menu. 

Enable Mapping 

Right-click on a screen/controller and select Mapping, Controller Identify, and Canvas Mapping from the 

pop-up menu. 

 Mapping 

Activating the Mapping feature allows you to clearly identify the location and wiring path of the receiving 

cards. 

 Controller Identify 

Turn on the controller identify feature and set the display color on the controller's LCD. This will help you 

quickly identify the controller. 

 

 Canvas Mapping 

Enable the canvas mapping feature to quickly view the position of the canvas on the LED screen. 

Controller Properties 

Right-click a controller and then select Controller Properties to open the corresponding interface. 
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 Date and Time 

− Auto Sync: 

1. Toggle on Automatic Time Setting ( ). You can choose to sync from either the Computer or an 

NTP Server. 

 If you select Computer, the controller's time will be synchronized with the control computer's time. 

 If you select NTP Server, you can manually enter the NTP server address and select your timezone 

and daylight saving settings to obtain the correct time for the chosen timezone. 

2. Click Sync Now to complete the time setting. 

− Manual Adjustment: 

Toggle off Automatic Time Setting ( ) and click Controller Time to manually adjust the time. 

 Basic Information 

Check the controller model, SN, firmware version, IP address, MAC address, etc. 

 Detailed Information 

Click  to expand the panel and check the detailed controller hardware and software information. 

 Input/Output Card Information 

Check the input/output card name, model, SN, firmware version, hardware version and other information 

when connecting to card-based controllers (MX6000 Pro and MX2000 Pro). 

 Export Logs 

Click Export Log, select a location, set the file name, and click Save. 

4.4 Export and Import Project 

Export the project files (.nprj) so that you can import the files to apply the configuration data to the same kind of 

controllers, improving the configuration efficiency. 
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Prerequisites 

The project file can be imported to a controller that is of the same model. For card-cased controllers (MX6000 

Pro and MX2000 Pro), you also need to make sure the card slot and model in the file match the controller. 

 If the project file version is higher than that of the controller, you will be prompted to upgrade the controller 

firmware during the import. Please note that the features of the new version will not be supported by the 

controller. 

 If the project file version is lower than that of the controller, you can import it without any issues. 

Export Project Files 

Step 1 From the menu bar, choose Project > Export and select a project. 

You can also right-click a project and select Export from the pop-up menu. 

Step 2 Select a local directory and click Save. 

Figure 4-5 Successful export 

 

Import Project Files 

Step 1 From the menu bar, choose Project > Import and select a device or device group. 

You can also right-click a project and select Import from the pop-up menu. 

Step 2 Select a local project file and click Open. 

After successful device matching, a dialog box as shown in Figure 4-6 is displayed. 
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Figure 4-6 Matching devices 

 

Step 3 Click OK. After importing, the original screen and controller names will be overwritten. 

Figure 4-7 Successful import 

 

4.5 Manage Peripherals 

VMP supports detecting all 3D emitters, multifunction cards, and light sensors connected to the project 

controllers, as well as enabling power control through the multifunction cards. 

Applicable Products 

 3D emitters: EMT200, EMT200 Pro 

 Multifunction card: MFN300 

 Light sensor: NS060 

Notice 

 When system backup is set, only the primary controller/card/Ethernet port can detect and read information from 

multifunction cards and light sensors. Backup controller/card/Ethernet port does not support detecting or 

reading this information. 

 It is recommended to connect the multifunction card to port 1 of the controller. For the multifunction card 

MFN300-B V4.4.2.0 and above, connect to any of the first 16 ports of the controller. 
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 If multiple controllers with light sensors are connected to the same screen and are placed in environments with 

different brightness levels, ensure proper communication between the controllers when adjusting screen 

brightness via the brightness strategy table. Otherwise, inconsistencies in screen brightness may occur. 

Related Information 

 Light sensor ambient brightness rules: The light sensor checks the brightness every 10 seconds and adjusts 

every minute. During adjustment, it discards the highest and lowest values from the five most recent readings 

and calculates the average to determine the ambient brightness. 

 A single controller can connect to multiple multifunction cards, with each card supporting up to four light 

sensors. When multiple light sensors are connected, the average ambient brightness from all sensors is used. 

Operating Procedure 

Step 1 Select a project from the project list. 

Step 2 In the Peripheral section of the project list, you can check the 3D emitters and multifunction cards 

connected to all the controllers within the project, as well as the light sensors connected to the 

multifunction cards. 

Figure 4-8 Check peripheral (multifunction card) 

 

Step 3 Select a peripheral to view its information in the properties area on the right. 

 3D emitter: You can view the model, position, and firmware version. 

 Multifunction card: You can view the model, position, and firmware version. 

 Light sensor: You can view the position and ambient brightness. 

Light sensor ambient brightness rules: The light sensor checks the brightness every 10 seconds and adjusts 

every minute. During adjustment, it discards the highest and lowest values from the five most recent readings 

and calculates the average to determine the ambient brightness. 

Step 4 Perform power control operations as needed. 
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Figure 4-9 Power control 

 

Select a multifunction card and set the power control mode in the properties area on the right. You can choose 

between the auto and manual mode. You can also click Power on or Power off to control the state of all power 

channels. 

 Manual mode: Set the state of each individual power channel. 

 Auto mode: Different start and shutdown times can be set for each power channel, with default times retrieved 

from the multifunction card. 

4.6 Art-Net Control 

Enable the Art-Net protocol switch to realize control via third-party controller. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

To apply the Art-Net protocol, make sure the transmitter ends (such as console and control PC) and the receiver 

ends (such as LED display control system and lighting system) are on the same LAN. 

Related Information 

After the Art-Net protocol switch is enabled, the configured parameters cannot be modified. For the protocol 

details, see Art-Net Protocol Instructions. 

Operating Procedure 

From the menu bar, choose Tools > Control, enable the Art-Net switch. Set the Start Address and complete the 

Source, Image Quality and Preset parameter configurations. 



 

VMP Vision Management 

Platform User Manual  
   

 

www.novastar.tech   16 
 

 

Figure 4-10 Art-Net 
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5 Screen Configuration 

5.1 Edit Screens 

Edit the settings of the selected screen. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Layout. 

Figure 5-1 Layout 

 

Step 2 Click Edit in the properties area on the right. 

Step 3 Enter a screen name on the pop-up window. 

Figure 5-2 Edit screen 

 

Step 4 Select a Working Mode. When operating as a Send-Only Controller, the display latency is reduced by 1 frame. 

Step 5 Set Low Latency. 
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When low latency is set to , the latency at the data sending end is reduced by 1 frame. 

Step 6 When a card-based controller (MX6000 Pro or MX2000 Pro) operates as a Send-Only Controller, you 

also need to do the following. 

1. Choose a layer alignment from the four options. 

For , , or , you can adjust the layer size by dragging the layer divider, or setting a value under 

the Canvas Size section. 

 

2. Set the state of Pixel to Pixel. 

When Pixel to Pixel is enabled ( ), it will output the display based on the size of the input source in a 

pixel-to-pixel manner. 

When Pixel to Pixel is disabled ( ), the input source will automatically scale to fill the layer based on the 

configured layer size. 

Step 7 Click OK once you are done. 

Note 

Please note the following when using the low latency function: 

 Low latency, frame multiplication, and 3D cannot be enabled at the same time. 

 When low latency is enabled, the sync source cannot be set to Genlock. 

 To enable low latency, please make sure all Ethernet ports load the cabinets vertically and share the same Y 

coordinate. Free screen configuration (for example, Ethernet port 2 loads cabinets horizontally, or its Y 

coordinate is different from that of Ethernet port 1) will reduce the load capacity. For specific calculations, 

please contact NovaStar technical support. 
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5.2 Set Canvas Size 

Step 1 Select a screen from the project list and then select Layout. 

Step 2 In Canvas section, select a pre-defined resolution from the drop-down list or customize the width and height of 

the canvas. The maximum supported setting is 16,384. 

The system will automatically calculate the maximum frame rate for the canvas based on the current resolution. 

Figure 5-3 Canvas 

 

Step 3 Select the canvas in the canvas area and enter the X and Y coordinates to adjust the canvas starting position. 

Step 4 When a card-based controller (MX6000 Pro or MX2000 Pro) operates as a Send-Only Controller, you can set the 

layer divider. 

For , , or , you can adjust the layer size by dragging the layer divider, or setting a value for the 

divider. 

 

5.3 Configure Screen Topology 

Configure the cabinet topological diagram to complete the logical connection of the cabinets. 

Prerequisites 

The controller is connected and cabinets are connected to the controller. 



 

VMP Vision Management 

Platform User Manual  
   

 

www.novastar.tech   20 
 

 

Operating Procedure 

Step 1 Select a controller from the project list and then select Layout. 

Figure 5-4 Layout 

 

Step 2 Select a view for the topology area, and choose what to display on the topology. 

Select a view or switch pages by clicking one of the icons in the top right corner of the topology area: 

 : Show the cabinets only. 

 : Show the preview image of the input source only. 

 : Show both the cabinet and the input source preview, with the cabinet on top. 

 : Show both the cabinet and the input source preview, with the input source on top. In this view, you can 

click  to navigate to the Source interface, then click and hold the left mouse button within the topology 

to select and move layers. 

 : Click to enable Source Snapshot. When this is enabled, the source playback in VMP will freeze on the last 

frame and the display on the LED screen will not be affected. Users can then adjust screen settings based on the 

frozen image without needing to look at the LED screen. To disable Source Snapshot, simply click the icon 

again. 

 : Click to switch pages in the dropdown menu. VMP supports a fixed total of 8 pages. When 

multiple screens are displaying the same content, you can configure screen layout at different pages and choose 

to show or hide them as needed. Click  to clear all topologies. 
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In the topology area, you can choose to display the cabinet topology, cabinet status, group names, source tags, 

and overlapping cabinets. 

Step 3 Select an Ethernet port at the bottom and then drag or click the mouse in the topology area to add cabinets. 

Note 

Offline projects created in In VMP V1.5.0 allow a single Ethernet port to support 512 cabinets. However, for 

projects created in versions prior to V1.5.0, the maximum number of cabinets per port remains capped at 32. 

The cabinets will be automatically connected when you are adding them, as shown in Figure 5-5. The Ethernet 

port's load capacity information will be displayed, as shown in Figure 5-6. The properties area will display the 

cabinet specifications, as shown in Figure 5-7. You can also select a custom cabinet and click Edit to modify the 

specifications of the cabinet. 

Figure 5-5 Cabinets connected automatically 

 

Figure 5-6 Ethernet port capacity 

 

 16/-: Indicates that Ethernet port 1 has 16 cabinets added to the topology. 

 90%: Indicates these 16 cabinets have used 12% of the Ethernet port's capacity. 
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Figure 5-7 Change cabinet model (only available in offline mode) 

 

Note 

 Swift Layout: To use the Swift Layout feature, all Ethernet ports must have cabinets with the same model, 

resolution, quantity, and topology. Additionally, there should be no single cabinet completely outside the 

canvas. When these conditions are met, the Swift Layout feature can quickly add and connect cabinets for 

all Ethernet ports. 

 Operating procedure: Click  and then drag the mouse on the canvas to add cabinets that 

match the actual requirements. In the properties area, select a layout and click Done. 

Step 4 Select other Ethernet ports and continue to add cabinets until all cabinets are connected. 

Step 5 For cabinets that have the same size and consecutive serial numbers, if you want to change the cabinet 

connection topology, select the cabinets and then select a quick topology under Quick topo in the properties 

area, as shown in Figure 5-8. For other cabinets, skip this step. 

Figure 5-8 Quick topology 

 

Step 6 Do any of the following to arrange, align, or copy the cabinets and cabinet groups to let the cabinet positions 

meet the display requirements. 
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 Use the function buttons 

 

− 1:1: The canvas size equals to the input source resolution. 

− Zoom To Selection: The selected element is zoomed and displayed in the center of the canvas. 

− Fit Screen: The canvas size is automatically adjusted to fit the topology area size. 

− Coordinate Ruler: Show coordinate ruler on the left and top sides of the canvas. 

Click  to show its drop-down menu shown below. The menu can be used to set the canvas grid. 

 

− Grid: When the switch is in the  status, a grid is displayed on the canvas. If you do not need to 

display the grid, set the switch to . 

− Color: Set the grid color. 

− Spacing: Set the spacing of horizontal and vertical lines of the grid. The spacing is set to the resolution of 

the first cabinet by default. 

− Snap to Cabinet: When positioning a cabinet near another one, the cabinet being moved will 

automatically align and snap to the edge of the adjacent cabinet, effectively eliminating gaps. 

− Snap to Grid: The cabinet will be snapped to the grid. 

Click  to enable the manual cabinet topology adjustment. 

− Left-click a cabinet to manually connect any unconnected cabinets or to adjust or remove existing 

connections. 

− Right-click a cabinet to assign an Ethernet port to the selected cabinet. 

Only unused Ethernet ports can be assigned, and once assigned, all cabinets in the connection will be 

redirected to the new port. 
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 Use the function menus on the menu bar 

− Edit menu 

 

− View menu 

 

 Right click the cabinet 

 

Select String: Select all the cabinets on the connection line of the current cabinet. 

Swap: Swap the positions of the two selected cabinets. 
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Group: Group the selected cabinets. To set the group name and color, please select the group and set 

them in the properties area. 

Ungroup: Ungroup the cabinets. 

Add to: Add the selected cabinets to a group. 

Move to: Move the selected cabinets to the chosen page (only supports selecting cabinets from the same 

string). 

Specify Port: Move the selected cabinet to the chosen Ethernet port (only supports selecting cabinets 

from the same string). 

Copy: Duplicate the selected topology, including the cabinets and connection. 

Paste: Insert the copied topology. 

 Set cabinet coordinates and rotation 

Select a cabinet and set its coordinates and rotation angle in the properties area. After the cabinet is 

rotated, the input source will be rotated by the set angle and displayed. 

The cabinet rotation in 90° increments feature is only supported by certain models of receiving cards, as 

detailed below: 

Table 5-1 Receiving cards supporting cabinet rotation 

Model Description 

XA50 Pro, CA50E, A10s Pro and its derivative cards. Supported by all versions. 

A5s Plus, A7s Plus, A8s-N, A8s Pro and its derivative cards. Supported by V4.9.0.0 or later. 

5.4 Set the Cabinet 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Navigate to Layout and select a screen. Do any of the following operations in the cabinet settings area. 

Figure 5-9 Cabinet settings 
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 Control Display Status 

Set the Blackout or Freeze switch to . 

 Enable Indicator 

If the cabinet has a running status indicator, you can set the Indicator switch to . 

- Green: The cabinet is fully within the canvas, with normal temperature and voltage. 

- Yellow: The cabinet is partially outside the canvas, with temperature or voltage warnings. 

- Red: The cabinet is completely outside the canvas, with temperature or voltage faults. 

- Gray: The cabinet is offline. 

 Enable the Light Up Slowly Function 

Set the Light up slowly switch to  so that after the screen is powered on, the display brightness will 

slowly change from 0 to the target value. 

 Set Test Pattern 

Select a test pattern from the drop-down list of Test Pattern to perform screen aging test and troubleshoot 

problems. 

 Set Image for Abnormal Situations 

Select an option from the No data signal drop-down list. 

− Blackout: The screen displays a black image. 

− Last Frame: The screen always displays the last frame. 

5.5 Set OPT Ports 

Applicable Products 

MX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Layout. 

Step 2 Set the output mode of the OPT ports under OPT Settings. You can choose either 20 Ports Mode or 40 

Ports Mode. 

 20-port mode: 

− OPT 1 transmits the data of Ethernet ports 1 to 10. OPT 3 is the copy channel of OPT 1. 

− OPT 2 transmits the data of Ethernet ports 11 to 20. OPT 4 is the copy channel of OPT 2. 

− You can use the optical port alongside the physical Ethernet port, with priority given in the following 

order: OPT 1/2 > OPT 3/4 > Ethernet ports 1–20. 

 40-port mode: 

− OPT 1 transmits the data of Ethernet ports 1 to 10. 

− OPT 2 transmits the data of Ethernet ports 11 to 20. 
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− OPT 3 transmits the data of Ethernet ports 21 to 30. 

− OPT 4 transmits the data of Ethernet ports 31 to 40. 

− You can use the optical port alongside the physical Ethernet port, with priority given in the following 

order: OPT 1/2 > Ethernet ports 1–20. 

Figure 5-10 OPT settings 

 

Note 

 When both the optical and Ethernet ports are used simultaneously, please do NOT connect the controller's 

Ethernet port with the same number as the one of the optical port to the receiving card at the same time. If 

they are connected simultaneously, the display effect of the optical port will take precedence. 

 When Ethernet port backup is enabled in 40-port mode, the last 20 Ethernet ports backs up by the first 20 

Ethernet ports. When switching to the 20-port mode, please remember to remove the loop backup setup of 

the receiving card. 

 While in the 40-port mode, additional Ethernet ports can be used to create easier screen topology without 

reducing the controller's maximum load capacity. 
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6 Input Source Configuration 

6.1 Set Layers 

Add layers and set the layer properties. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

 For single-card controllers (MX40 Pro, MX30, MX20, KU20, CX40 Pro), the Layers function is only available while 

under All-In-One Controller mode. Please refer to 5.1 Edit Screens for more details. 

 For card-based controllers (MX6000 Pro and MX2000 Pro), the Layers function is available for both All-In-

One Controller and Send-Only Controller modes. 

− All-In-One Controller supports free layer layout. 

− Send-Only Controller follows a fixed layer layout with a predetermined layer quantity. 

Related Information 

The maximum number of layers that can be added depends on the connected controller. When the supported 

layer quantity is 1, layer position, border, input crop and other operations are not supported. 

Controller Model Number of Supported Layers 

MX40 Pro 4 

MX30 3 

MX20 3 

KU20 1 

CX40 Pro 3 

MX6000 Pro (Each output card supports 4 layers, and up to 8 output cards can be used at the 

same time.) 

MX2000 Pro (Each output card supports 4 layers, and up to 2 output cards can be used at the 

same time.) 

Operating Procedure 

Step 1 Select a controller from the project list and then select Source. 
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Figure 6-1 Input source 

 

Step 2 Select an input card at the bottom of the page when there are multiple input cards. 

Step 3 Double-click the thumbnail of the input source or drag the input source to the target position to add a layer. 

You can check the source status according to the source indicator: 

 Green: The input source is connected. 

 Red: The input source is being used for the screen but not connected. 

 Gray: The input source is not connected. 

Step 4 Make layer adjustments as needed. 

 Lock layer 

 

 Switch source 

− Select a layer and select another source in the properties area. 

 

− Right-click a layer, select Source from the displayed menu, and select another source. 

 Adjust layer size and position 

− Select a layer and set the layer size and coordinates in the properties area. You can also bring the layer 

to front or send it to back. 
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− Right-click a layer and select Bring to Front, Send to Back, Bring Forward or Send Backward from the 

displayed menu. 

− At the top right of a layer, click a function icon to set the layer. 

: Lock the layer. 

: Unlock the layer. 

: The layer size is the same as the input source resolution. 

: The layer automatically fill the screen. 

: The layer size changes automatically according to the canvas size. 

: Delete the layer. 

 Set borders 

Select a layer and enable or disable the layer borders function in the properties area. After enabling the 

function, you can set the border thickness and color. 

 

 Crop the input source 

Select a layer and enable or disable the Crop function in the properties area. Then, you can set the crop size 

and position on the thumbnail of the layer. You can also make adjustments by setting the parameter values 

below the thumbnail. When Same as Layer Size is set to , the input source image will be cropped 

according to the layer size. 
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6.2 Set External Sources 

Select a controller from the project list and then select Source. Select an external source from the source list and 

do the following as required. 

6.2.1 Set Connector Capacity 

When installing an 8K input card in a card-based controller, it is necessary to configure the connector capacity 

for the input source in order to calculate the layer resources of the input connectors. 

Applicable Products 

MX6000 Pro, MX2000 Pro 

Operating Procedure 

Select an option from the drop-down list and the system will automatically calculate the layer resources. Below 

takes the MX_2xDP1.4 input card as an example. 

 4096*2160@60Hz: Up to 4 layers can be added. 

 8192*2160@60Hz: The maximum number of layers that can be added is determined based on the size of the 

input source used in the currently enabled layers of the input card. For example: 

− When using two input sources of 8192×2160@60Hz, a maximum of two layers can be added. 

− When using one input source of 8192×2160@60Hz and two input sources of 4096×2160@60Hz, a 

maximum of three layers can be added. 

Figure 6-2 Connector capacity 

 

6.2.2 Set Resolution and Refresh Rate 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Related Information 

If the resolutions of the input source and screen are the same, the image can be displayed pixel to pixel. 

A lower frame rate may result in image flickering, while a higher refresh rate helps stabilize the display image. 

Operating Procedure 

Select a value from the drop-down lists of Resolution and Refresh Rate and click Apply. 
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Figure 6-3 EDID 

 

6.2.3 Adjust the Color 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Step 1 In the InfoFrame Override area, select a value from the drop-down lists of Color Space/Sampling, Gamut and 

Quantization Range. 

The override parameter will be used in the calculation of color adjustment. Select From Input and the software 

will read the attribute value that comes with the input source. 

Figure 6-4 InfoFrame override 

 

Note 

When selecting the color space/sampling as YCbCr 4:2:0, the input source resolution's height must be an even 

number, and the width must be a multiple of 8. 

Step 2 In the Color area, drag the sliders to adjust the parameter values. 
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Figure 6-5 Color 

 

Table 6-1 Descriptions of color adjustment parameters 

Parameter Description 

Black Level It is used to adjust the brightness of the dark areas of the image. The smaller the 

value, the darker the dark part of the screen. 

Contrast It is used to adjust the brightness of the highlight areas of the image. The greater 

the value, the brighter the highlight part of the screen. 

Contrast and black level together affect the overall contrast of the image. 

Saturation It is used to adjust the color purity of the image. The greater the value, the more 

vivid the color. 

Hue It is used to adjust the color effect of the displayed image color. Generally, it is 

divided into warm, cool and intermediate tones. 

Red Shadow/Green 

Shadow/Blue Shadow 

It is used to adjust the brightness of the dark areas of the image. The principle is 

the same as that of black level, but only the RGB components are adjusted. 

Red Highlight/Green 

Highlight/Blue Highlight 

It is used to adjust the brightness of the highlight areas of the image. The principle 

is the same as that of contrast, but the RGB components are adjusted. 

6.2.4 Set HDR Parameters 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, CX40 Pro 



 

VMP Vision Management 

Platform User Manual  
   

 

www.novastar.tech   34 
 

 

Related Information 

Supports automatic parsing and manual setting of HDR. For 12G-SDI, DP1.2, and non-standard HDR sources, 

they can only be set to HDR properties manually. 

Using the HDR function together with receiving cards including the CA50E, XA50 Pro, and A10s Pro and its 

derivatives will not reduce the Ethernet port load capacity by half. For details, see the COEX series LED display 

controller specifications. 

Operating Procedure 

Select an HDR format from the drop-down list of Format and set related parameters. Select Auto and the 

software will read the attribute value that comes with the input source. 

Figure 6-6 HDR 

 

HDR10 parameters: 

 PQ Mode: The mapping method of video source brightness. 

− ST2084 (PQ): This mode 1:1 maps the brightness of the video source. The part that exceeds the 

maximum screen brightness will still be displayed as the maximum screen brightness. 

− ST2086 (Linear mapping): This mode linearly maps the brightness of the video source. It globally adjust 

the video source brightness according to the maximum screen brightness to ensure that the ratio of the 

brightness of the entire source content remains unchanged. 

 MaxCLL: The override value of the maximum video source brightness. MaxCLL takes effect when Override is 

selected. 

Note 

When HDR is enabled, the gamma value cannot be adjusted. In PQ mode, if HDR 2084 is selected, brightness 

adjustment is also not supported. 

HDR 2084 and brightness schedule cannot be enabled at the same time. If HDR 2084 is selected while the 

brightness schedule is already enabled, the brightness schedule will take precedence. 

6.2.5 Set ST 2110 Parameters 

When installing ST 2110 input cards in card-based controllers like the MX6000 Pro and MX2000 Pro, you need to 

configure the relevant parameters. 



 

VMP Vision Management 

Platform User Manual  
   

 

www.novastar.tech   35 
 

 

Applicable Products 

MX6000 Pro, MX2000 Pro 

Operating Procedure 

Step 1 Select the ST 2110 input card from the source list and navigate to the ST 2110 Settings in the 

properties area on the right. 

Figure 6-7 ST 2110 settings 

 

Step 2 When using the MX_1×ST 2110 (100G) input card, you need to configure the channel in the Interface 

Settings area. 

 1*8K UHD: The maximum resolution for a single channel is 7680×4320@60Hz. 

 4*4K UHD: The maximum resolution for a single channel is 4096×2160@60Hz. 

Step 3 Under the Video Stream section, you can set the ST 2110 port information using either of the 

following two methods. 

 Method 1: Click  to load the SDP file for configuration. 

 Method 2: Click Edit and fill in the below parameters to complete the OPT configuration. Once the setup is 

complete, you can export the current parameters as an SDP file. 

− Destination IP (primary/backup OPT ports) 

− Port (primary/backup OPT ports) 

− Source IP (primary/backup OPT ports) 
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− Select an option from the drop-down lists of Resolution, Refresh Rate, Color Space/Sampling, and Bit 

Depth. You can also set a custom resolution. 

Step 4 In the NMOS Settings section, set the NMOS control interface and registry mode, then click Apply. 

 Control Interface: Options include ETHERNET or ST 2110 SFP1. 

 Registry Mode: Options include mDNS, DNS-SD, and Static. 

Figure 6-8 NMOS 

 

Step 5 Set the primary and backup OPT IP addresses for the ST 2110 input card under the Primary OPT IP 

and Backup OPT IP sections. 

You can enter the IP address manually or simply toggle on Obtain Automatically. Remember to click Apply once 

you are done. 

Notes 

Please assign different subnet IP addresses to the optical ports on the ST 2110 card. Failure to do so may result in 

NMOS malfunctions due to network card routing issues. 

Example: (SFP1: 192.168.0.20, SFP2: 192.168.1.20). 

Step 6 Configure the input source synchronization under the PTP section. 

1. Enable or disable Input is Locked to PTP. Enabling this option allows for high-precision synchronization with 

the network's primary clock. 

2. Configure the PTP parameters, including Domain, Log sync interval, and Log delay request interval. 

3. Review the PTP status, which includes the Master Clock MAC, Time Lock Status, and Offset from Leader. 

Note 

 If the Time Lock Status shows Unlocked, enabling Input is Locked to PTP may result in display abnormalities. 

4. Remember to click Apply once you are done.  
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Figure 6-9 PTP 

 

Step 7 Adjust the on/off status for FEC Settings. 

Enabling this feature allows for automatic error detection and correction during data transmission, enhancing the 

reliability of video signal transmission. 

Note 

 Only supported by the MX_1×ST 2110 (25G) and MX_1×ST 2110 (100G) input cards. 

 The FEC feature must be configured on the switch before it can be used. 

Figure 6-10 FEC settings 

 

Step 8 Review the IGMP multicast protocol version. 

6.3 Set Internal Sources 

Select the internal source and set the related parameters for screen testing and troubleshooting. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Step 1 Select a controller from the project list and then select Source. 

Step 2 Double-click the thumbnail of internal source in the source list at the bottom of the page, or select Internal 

Source from the drop-down list next to Select Source in the properties area on the right. 

Step 3 Select an image and set the Grayscale, Gradient Stretch, Speed, and Space. The adjustable parameters for each 

image may vary based on the interface. 

 Static images 
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These images come with VMP, as shown in the figure below. 

 

 Dynamic images 

These images come with VMP, as shown in the figure below. 

 

Step 4 Set the resolution, frame rate and bit depth for the internal source. 

 

Step 5 After the settings, click Apply.
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7 Display Correction 

This chapter describes output configuration with one device selected. 

7.1 Seams 

7.1.1 Correct Seams 

Adjust the seams between cabinets or modules to improve the display effect. 

Related Information 

If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it 

can be adjusted only in percentage. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Correction. 

Step 2 On the Seams tab in the properties area, toggle on the Seam Correction ( ). 

Note 

Currently, apart from the A10s Pro receiving card and its derivatives, the Seam Correction switch will not be 

displayed on this interface. In such case, simply toggling on the Brightness Calibration or Brightness and 

Chroma Calibration will ensure that the seam correction takes effect. 

Step 3 Toggle on Brightness Calibration or Brightness and Chroma Calibration to view the correction effect. 

 Brightness Calibration: Set the Brightness Calibration switch to  to make the screen apply the calibration 

effect made by the calibration platform. 

 Brightness and Chroma Calibration: Set the Brightness and Chroma Calibration switch to  to make the 

screen apply the calibration effect made by the calibration platform. 

The Brightness Calibration and Brightness and Chroma Calibration are mutually exclusive. 

Figure 7-1 Correction (seams) 

 

Step 4 Select a correction mode. 
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Figure 7-2 Select mode (seams) 

 

 Cabinet Seams: Correct the seams of cabinets. 

 LDM Seams: Correct the seams of modules. 

Step 5 When correcting the module seams, if you need to override the numbers of module columns and rows, 

click the  icon next to Select Mode and then perform the settings on the Cabinet Structure 

Override window. Otherwise, skip this step. 

Figure 7-3 Cabinet structure override 

 

Step 6 Set the screen display parameters and check the seam correction effect. 

Figure 7-4 Adjustment (7-color/4-color) 

  

 Brightness: Adjust the display brightness. 

 Display image: Set the image displayed on the screen. By default, the current input source is being displayed 

( ). You can switch to a monochrome display. The available colors depend on the model and version of the 

receiving card in use. Additionally, you can use the corresponding shortcut keys to switch between display 

modes. 

Note 

You can only configure the displayed image for the currently selected page. All other pages will show a black 

screen. 

Step 7 In the topology area, click or click and drag the mouse to select the seams to be corrected. 

Step 8 Set the adjustment parameters. 
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Figure 7-5 Set the parameters 

 

 Quick adjust: Has a large range of adjustment. 

 Fine Adjust: Has a large range of adjustment. 

 Hide cursor on screen: When this is enabled ( ), the cursor will not be displayed on the screen while adjusting 

brightness and chroma. 

Step 9 Place the mouse on the scroll wheel icon and adjust the brightness by dragging the wheel icon up or down, 

scrolling the mouse wheel, or using the keyboard shortcuts 1+↑/↓. 

 Restore: Restore the configuration to the last saved. 

 Reset: Reset the configuration to factory defaults. 

Step 10 After the settings, click Save. 

7.1.2 Erase Seam Correction 

Related Information 

If there are any changes made to the cabinets, such as moving a receiving card from one cabinet to another or 

replacing the cabinet module, it may cause bright or dark lines that had been previously corrected to appear in 

the middle of the cabinet or module. In such cases, you have the option to remove the seam correction that was 

applied. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Correction. 

Step 2 Select the Cabinet mode. 

Figure 7-6 Select mode (cabinet) 
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Step 3 Select the target cabinets and then click Erase to remove the seam correction that was applied to them. The 

erasion will be automatically saved to the hardware once you are done. 

Figure 7-7 Erase seam correction 

 

7.2 Correct Multi-Batch Cabinets/Modules 

Adjust the chroma of cabinets or modules from multiple batches to make the overall chroma of the display more 

balanced and uniform. 

Applicable Products 

The adjustable range varies depending on the model and version of the receiving card. 

 7-color multi-batch adjustment: Supported by XA50 Pro, CA50E, A10s Pro and its derivatives (version V1.5.3.0 

and above). 

 4-color multi-batch adjustment: Supported by A5s Plus, A7s Plus, A8s-N, A8s Pro and its derivatives, and B6s 

(version V1.3.0.0 and above). 

Related Information 

 When performing the adjustments, note that the 7-color multi-batch adjustment uses an independent matrix 

adjustment and will not affect the calibration coefficients. In contrast, the 4-color multi-batch adjustment is 

coupled with the calibration coefficients, and adjustments may slightly influence these coefficients. 

 If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it 

can be adjusted only in percentage. 

7-color Multi-batch Adjustment 

Step 1 Select a screen from the project list and then select Correction. 

Step 2 On the Modules tab in the properties area, toggle on Multi-batch ( ). 

Step 3 Toggle on Brightness Calibration or Brightness and Chroma Calibration to view the correction effect. 
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 Brightness Calibration: Set the Brightness Calibration switch to  to make the screen apply the calibration 

effect made by the calibration platform. 

 Brightness and Chroma Calibration: Set the Brightness and Chroma Calibration switch to  to make the 

screen apply the calibration effect made by the calibration platform. 

Figure 7-8 Correction (modules) 

 

Step 4 Select a correction mode. 

Figure 7-9 Select mode (modules) 

 

 Cabinet: Correct the multi-batch cabinets. 

 Module: Correct the multi-batch modules. 

Step 5 When correcting multi-batch modules, if you need to override the numbers of module columns and rows, click the 

 icon next to Select Mode and then perform the settings on the Cabinet Structure Override window. 

Otherwise, skip this step. 

Figure 7-10 Cabinet structure override 

 

Step 6 Set the screen display parameters and check the display effect. 
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Figure 7-11 Adjustment (modules) 

 

 Brightness: Adjust the display brightness. 

 Display image: Set the image displayed on the screen. By default, the current input source is being displayed 

( ). You can switch to a monochrome display in white, red, green, blue, cyan, magenta and yellow. To do so, 

simply press the shortcut keys W, R, G, B, C, M, Y, and Tab. 

Note 

You can only configure the displayed image for the currently selected page. All other pages will show a black 

screen. 

Step 7 In the topology area, click or click and drag the mouse to select the cabinets or modules to be corrected. 

Step 8 Adjust the parameters. Different colors have different adjustment parameters. Place the mouse on the scroll 

wheel icon and adjust the brightness by dragging the wheel icon up or down, scrolling the mouse wheel, or using 

the keyboard shortcuts 1+↑/↓. 

Figure 7-12 Adjustment (White/Red/Blue/Green/Cyan/Magenta/Yellow) 

 

 Restore: Restore the configuration for the current color to the last saved. 

 Restore All: Restore the configuration for all colors to the last saved. 
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 Restore to Last Saved: Restore the configuration to the last saved. 

 Hide cursor on screen: When this is enabled ( ), the cursor will not be displayed on the screen while adjusting 

brightness and chroma. 

 Import Coefs: Import the existing correction coefficients to the current cabinet/module. 

 Export Coefs: Export the correction coefficients of the current cabinet/module. 

Once a cabinet's parameters are set, you can right-click to copy the current cabinet's parameters and paste them 

to other cabinets. Alternatively, use the shortcuts Ctrl+C to copy and Ctrl+V to paste. 

Step 9 Click Save once you are done to save the configuration to the receiving card. 

4-color Multi-batch Adjustment 

Step 1 Select a screen from the project list and then select Correction. 

Step 2 On the Modules tab in the properties area, you can enable the correction switches including Brightness 

Calibration and Brightness and Chroma Calibration to view the correction effect. 

 Brightness Calibration: Set the Brightness Calibration switch to  to make the screen apply the calibration 

effect made by the calibration platform. 

 Brightness and Chroma Calibration: Set the Brightness and Chroma Calibration switch to  to make the 

screen apply the calibration effect made by the calibration platform. 

The Brightness Calibration and Brightness and Chroma Calibration are mutually exclusive. 

Figure 7-13 Correction (modules) 

 

Step 3 Select a correction mode. 

Figure 7-14 Select mode (modules) 

 

 Cabinet: Correct the multi-batch cabinets. 

 Module: Correct the multi-batch modules. 

Step 4 When correcting multi-batch modules, if you need to override the numbers of module columns and rows, click the 

 icon next to Select Mode and then perform the settings on the Cabinet Structure Override window. 

Otherwise, skip this step. 
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Figure 7-15 Cabinet structure override 

 

Step 5 Set the screen display parameters and check the display effect. 

Figure 7-16 Screen Control 

 

 Brightness: Adjust the display brightness. 

 Display image: Set the image displayed on the screen. By default, the current input source is being displayed. 

You can switch to a monochrome display in white, red, green, and blue. 

To do so, simply press the shortcut keys W, R, G, B, and Tab. 

Note 

You can only configure the displayed image for the currently selected page. All other pages will show a black 

screen. 

Step 6 In the topology area, click or click and drag the mouse to select the cabinets or modules to be corrected. 

Step 7 Adjust the parameters. Different colors have different adjustment parameters. Place the mouse on the scroll 

wheel icon and adjust the brightness by dragging the wheel icon up or down, scrolling the mouse wheel, or using 

the keyboard shortcuts 1+↑/↓. 
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Figure 7-17 Adjustment (White/Red/Blue/Green) 

 

 Restore to Last Saved: Restore the configuration to the last saved. 

 Hide cursor on screen: When this is enabled ( ), the cursor will not be displayed on the screen while adjusting 

brightness and chroma. 

 Import Coefs: Import the existing correction coefficients to the current cabinet/module. 

 Export Coefs: Export the correction coefficients of the current cabinet/module. 

Once a cabinet's parameters are set, you can right-click to copy the current cabinet's parameters and paste them 

to other cabinets. Alternatively, use the shortcuts Ctrl+C to copy and Ctrl+V to paste. 

Step 8 Click Save once you are done to save the configuration to the receiving card. 
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8 Color Processing 

This chapter describes output configuration with one device selected. 

8.1 Color Replacement 

Replace a color with another color according to the settings. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, CX40 Pro 

Notice 

Replacement of highly saturated colors is recommended for better effect. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Set the Color Replacement switch to . 

Step 3 Set the colors before and after replacement. 

 Method 1: Click the color area in  to open the color palette and set a color. 

 Method 2: Click the eyedropper in  and select a color in the topology area. 

Figure 8-1 Color replacement 

 

Step 4 Set Hue Tolerance, Hue Softness, Shadow Strength, and Skin Tone Protect. 

 Hue Tolerance: Indicates the hue range of the color to be replaced. The larger the value, the larger the 

replacement area 

 Hue Softness: Indicates the hue softness of the transition area. 

 Shadow Strength: Indicates the gradient parameter of the highlight or shadow area. The larger the value, the 

smoother the gradient. 

 Skin Tone Protect: Keeps the skin tone as original as possible. 
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8.2 14Ch Color Correction 

Precisely adjust the hue, saturation and brightness of black, white, and the 12 derived standard colors of the red, 

green and blue primary colors. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Set the 14h Color Correction switch to . 

Step 3 Click a value of a color to enable the editing status and change the value. 

Parameter Change Trend 

Hue (H) 
Positive value: The hue angle changes counterclockwise. 

Negative value: The hue angle changes clockwise. 

Saturation (S) 
Decrease to -100%: The 12 colors are gradually diluted. 

Increase to +100%: The 12 colors are more vivid and rich. 

Brightness (B) 

Decrease to -100%: The 12 colors gradually darken. 

Increase to +100%: The 12 colors are brighter, and the colors seems to be 

diluted. 

Figure 8-2 14Ch color correction 
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8.3 Set Color Curves 

This feature allows you to quickly adjust image brightness and color tone, customize the response curves for red, 

green, blue, and white, and fine-tune highlights and shadows independently. It ensures that highlights are not 

overexposed and that low-grey areas retain rich details. Additionally, you can use this feature to make precise 

tweaks to the screen display, compensating for variations due to ambient light or camera performance. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Set the Curve switch to . 

Figure 8-3 Curves 

 

Step 3 (Optional) Click  to enter full-screen mode. This will expand the curve adjustment section to the center of 

the screen, making it easier to fine-tune details. 
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Step 4 Select the white, red, green or blue channel. 

Step 5 Drag the slider at the bottom of the curve diagram to set the curve adjustment range. 

Step 6 Click anywhere on the curve to add an adjustment point and drag the point to adjust the curve. 

Input and Output indicate the absolute coordinates of the adjustment point in the curve diagram. 

To delete the adjustment point, drag the point outside the curve diagram, or select the point and press Delete. 

Click the  icon at the right of Channel to reset the curve of the current channel. Click the  icon next to 

Curves to reset all the curves. 

8.4 Enable 3D LUT 

A set of mapping relationships are defined in the 3D LUT file (.cube) to adjust the colors of the video source. It is 

commonly used in the film and image processing industries. With this feature, you can change target colors 

without affecting neutral gray and other colors, which eliminates the issue of layer merging and maintains 

smooth color transitions. Additionally, this feature provides precise control over the entire color space, offering 

more accurate colors and enhancing the overall effect. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, CX40 Pro 

Prerequisites 

Please prepare a 3D LUT file in the .cube format with a file precision of either 17×17×17, 33×33×33, or 65×65×65. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Click anywhere in the Load 3DLUT File area, select a file and open it. 
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Figure 8-4 Loading 3D LUT file 

 

Step 3 Set the 3D LUT to  and drag the slider to adjust the strength of the 3D LUT. 

Figure 8-5 Adjusting intensity 

 

To delete the file, click . 

8.5 Enable Dynamic Booster 

Dynamic Booster can significantly improve the display contrast and image details for better visual experience and 

effectively control and lower the display power consumption. 

Applicable Products 

 LED display controllers: MX40 Pro, CX40 Pro 

 Receiving cards: XA50 Pro, CA50E, A10s Pro and its derivatives. 

Prerequisites 

Before the operation, color gamut and brightness correction by using the CA410-VP427, CA410-P427 or CA410-

P427H colorimeter must be done. Otherwise, the Dynamic Booster switch is grayed out and the function is 

unavailable. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Processing. 

Step 2 Set the Dynamic Booster switch to . 

Step 3 Drag the slider to adjust the intensity of applying the Dynamic Booster. 

Figure 8-6 Dynamic Booster 
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9 Screen Settings 

9.1 Adjust Image Quality 

9.1.1 Adjustment Mode 

Switch the cabinet display mode to let the screen of the same specifications have the optimal display effect under 

different application scenarios. 

Prerequisites 

The NCP file is uploaded, and the NCP files of the receiving card and the controller must match. For details, see 

17.2 Manage Cabinet Library. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 On the Image Quality tab, select a mode based on the application scenario to let the screen have the 

optimal display effect. 

Support mode switching when using different sizes of cabinets of the same batch with different specifications 

under a single Ethernet port. 

Figure 9-1 Mode 

 

9.1.2 Adjust Brightness and Gamma 

Manually adjust the screen brightness, gamma, and brightness components to change the brightness 

performance of the display in real-time. You can also set the maximum brightness as needed and toggle 

Brightness Overdrive on or off. 

Prerequisites 

To use the brightness overdrive function, please make sure the NCP file is uploaded, and the NCP files of the 

receiving card and the controller must match. For details, see 17.2 Manage Cabinet Library. 

Related Information 

If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it 

can be adjusted only in percentage. 
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Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 On the Image Quality tab, click  to open the pop-up window. Here, you can enable or disable the 

Brightness Limit and set the limit value. 

Figure 9-2 Brightness limit 

 

Step 3 Enable or disable Brightness Overdrive based on on-site needs. 

After calibration, some brightness is usually lost. By enabling Brightness Overdrive, the screen's brightness can be 

restored to its pre-calibration levels. If higher brightness is desired for improved HDR effects, this feature can 

compensate for the lost brightness, making specific content like starry skies appear especially bright. 

Step 4 Adjust the values for brightness, gamma, and the RGBW brightness components. 

Only receiving cards such as XA50 Pro, CA50E, A10s Pro and its derivatives (version V1.5.3.0 and later) support 

RGBW component adjustment. 

Figure 9-3 Adjustment 

 

9.1.3 Set LED Image Booster 

Set the LED Image Booster function to improve the delicacy and accuracy of the image color and gradation and 

realize free switching of the display color gamut. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

 Receiving cards: A10s Pro and its derivatives, A8s, A8s-N, XA50 Pro, CA50E 
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Prerequisites 

Before the operation, color gamut and brightness correction by using the CA410-VP427, CA410-P427 or CA410-

P427H colorimeter must be done. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Image Quality tab on the Screen Settings page. In the LED Image Booster area on the right, select an 

output color gamut from the Gamut drop-down list. 

The output gamut options include standard gamuts, custom gamuts, the original screen gamut and the input 

gamut (From input). 

To set the custom gamut, click , select a gamut in the properties area on the color gamut diagram, and adjust 

the red, green, blue and white parameters based on the selected gamut. The custom gamut name can be 

changed. 

Step 3 Drag the slider to adjust color temperature. 

Step 4 Enable or disable Magic Gray as needed. 

Figure 9-4 LED Image Booster 

 

9.1.4  Set Thermal Compensation 

Adjust the application intensity of the thermal coefficients. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

 Receiving cards: A10s Pro and its derivatives, A8s, A8s-N, XA50 Pro, CA50E 

Prerequisites 

Before operation, it is necessary to complete the thermal calibration of the screen. Use the Cabinet Tool to create 

an NCP file containing thermal coefficients and upload it. The thermal compensation interface may vary 

depending on the receiving card model and the settings in the NCP file. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 
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Step 2 On the Image Quality tab, set the Thermal Compensation switch to . 

Figure 9-5 Thermal Compensation - Auto/Manual 

 

Step 3 Adjust the thermal compensation coefficient using either manual or automatic mode. 

 Automatic: The system automatically generates the thermal coefficient application strength based on the screen 

status, eliminating the need for manual adjustments. 

 Manual: Adjust the application strength of the thermal coefficient by dragging the slider. 

9.1.5 Adjust EOTF 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

 Receiving cards: A10s Pro and its derivatives, A8s, A8s-N, XA50 Pro, CA50E 

Related Information 

The supported adjustment parameters depend on the HDR settings. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 In the Image Quality tab, drag the sliders to adjust the values of Shadow Compensation, Ambient 

Light Compensation and Clip Level. 

Figure 9-6 EOTF adjustment 

 

9.2 Set Output 

9.2.1 Set Video Parameters 

Set the output bit depth and additional frame latency. 



 

VMP Vision Management 

Platform User Manual  
   

 

www.novastar.tech   57 
 

 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20 (output bit depth is fixed at 8-bit), CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 In the Output tab, select an option from the drop-down list of Bit Depth. 

If Auto is selected, the output bit depth is the same as the input bit depth. 

Figure 9-7 Output bit depth 

 

Step 3 Set a value for Additional Frame Latency. 

When the controller works with high-latency devices, you can set additional frame latency. 

Note 

It is not possible to set Additional Frame Latency when Low Latency is enabled. 

9.2.2 Set Sync Parameters 

Set the sync source and phase offset. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab. 

Step 3 Select a synchronization signal for the display frame rate and set the phase offset. 

Figure 9-8 Sync 
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 Canvas Max Frame Rate: This displays the maximum frame rate of the current output card's canvas. If all 

canvases have the same maximum frame rate, it will show the value. If the frame rates are different, it will display 

Mix. 

 Source: Sync with the frame rate of the active source. 

 Genlock: Sync with the frame rate of the Genlock signal. When the shutter fit function of the controller is 

effective, please select this option. In addition, the controller and the camera need to use the same Genlock 

signal generator. 

 Internal: Sync with the frame rate of the controller's internal clock. 

Note 

 When low latency is enabled, setting the sync source to Genlock and adjusting phase offset are not 

supported. 

 The Genlock parameter adjustment only takes effect on the selected controller, while other output 

adjustments applies to all controllers of the screen. 

9.2.3 Set Frame Multiplication 

Frame multiplication can make the screen output multiple frames within the original one frame time and provide 

them to different cameras. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, CX40 Pro 

Related Information 

 Frame multiplication, low latency, and 3D cannot be enabled at the same time. 

 MX6000 Pro and MX2000 Pro are capable of supporting a max frame rate of 480 Hz when using the XA50 Pro, 

CA50E, and A10s Pro and its derivatives receiving cards. 

 MX40 Pro is capable of supporting a max frame rate of 240 Hz when using the A10s Pro and its derivatives 

receiving cards. 

 CX40 Pro is capable of supporting a max frame rate of 240 Hz when using the XA50 Pro and CA50E receiving 

cards. 

 The specific maximum frame rate that can be set is related to the hardware configuration of the screen. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab and set Frame Multiplication to . 
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Figure 9-9 Frame multiplication 

 

Step 3 Set the number of frames and the display mode of each frame. 

Take the above figure as an example. The parameters are described as follows: 

 Frame Multiplication: After the current frame rate (59.94) is multiplied by 3, it is 179.82 Hz. Three frames are 

output in 1/59.94 second. 

 Video: The first and second frames display the input source image. The first frame displays the image from the 

coordinates (0, 0) and the second frame displays the image from the coordinates (1920, 0). 

 Color: The third frame displays a pure white image. 

9.2.4 Set Shutter Fit 

Adapt the screen and camera shutter to produce better filming results. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, CX40 Pro 

 Receiving cards: XA50 Pro, CA50E, A10s Pro and its derivatives. 

Prerequisites 

It requires that the sync signal must be Genlock and the controller and camera need to use the same Genlock 

signal generator. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab and set Shutter Fit to . 

Figure 9-10 Shutter fit 

 

Step 3 Set the relevant parameters. 
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9.2.5 Enable 3D Function 

Enable the 3D function and set the related parameters for users wearing 3D glasses to view stereoscopic images. 

Applicable Products 

 LED display controllers: MX6000 Pro, MX2000 Pro, MX40 Pro, CX40 Pro 

 3D emitters: EMT200 Pro (5G/1G), EMT200 (1G) 

Notice 

The 3D function and the low latency or frame multiplication function cannot be enabled at the same time. 

Related Information 

To use the 3D function, specified 3D glasses are needed. Please contact NovaStar technical support. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab and set 3D to . 

Figure 9-11 3D 

 

Step 3 Set the parameters. 

 Source Format: Set the format of the 3D video source. Set the format to Side-by-side, Top-and-bottom or 

Frame sequential according to the format of the accessed video source. 

 Right Eye Offset: Set the start position of the right eye image. When the video source format is side-by-side or 

top-and-bottom and the left and right eye images are provided, this parameter can be set. 

 Eye Priority: Set which image is sent first, the right eye image or the left eye image. Wear the 3D glasses to 

watch the display. If the display is abnormal, set the parameter value to the other one. If the display is normal, 

the setting is done. 

 Custom Emitter: When a third-party 3D signal emitter is used, set the switch to . 

 Emitter Delay: Set the delay time of sending the synchronization signal from the 3D signal emitter to the 3D 

glasses. This setting ensures that the switching between left and right eye images of the 3D glasses is in sync 

with the switching between the left and right eye images on the display. This parameter is applicable to both the 

NovaStar and third-party emitters. 
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9.2.6 Enable SPDIF Audio 

You can select one of the connected input sources for audio output. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Please note that some interfaces/input cards may not support SPDIF audio output on certain controllers. The 

specifics are as follows: 

Controller Interface/Input Card Audio Output 

KU20 HDMI1.3 Supported 

MX20 HDMI1.3 Supported 

3G-SDI Not supported 

MX30 HDMI2.0, HDMI 1.4, DP 1.1 Supported 

3G-SDI Not supported 

MX40 Pro HDMI 2.0_2, HDMI 2.0_3 Supported 

HDMI 2.0_1, DP 1.2, 12G-SDI Not supported 

CX40 Pro HDMI 2.0_2 Supported 

HDMI 2.0_1, DP 1.2, 12G-SDI Not supported 

MX6000 Pro, MX2000 Pro 4×HDMI 2.0, 4×DP 1.2, 2×HDMI 2.1, 2×

DP 1.4, 1×HDMI 2.1+ 1×DP 1.4 

Supported 

1xDP 1.4 (8K@60 Hz), 4x12G SDI, 

1xST 2110 (25G), 2xST 2110 (25G), 

1xST 2110 (100G) 

Not supported 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab and set Audio to . 

Step 3 Click the drop-down menu next to Input and select one of the connected input sources as output 

audio. 

Figure 9-12 Audio 

 

9.2.7 Check the Load 

Check the capacity usage of each Ethernet port of the controller. 
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Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Screen Settings. 

Step 2 Select the Output tab. Under Port Load, click  next to the controller information to check the usage 

of the controller's load capacity. 

Figure 9-13 Port load 
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10 Backup Settings 

10.1 Controller Backup 

You can configure controller-level hot backup for controllers within the same screen, enabling the backup 

controller to take over as the primary controller in case of a failure. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

 A primary controller can only have one backup controller. 
 The primary and backup controllers must be of the same model and firmware version. For card-cased controllers 

(MX6000 Pro and MX2000 Pro), please also make sure the number, slot, model, and firmware version of the 

daughter cards also match. 

 Controller backup and Ethernet port backup are mutually exclusive. You can only configure one type of backup 

at a time. For card-cased controllers (MX6000 Pro and MX2000 Pro), controller backup, card backup, and 

Ethernet port backup are all mutually exclusive. However, controllers that have not been backed up support 

simultaneous configuration of card backup and Ethernet port backup. 

Related Information 

 Controller backup parameter synchronization: 

1. When creating a controller backup, the backup controller will synchronize with the primary controller's data. 

2. Upon power cycling the primary/backup controller, it will sync data with the counterpart device. 

Note 

If a controller goes offline and back online due to a disconnected Ethernet cable, the parameters will not be 

synchronized between the controllers. 

 When controller backup is set up, only the primary controller can detect multifunction card and light sensor 

information. The backup controller does not support detecting or reading this information. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Backup. 
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Figure 10-1 Controller backup 

 

Step 2 All controllers of the screen will be shown in the canvas area. You can drag and drop a controller onto 

another to establish a backup relationship. 

The controller being dragged is considered the backup, while the one being dropped onto becomes the primary. 

Upon dropping, a pop-up window will appear showing information about the primary and backup controllers. If 

everything is correct, simply click OK. 

Step 3 Click Verify Primary or Verify Backup to examine whether the controllers are working properly. 

 Verify Primary: Disconnect the backup and examine whether the primary is working properly. 

 Verify Backup: Disconnect the primary and examine whether the backup is working properly. 

10.2 Card Backup 

You can configure card-level hot backup for output cards within the same screen, enabling the backup card to 

take over as the primary card in case of a failure. 

Applicable Products 

MX6000 Pro, MX2000 Pro 

Prerequisites 

 The primary and backup output cards must be of the same model and firmware version. 

 Controller backup and card backup are mutually exclusive. You can only configure one type of backup at a time. 

Related Information 

When backup is set for the cards, only the primary card can detect multifunction card and light sensor 

information. The backup cards cannot detect or read this information. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Backup. 

Step 2 In the Backup Settings section, select Card Backup from the dropdown menu. 
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Step 3 Set a backup card for the primary. 

Figure 10-2 Card backup 

 

Step 4 Click Verify Primary or Verify Backup to examine whether the controllers are working properly. 

 Verify Primary: Disconnect the backup and examine whether the primary is working properly. 

 Verify Backup: Disconnect the primary and examine whether the backup is working properly. 

10.3 Ethernet Port Backup 

You can configure Ethernet port hot backup within the same controller or output card, enabling the backup port 

to take over as the primary port in case of a failure. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

Controller backup and Ethernet port backup are mutually exclusive. You can only configure one type of backup at 

a time. 

Related Information 

When Ethernet port backup is set up, only the primary port can detect multifunction card and light sensor 

information. The backup ports cannot detect or read this information. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Backup. 

Step 2 In the Backup Settings section, select Ethernet Backup from the dropdown menu. 

For card-cased controllers (MX6000 Pro and MX2000 Pro), you need to first select Card Backup before 

configuring Ethernet port backup for the cards. 
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Figure 10-3 Ethernet port backup 

 

Step 3 Select an option from the sub-menu of Ethernet Backup. 

 Port (1~20) ⇌ (21~40): Split  B ackup where Ethernet ports 21 to 40 are the backups to Ethernet ports 1 to 20. 

 Port (1 ⇌ 2, 3 ⇌  4...): Sequential Backup where Ethernet port  2 is the backup to Ethernet port  1, Ethernet port  4 
is the backup to Ethernet port 3, and so on. 

 Custom: Select a controller or output card from the project list, and then you can drag and drop the port icon in 

the port list to customize the backup settings. You can also select a backup mode first and then adjust the 

backup settings according to your needs. 

Figure 10-4 Port list 

 

Note 

You can click Split Backup or Sequential Backup on the right side of the port list to switch between backup 

modes. 

When hovering the mouse over the line between the Ethernet ports, you will see an icon ( ). Click the icon to 

delete the backup relationship between the ports. 

Step 4 Click Verify Primary or Verify Backup to examine whether the controllers are working properly. 

 Verify Primary: Disconnect the backup and examine whether the primary is working properly. 

 Verify Backup: Disconnect the primary and examine whether the backup is working properly. 
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11 Preset Management 

11.1 Save Presets 

After completing the display effect adjustment, you can save the data on the Source, Layout, Processing and 

Screen Settings pages as presets so that these data can be directly applied in the future. Up to 128 presets can 

be saved in VMP. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Related Information 

The preset of a specific controller can only be applied by this controller itself and the preset of a screen can be 

applied by all the controllers of the screen. 

Operating Procedure 

Step 1 Select Preset. 

Step 2 On the preset management page, click  to enter the page shown in Figure 11-1. 

To go back to the preset management page, click a blank area in the properties area. 

Figure 11-1 Preset management 

 

Step 3 Click the icon of a preset. 

Step 4 Select the data you need to save. You can also enable Transition Through Black as needed. 

If the preset you selected is not empty, the original data will be overwritten. 

Step 5 Click Save. 

11.2 Apply Presets 

Apply a saved preset to quickly complete settings of the parameters on the Source, Layout, Processing and 

Screen Settings pages. 
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Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Related Information 

The preset of a specific controller can only be applied by this controller itself and the preset of a screen can be 

applied by all the controllers of the screen. 

Operating Procedure 

Step 1 Select Preset. 

Step 2 On the preset management page, double-click a preset and wait it to finish loading. 

The preset that is being used has a  at the top right. 

Figure 11-2 Apply presets 

 

11.3 Manage Presets 

Select Preset and do the following operations as needed. 

Modify a Preset 

Select a preset. In the properties area, change the related information and click Save. 

Delete a Preset 

 Right-click a preset and select Delete from the pop-up menu. 

 On the preset management page, select a preset and click Delete in the properties area. 

Clear Presets 

Right-click a preset and select Delete All from the pop-up menu. 



 

VMP Vision Management 

Platform User Manual  
   

 

www.novastar.tech   69 
 

 

12 Screen Monitoring 

12.1 Overall System Health 

You can assess the operational status of each component within the entire LED display system. 

Operating Procedure 

Navigate to Monitor > Health to access the relevant information. The figure below uses the MX6000 Pro as an 

example: 

 

 System Link Diagram 

This diagram provides a clear visual representation of the connection status and locations of the controllers 

and fiber converters within the selected screen. A green indicator signifies normal operation; yellow 

indicates an alarm; red denotes a fault; and gray represents unknown status. This allows you to quickly 

pinpoint any issues if they arise. 

 Health 

Shows the overall system health status. It displays Normal if all controllers, cabinets, and accessories are 

operating without issues. If there are alarms but no faults, it shows Alarm. If any faults are detected, it 

displays Fault. 

− Controller 

Shows the total number of controllers and provides a breakdown of those in normal operation, those 

with alarms, and those with faults. 

− Cabinet 

Displays the total number of cabinets and their status, indicating the number in normal operation, those 

with alarms, and those with faults. 
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− Accessory 

Lists the total number of accessories, along with the count of those functioning normally, those with 

alarms, and those experiencing faults. 

12.2 View Alarm Information 

You can view the system alarm records. 

Operating Procedure 

Navigate to Monitor > Alarms to check the current alarms. You will see details such as severity, count, summary, 

time elapsed, possible causes, and recommended actions. Perform the necessary actions based on this. 

Figure 12-1 Alarms 

 

 Search records 

You can search by controller name (including IP), controller type, exception level, summary, or problem 

description. 

 View history 

Select View History to display all past alarms. If unselected, only unresolved alarms are shown. 

 Sort alarms 

Choose By Type or By Time from the drop-down menu to organize the alarm records. 

 Reset records 

Click , then select Reset in the popup window to clear existing records, refresh to the latest status, and 

generate alarm information. 

 Export records 
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Click Export to save all alarm records of the screen. The file will be in .CSV format. 

12.3 Monitoring Status 

12.3.1 Screen Monitoring 

You can monitor the LED screen's receiving cards, cabinets, and modules from multiple metrics to confirm the 

operational status of the screen. 

Prerequisites 

Certain screen monitoring tasks require cooperation with receiving cards and accessories. The specifics are as 

follows. 

Monitoring Receiving Card Requirements Other Requirements 

Cabinet HUB 

board 

temperature 

Must work with receiving cards including XA50 

Pro, CA50E, or A10s Pro and its derivatives 

(version V1.5.3.0 or later) for effective 

monitoring. 

N/A 

Receiving card 

PHY 

temperature 

Must work with receiving cards including XA50 

Pro or CA50E (version V1.5.3.0 or later) for 

effective monitoring. 

N/A 

Module wiring 
Monitoring is supported if the module is a smart module or is equipped with the TBS614S 

chip. 

Module 

temperature 

Support for monitoring requires custom versions 

of the XA50 Pro, CA50E, A10s Pro and its 

derivatives. For more details, please contact 

NovaStar tech support. 

The module must have a temperature 

sensor. 

Module voltage The module must have a voltage sensor. 

Cabinet 

humidity 

The cabinet must be connected to a 

humidity sensor. 

Cabinet power 

supply 

N/A 

Cabinet smoke 
The cabinet must be connected to a 

smoke detector. 

Related Information 

When collecting data effectively, the topology diagram uses color to distinguish the status. You can view the 

legend in the bottom right corner of each tab: green indicates normal, yellow for alarms, red for faults, and gray 

for unknown. Hovering the cursor over a cabinet will also display detailed monitoring values. 

Operating Procedure 

Navigate to Monitor > Screen. Depending on your needs, perform the following actions to view screen 

monitoring information: 
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 Switch to the Temperature tab to view screen temperature details. Specific values are shown in the properties 

area. 

− : The receiving card temperature. 

− : The operating temperature of the cabinet's HUB board. 

− : The module temperature. 

− : The receiving card PHY temperature. 

 

 Switch to the Voltage tab to view screen voltage details. Specific values are shown in the properties area. 

− : The cabinet voltage. 

− : The module voltage. 

 

 Switch to the Cabinet Power tab to monitor the status of the cabinet's power supply. In the properties area, you 

can check the status of each power supply. 
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 Switch to the Packet Loss tab to monitor accumulated bit errors on the receiving cards. Any abnormal receiving 

card will appear in yellow on the topology with the error count indicated. You can view specific cumulative errors 

in the properties area. Click  to reset the error count and start monitoring again, and click  to view the 

packet loss curve. 

 Switch to the Module Wiring tab to monitor the wiring of modules. 

 Switch to the Cabinet Humidity tab to monitor the ambient humidity of the cabinet. In the properties area, you 

can check the humidity level. Excessive humidity can lead to oxidation and corrosion of the internal circuit 

boards and components in the cabinet, potentially reducing performance or even causing damage to the device. 

 Switch to the Cabinet Smoke tab to monitor the cabinet for smoke. Smoke acts as a warning signal for electrical 

component short circuits. By monitoring it, short-circuit issues can be quickly identified, allowing for timely 

replacement of components and effectively preventing fires. 

Note 

 By selecting a target in the topology diagram, you can view detailed values for screen monitoring items, 

cabinet location, total runtime, and current runtime in the properties area. 

 In the Cabinet Settings area, you can set the cabinet to black out, freeze the display, or show a test pattern. 

12.3.2 Input Source Monitoring 

Navigate to Monitor > Source to view details about the number of currently connected input sources, the type of 

interface, resolution, and frame rate for your primary and backup controllers. You can also click to enlarge the 

input source preview. 

 

12.3.3 Controller Monitoring 

Navigate to Monitor > Controller to access the relevant information. The figure below uses the MX6000 Pro as 

an example: 
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Figure 12-2 Controller Monitoring 

 
 Check the status of the connectors on the rear panel of the controller. 

 Check the controller's name, current uptime, total uptime, mainboard temperature, mainboard voltage, and fan 

status. 

 Check the temperature and voltage of the cards. 

 Enable or disable Controller Finder. You can identify the controller by toggling on the switch ( ). In the 

project list, right-click on the controller to set the LCD display color from the pop-up menu. 

12.4 System Diagnostic 

Perform diagnostics on the selected screen. You can choose to diagnose various items including LED error 

detection, origin data comparison, controller self-check, monitoring items, and receiving card signal interruptions. 

Prerequisites 

Before conducting LED error detection, ensure the following: 

 The module is a smart module. 

 The receiving card firmware supports LED error detection. 

 LED error detection is enabled in Cabinet Tool. 

Operating Procedure 

Step 1 Select a screen from the project list and then go to Monitor > Diagnostics. 
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Step 2 In the System Diagnostics on the right, select the diagnostic items you wish to perform. 

 LED Errors: Diagnoses the number of dead pixels in each module. 

− When a cabinet is selected in the topology, diagnostics are based on the selected cabinet. 

− If no cabinet is selected, diagnostics are performed on all cabinets by default. 

 Compare Origin Data: Compares whether the saved origin data values differ from the current values. 

 Device Diagnostics: Performs a self-check on the controller, with results categorized as Normal, Alarm, or Fault. 

 Monitoring Values: Diagnoses current results of monitoring item values to determine if there are any anomalies 

in the system. 

 Receiving Card Signal Interruptions: Counts the number of times a receiving card experiences signal 

interruptions without going offline. 

Step 3 Click Start to carry out the system diagnostics based on the selected options. 

Step 4 Click View Report to obtain a diagnostic report file (.pdf) for the selected screen. 

Step 5 Click the function icons on the left to view corresponding diagnostic results. 

 : LED error detection. The topology will display faulty modules in yellow with the number of dead pixels 

labeled. At the bottom of the interface, you can check the specific number of faulty modules and dead pixels. 
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 : Origin data comparison. View specific data changes for controllers, cabinets, receiving cards, and modules 

at the bottom of the interface and perform the necessary actions. 

 

− Click  to select Create System Origin or Export System Origin. Selecting both will export the 

saved origin data. 
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Create System Origin lets you manually save the current data as origin data, overwriting the existing 

values. 

Export System Origin allows exporting the current origin data as a file (.opd). 

 

− Click  to select Compare with System Origin or Compare with Origin File. Upon 

completion, a comparison file (.CSV) is generated. 

Compare with System Origin compares the current data values with the latest saved system origin 

values. 

Compare with Origin File compares the current data values with a selected origin file's values. 

 

− Click  to select Restore to System Origin or Restore to Origin File. 

Restore to System Origin reverts the current data values back to the latest saved system origin values. 

Restore to Origin File reverts the current data values to a selected origin file's values. 

 

 : Device diagnostics result. The bottom of the interface shows the counts of controllers categorized as 

normal, alarm, or fault. 
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 : Receiving card signal interruptions. After diagnosis, faulty receiving cards are shown in yellow on the 

topology with the interruption count labeled. The interface displays the specific count of receiving cards 

with signal interruptions and the number of interruptions. Click  to reset the interruption count to zero 

and start a new count. 

 

Note 

You can also blackout, freeze, or enable test patterns for cabinets under the Cabinet Settings section. 
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12.5 Monitoring Settings 

12.5.1 Monitoring Items 

Select a screen from the project list, then choose Monitor > Settings. Then, toggle on or off Packet Loss as 

needed. 

 On: The screen monitoring page will show and monitor packet loss on the receiving cards. 

 Off: The screen monitoring page will not include packet loss monitoring. 

 

12.5.2 Monitoring Strategy 

To configure the monitoring strategy, select a screen from the project list and go to Monitor > Settings. In the 

Monitoring Strategy section, you can set actions to be automatically taken when abnormal values are detected, 

temporarily reducing risk. The specific monitoring strategies available depend on the capabilities of the receiving 

card being used. 

1. If the cabinet or receiving card temperature exceeds the set threshold, the screen brightness will 

automatically reduce to the specified level to prevent overheating. 

2. If smoke is detected in the cabinet, the system will automatically power off the screen. 

3. If there is a power failure in one of the cabinet's power supplies, the screen brightness will automatically 

reduce to the set level. 

Note 

When the Brightness Limit feature is enabled, the resulting brightness application in the monitoring strategy will 

be based on a percentage of the brightness limit. 

 

12.5.3 Email Alarms 

Email alarms can be configured to notify you via email whenever there are changes in the system, such as when 

an alarm is triggered, a fault occurs, or normal operation is restored. 

Step 1 Select a screen from the project list and then go to Monitor > Settings. 

Step 2 Toggle the email alarms on or off in the Alarm Email section. 

 

Step 3 Configure the email notification settings and check the sender email address: 
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 Notification Frequency: Options include Immediate, 3 minutes, 5 minutes, 10 minutes, 30 minutes, 1 hour, or a 

custom frequency. 

 24-Hour Limit for Same Fault/Alarm Emails: Options include: 1 time, 3 times, 5 times, 7 times, 10 times, and No 

limit. 

Step 4 Set recipient email addresses, with a maximum of 5 recipients allowed. 

1. Click the Add button, and then enter the email address in the pop-up window. 

2. Click  to send a verification email to the specified address and complete the verification by checking your 

email. 

3. After the settings, click OK. 

 

13 Display Schedule 

13.1 Create Brightness Schedule 

You can create a brightness adjustment schedule for the LED display screen. When a light sensor is connected to 

the system, it can automatically adjust the brightness of the LED screen based on the real-time ambient light 

conditions. This adjustment occurs within a predetermined time frame, with the sensor measuring the ambient 

light brightness and referring to a mapping policy that correlates the LED display brightness with ambient light 

levels. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Schedule. 

Step 2 Click Create Schedule, select the Brightness tab, and then set the date and time range. 



 

VMP Vision Management 

Platform User Manual  
   

 

www.novastar.tech   81 
 

 

Figure 13-1 Create brightness schedule 

 

Step 3 Set the screen's active time. You can either input custom times or use the local sunrise and sunset 

times for scheduling. 

In the Sunrise/Sunset section, click Access Location to retrieve the current screen's latitude and longitude along 

with the local sunrise and sunset times. You can also add notes for the location. 

 

Step 4 Specify how the brightness is adjusted, by Light sensor, or by Specified brightness. 

If you choose to adjust by a light sensor, remember to configure the brightness schedule on the right side of the 

interface (refer to Step 5 to Step 6). 

Step 5 Select one of more light sensors under the Automatic Brightness section. 

Selectable Range: Light sensors connected to multifunction cards on each controller/output card that are online 

in the current project. 

Note 

When multiple light sensors are selected, the system calculates the average ambient brightness from all sensors 

to adjust the screen brightness according to the brightness schedule. 

If multiple controllers connected to light sensors are placed in environments with differing brightness levels under 

the same screen, ensure proper communication between controllers to prevent inconsistent screen brightness. 

Step 6 In the Brightness Schedule section, set up the mapping between ambient brightness and screen 

brightness. When the light sensor detects a specific ambient brightness, the screen brightness will 

adjust to the corresponding value. 

1. Choose the brightness adjustment method: Linear or Stepwise. 

− Linear: Continuously calculates the average brightness between two adjacent ambient levels based on the 

measurement rules and adjusts the screen brightness according to the brightness schedule. 
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− Stepwise: Adjusts the screen brightness only at the endpoints of two adjacent ambient levels per the 

brightness schedule. 

Figure 13-2 Brightness schedule 

 

2. Add new brightness schedules, with up to 29 entries supported. You can choose Add or Batch Add. 

− Batch Add: Click Batch Add, then set Ambient Brightness, Screen Brightness, and the number of segments 

in the pop-up window. 

 
− Add: Click Add to create a new brightness schedule and then adjust the values for Ambient Brightness and 

Screen Brightness. 

 

Note 

When all the cabinets of the screen support the multi-mode function and use the same NCP file, you can 

manually link the brightness schedule to the multi-mode and display data based on the maximum brightness of 

the multi-mode. 
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Step 7 Specify if the schedule should repeat and provide the end time for the repetition. 

Step 8 Click OK once you are done. The created schedule will be displayed in the schedule chart. 

You can click  on the top-left corner to switch between daily view, weekly view, and monthly 

view to review the overall schedule plan. 

 

Step 9 Right-click a schedule in the chart to Edit or Delete it. 

Edit: You can edit the Current schedule or Current and follow-up schedules. 

Delete: You can delete the Current schedule, Current and follow-up schedules, or All schedules. 

Step 10 To activate the schedule, please toggle on Schedule in the upper right corner of the chart. 

Figure 13-3 Schedule 

 

Note 

Brightness schedule and HDR 2084 cannot be enabled at the same time. If brightness schedule is enabled after 

HDR 2084 is selected, the HDR function will be disabled. 
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13.2 Create Preset Schedule 

You can create a predetermined schedule for the LED screen, enabling automatic switching of different presets 

according to the specified timetable. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

You need to save a preset for the screen before creating a preset schedule. 

Operating Procedure 

Step 1 Select a screen from the project list and then select Schedule. 

Step 2 Click Create Schedule, select the Preset tab, and then set the start date. 

 

Step 3 Set the start time for the schedule, with options to enter it manually or use local sunrise/sunset times. 

In the Sunrise/Sunset section, click Access Location to obtain the current screen's latitude, longitude, and 

sunrise/sunset times. You can also add notes for the location. 

 

Step 4 Select the preset to be applied. 

Step 5 Specify if the schedule should repeat and provide the end time for the repetition. 

Step 6 Click OK once you are done. The created schedule will be displayed in the schedule chart. 
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You can click  on the top-left corner to switch between daily view, weekly view, and monthly 

view to review the overall schedule plan. 

 

Step 7 Right-click a schedule in the chart to Edit or Delete it. 

Edit: You can edit the Current schedule or Current and follow-up schedules. 

Delete: You can delete the Current schedule, Current and follow-up schedules, or All schedules. 

Step 8 To activate the schedule, please toggle on Schedule in the upper right corner of the chart. 

Figure 13-4 Schedule 

 

13.3 Create Diagnostic Schedule 

You can set up a diagnostic schedule for LED screen to conduct regular diagnostics based on a defined schedule 

and selected diagnostic items. 
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Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Operating Procedure 

Step 1 Select a screen from the project list and then select Schedule. 

Step 2 Click Create Schedule, select the Diagnostics tab, and then set the start date. 

 

Step 3 Set the start time for the schedule, with options to enter it manually or use local sunrise/sunset times. 

In the Sunrise/Sunset section, click Access Location to obtain the current screen's latitude, longitude, and 

sunrise/sunset times. You can also add notes for the location. 

 

Step 4 Configure the diagnostic items, including: LED Errors (only supported by smart modules), Compare 

Origin Data (optional), Device Diagnostics (optional), and Monitoring Values (mandatory). 

Step 5 Specify if the schedule should repeat and provide the end time for the repetition. 

Step 6 If email alarms are set up on the monitor page, you can opt to send diagnostic results via email. 

Step 7 Click OK once you are done. The created schedule will be displayed in the schedule chart. When setting 

multiple diagnostic schedules, ensure there is at least a 5-minute gap between each. 

You can click  on the top-left corner to switch between daily view, weekly view, and monthly 

view to review the overall schedule plan. 
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Step 8 Right-click a schedule in the chart to Edit or Delete it. 

Edit: You can edit the Current schedule or Current and follow-up schedules. 

Delete: You can delete the Current schedule, Current and follow-up schedules, or All schedules. 

Step 9 To activate the schedule, please toggle on Schedule in the upper right corner of the chart. 

Figure 13-5 Schedule 

 

13.4 Check Schedule Log 

You can check the schedule log and history charts. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 
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Operating Procedure 

Select Schedule and at the bottom of the page, do the operation as needed. 

Figure 13-6 Log 

 

 Search records 

Enter the key words in the search box. 

 Query records 

Click the time widget and set the start and end time. 

 History charts 

Click  and select a specific date to access the history charts displaying the brightness 

schedule, preset schedule, and diagnostics schedule log. Please note that you can only view the history on a 

daily basis. 

Figure 13-7 History charts 

 

 Export records 

Click Export, select a file page, set a file name, and click Save. 
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14 MVR 

Configure the relevant properties of the MVR output card. 

Applicable Products 

MX6000 Pro, MX2000 Pro 

Prerequisites 

The device has an MVR output card installed and the card is functioning normally. 

Operating Procedure 

Step 1 Select a device from the project list and then select MVR. 

Figure 14-1 MVR 

 

Step 2 Select the interface resolution from the drop-down list and click Apply. The selected resolution must 

match the resolution of the monitor connected to the MVR output card’s connector. 

Step 3 If only one layer is added, drag the input or output directly from the bottom of the interface into the 

editing area. If multiple layers are added, select a preset layout and all layers will be automatically 

added to the layout. To add a custom layout, follow the steps below. 

1. Click Add. 

2. Set the following parameters as needed. 

− Row & Col: Indicate the number of rows and columns in the cells. 

− Outer Border: Indicate the width and height of the layout’s outer border. 
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− Inner Border: Indicate the distance between adjacent cells. 

− Window Split: Merge or unmerge cells. 

− Type: Indicate the cell type, which can be set to input (blue) or output (purple). 

If this parameter is not set, after selecting this layout, the layer will not automatically fill the layout. 

3. Once done, click OK. 

Figure 14-2 Custom templates 

 

 : Maximize the layer’s width and height based on the cells it spans. 

 : Delete a single layer. To clear all layers, click Clear. 

Step 4 Select the layer and set its width, height, UMD, and border as needed. 

Figure 14-3 Property settings 

Item Description 

Window Settings Set the layer position, width and height. 

 : The width and height are unlinked and can be adjusted independently. 

 : The width and height are linked and can be adjusted synchronously. 

UMD Enable or disable UMD, and set its background color. 

 : Enabled. 

 : Disabled. 

Border Enable or disable layer border, and set the border’s width, height, and color. 

 : Enabled. 

 : Disabled. 
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15 Calibration Coefficient Management 

From the menu bar, choose Tools > Coefficient Management and do operations such as uploading, saving, 

adjusting and reading the coefficients. You can also check the module flash status. 

 

15.1 Check Module Flash Status 

When replacing modules or reading back coefficients from the module flash, you have the option to visually 

inspect the status of the module flash. 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 On the canvas, click  to display the module flash status. Click  again to hide the module status. Click  

to refresh the module status. 

 : Module flash is abnormal. 

 : Module flash is normal. 

Figure 15-1 Check module flash status 
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15.2 Upload Calibration Coefficients 

Upload the local calibration coefficient file to the current screen, cabinet or module and apply the coefficients to 

the display effect. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

 You can only upload coefficients from page 1. 

 

 To upload screen coefficients, make sure: 

− The screen configuration is done, the cabinets are not rotated, and there are no cabinet gaps or 

overlapping. 

− The configured screen must be rectangular, and the top-left-corner coordinates of the circumscribed 

rectangle of the configured screen must be (0, 0). 

− To use the database file, you should prepare it in advance, and the resolutions of the configured screen 

and the screen in the database must be the same and the database must be a screen database. 

 To upload cabinet coefficients, make sure: 

The target cabinets have cabinet IDs. You will need to configure cabinet ID manually if the target cabinets 

have no ID. 

Notice 

During coefficient uploading, if the controller and/or receiving cards go offline, the uploading will fail. 

If the coefficient uploading fails, the coefficients will not be saved automatically. You can manually save them as 

needed. 

Operating Procedure 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the uploading range. The options include Screen, Cabinet and LDM. 
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Figure 15-2 Select mode 

 

Step 4 In the Coefficient Management area, click  and select one or more target calibration data files (.db) from the 

local computer. 

You can select and batch import multiple coefficient files at once. When importing calibration coefficients for 

cabinets or modules, the system will automatically match and upload according to the corresponding 

cabinet/module ID. 

Figure 15-3 Upload calibration coefficients 

 

 When importing calibration coefficients for cabinets or modules, the system will automatically match and upload 

them using the corresponding cabinet or module ID. 

 

 When trying to import the cabinet/module calibration coefficient, but the cabinet/module ID does not match the 

ID in the coefficient file, you'll need to manually select and upload. 

In this case, the Match will show as not matched and File ID will be empty. You'll need to click the File ID 

dropdown menu and select the appropriate file ID manually. Ensure that the selected coefficient file is compatible 

with the cabinet or module before making a selection. 
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Step 5 Click OK to upload the coefficients to receiving cards. 

15.3 Edit Calibration Coefficients 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

 Calibration coefficients are available. 

 Cabinet configuration is done and the cabinets stay online. 

Operating Procedure 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select Pixel. 

Figure 15-4 Select mode 

 

Step 4 In the topology, click to select a cabinet. 

Step 5 In the displayed window, select the target pixels and enter the parameters in the Coefficient Management area 

to adjust the proportion relationship of the red components, green components and blue components in RGB. 

The calibration coefficients of the selected pixels will be overridden and changed to the values you set. 
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Figure 15-5 Pixel calibration coefficients 

 

Table 15-1 Parameter relationship and value range 

/ Red-R Green-G Blue-B 

Red-R RR (512 - 2047) GR (0 - 255) BR (0 - 127) 

Green-G RG (0 - 255) GG (512 - 2047) BG (0 - 255) 

Blue-B RB (0 - 127) GB (0 - 127) BB (512 - 2047) 

Table 15-2 Icon description 

Icon Function 

 The step of single increase or decrease. Use it together with . 

 Increase or decrease the coefficient value of the selected pixel. 

 Click to close the pixel topology. 

15.4 View Calibration Effect 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Related Information 

If brightness correction has been done for the screen, the screen brightness can be adjusted in nits. Otherwise, it 

can be adjusted only in percentage. 

Set the Display Content 

In the Display area, you can adjust the screen brightness to clearly see the actual calibration effect change at 

each grayscale. You can also switch the color to see the uniformity of a single color and the entire display image. 
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Figure 15-6 Set display content 

 

 Brightness: Adjust the screen brightness. 

 Display image: Set the image displayed on the screen. By default, the current input source is being displayed 

( ). You can switch to a monochrome display in white, red, green, and blue. 

To do so, simply press the shortcut keys W, R, G, B, and Tab. 

 Show locating cursor: When the switch is set to , the selected area on the screen will display blue borders. 

This helps you quickly identify the cabinets, modules or pixels that you are currently operating. 

Enable and Disable Calibration Effect 

In the Calibration area, you can turn on or off the calibration switches and then view the display effects before 

and after the calibration. 

The calibration switches include Brightness Calibration, Brightness and Chroma Calibration, Full-Grayscale 

Calibration and Low-Grayscale Calibration. The actual displayed switches depend on the existing coefficient 

types of the screen. 

Figure 15-7 Calibration switches 

 

The Brightness Calibration and Brightness and Chroma Calibration are mutually exclusive and cannot be 

enabled at the same time. 

15.5 Save Calibration Coefficients 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Notice 

During coefficient saving, if the receiving cards go offline, the saving will fail. 
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Related Information 

To manage changes to the factory calibration coefficients, users can contact NovaStar tech support to apply for a 

license and set a valid period. During the valid period, coefficients can be saved in the module's flash memory. 

Otherwise, they can only be saved in the user area of the receiving card's flash memory. 

To activate the license, place the file in the directory:  

 Windows: C:\Users\YourUsername\AppData\Roaming\VMP\Datas 

 Mac: /Users/Your User Name/Library/Application Support/VMP/Datas 

Operating Procedure 

Save the calibration coefficients of the current screen, cabinet or module to the receiving card to avoid 

calibration effect loss due to power failure. 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the saving range as needed, including Screen, Cabinet, LDM and Pixel. 

Figure 15-8 Select mode 

 

Step 4 In the Coefficient Management area, click Save to save the current display effect coefficients to the receiving 

card. 

The system automatically identifies the screen's coefficient types and saving locations. With an active license 

within its validity period, you can save coefficients in the module's flash memory. Otherwise, they are saved in the 

user area of the receiving card's flash memory. You can choose the extent of saving according to your needs.  

Figure 15-9 Save coefficients 

 

Step 5 Click OK. 
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15.6 Read Back Calibration Coefficients 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Notice 

During coefficient readback, if the receiving cards go offline, the readback will fail. 

Operating Procedure 

Read back the calibration coefficients saved in the receiving card and apply them to the current screen. 

Step 1 Select a controller from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the reading range as needed, including Screen, Cabinet, LDM and Pixel. 

Figure 15-10 Select mode 

 

Step 4 In the Coefficient Management area, click Read to read the saved coefficients and apply them to the display 

effect. 

The system will automatically read the current screen's display effect coefficients. If the cabinet has module flash, 

coefficients can only be read back from the module flash. If there is no module flash, they can only be read back 

from the user area of the receiving card's flash memory. 

Figure 15-11 Read back coefficients 

 

Step 5 Click OK. 
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15.7 Export Calibration Coefficients 

Export the calibration coefficients of the current screen, cabinet or module to the local computer. When the 

receiving card is replaced or the new screen has the same specifications, you can upload the exported calibration 

coefficients directly to use. 

Applicable Products 

MX6000 Pro, MX2000 Pro, MX40 Pro, MX30, MX20, KU20, CX40 Pro 

Prerequisites 

 You can only export coefficients from page 1. 

 

 To export screen coefficients, make sure: 

− The screen configuration is done, the cabinets are not rotated, and there are no cabinet gaps or 

overlapping. 

− The configured screen must be rectangular, and the top-left-corner coordinates of the circumscribed 

rectangle of the configured screen must be (0, 0). 

 To export cabinet coefficients, make sure: 

The target cabinets must have cabinet IDs. 

Notice 

During coefficient exporting, if the controller and/or receiving cards go offline, the exporting will fail. 

Operating Procedure 

Step 1 Select a screen from the project list. 

Step 2 From the menu bar, choose Tools > Coefficient Management. 

Step 3 In the Select Mode area, select the export range as needed, including Screen, Cabinet, LDM and Pixel. 

Figure 15-12 Select mode 

 

Step 4 In the Coefficient Management area, click Export to export the current display effect coefficients as a file (.db). 
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The system will automatically read the existing coefficient types of the screen, allowing you to choose whether or 

not to export them based on your needs. 

Figure 15-13 Export coefficients 

 

Step 5 Click OK.
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16 Screen Maintenance 

16.1 Maintain Controllers 

Step 1 From the menu bar, choose Tools > Maintain and select the Controller tab. 

Step 2 Select a screen from the project list on the left. 

Step 3 Select the target controllers and perform the following operations as needed. 

Figure 16-1 Controller maintenance 

 

 Controller finder 

Click Controller Finder and the LCD screen of the controller becomes green (default), which helps you 

identify the controller quickly. 

 Firmware painter 

a. Click Firmware Painter, select a single controller to start the firmware readback process. 

b. Once the readback is successful, the system will automatically enter the firmware upgrade mode. Select 

one or more controllers and click Start to update them so that they share the same firmware version as 

the current controller. 

 Factory reset (proceed with caution) 

Click Factory Reset, then select one or more controllers. This action will restore all user settings to their 

default values. Confirm by clicking OK to proceed with the reset. 

 Sync card firmware 
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If the card firmware version does not match with the controller firmware version, you can click Sync Card 

Firmware to sync the controller firmware to the card. Alternatively, you can resolve this issue by upgrading 

the firmware. 

 Update firmware 

Click Update to update the controller's firmware by downloading from the cloud or uploading a local file. 

− Select the Cloud tab to view the latest version release notes and click Update to download and 

automatically install the package. 

 

− Choose the Local tab, click Upload File, and select either a firmware file (.img) or a compressed file (.zip) 

from the pop-up folder. Verify the file name and version number, then click OK to proceed with the 

update. 

 

During the upgrade process, the controller will automatically restart. In addition, please do not close VMP or 

switch to another controller until the update is complete. 

Note: 

 When updating firmware, it's recommended to use a wired network. During the upgrade, connect the PC 

and controller via a wired network. If you need to update via the cloud, ensure the PC is connected to the 

internet. 

 All the controllers of a screen must be updated at the same time. 

 When upgrading card-based controllers (MX6000 Pro and MX2000 Pro), all of the cards must be updated at 

the same time. If the cards span across different screens, the controllers that are under the same screen as 

the card must also be updated together. 
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 Restart controller 

Click Restart and click OK. 

16.2 Maintain Cabinets 

Step 1 From the menu bar, choose Tools > Maintain and select the Cabinet tab. 

Step 2 Select a screen from the project list on the left. 

Step 3 (Optional) Switch between the list and topology views by clicking the icon in the upper right corner, 

depending on your preference. 

Figure 16-2 Cabinet maintenance – list/topology view 

 

 

Step 4 Select the target cabinets and perform any of the following operations. 

 Check the cabinet information 

Check the associated controller, daughter card (only applicable for card-based controller), location, 

receiving card model, receiving card firmware, cabinet model, and cabinet manufacturer. 

 Cabinet display settings (topology view only) 
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Select a cabinet through the topology view. In the Cabinet Settings section, click the Cabinet Test Pattern 

dropdown menu and choose the display for the cabinet. 

 Cabinet painter 

Click Cabinet Painter and select one or more cabinets so that other cabinets can have the same firmware 

program and configuration file as the selected cabinet. 

 Update cabinet configuration file 

On the Cabinet tab, select one or multiple cabinets and click Update. 

 

In the pop-up window, either select an existing cabinet data or click Import to upload a new NCP file. 

− Select an existing file: Choose an NCP file from the pop-up window and click Update. 

− Import a new file: Click Import to upload a new NCP file. You can select the import objects (multiple 

selections are possible) from Local pack or Device pack. Once the upload is complete, return to the 

Update interface, select the imported NCP file, and click Update. 

Note: 

 It is recommended to perform the update using a wired network. 

 When COEX series controllers work with the XA50 Pro, CA50E, A10s Pro and its derivative cards, as well as 

A8s Pro and its derivative cards, you can only perform the update using (.ncp) files. 

 When updating using NCP files, if the firmware of the receiving card matches the NCP file, you have the 

option to update only the cabinet configuration file to enhance the update speed. 

 Restart cabinet 

Click Restart and click OK. 

 Factory reset (proceed with caution) 

The factory reset function is only supported on XA50 Pro, CA50E, A10s Pro and its derivative cards (version 

1.5.3.0 and above). 

Select one or more receiving cards. If the selected receiving cards support the factory reset function and 

have default parameters in the factory area, you can click Factory Reset to restore all user parameters to 

their default values. Any receiving cards that do not support this function will be automatically skipped, and 

a reason will be provided. 
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 Refresh information 

Click Refresh. 

16.3 Maintain Peripherals 

Applicable Products 

 3D emitters: EMT200 Pro 

 Multifunction card: MFN300 

Operating Procedure 

Step 1 From the menu bar, choose Tools > Maintain and select the Peripheral tab. 

Step 2 Select a screen from the project list on the left. 

Step 3 Select the target peripherals and perform the following operations as needed. 

Figure 16-3 Peripheral maintenance 

 

 Check peripheral information 

Check the status, name, associated controller (daughter card), location, model, firmware version, and other 

details of the peripheral. 

 Update peripheral 

Click Update, select the firmware file (.img) or compressed file (.zip), and click Open. Verify the file name 

and version number in the pop-up window, and click OK to proceed with the update. 

 Restart peripheral 

Click Restart and click OK. 

 Refresh information 

Click Refresh. 
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17 Software Settings 

17.1 Change Language and Temperature Scale 

 From the menu bar, choose Settings > 语言/Language, and then select the desired language option. 

 From the menu bar, choose Settings > Preference, and then select the desired temperature scale. 

Figure 17-1 Changing the language/temperature scale 

 

17.2 Manage Cabinet Library 

From the menu bar, choose Settings > Cabinet Library. Click Manage Packs and do the following operations as 

needed to manage the cabinet library files. 

 

Upload NCP File 

Step 1 Click Add. On the displayed window, click Upload File. 
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Figure 17-2 Adding NCP file 

 

Step 2 Select the targets to be imported (multiple targets can be selected). 

 When Local pack is selected, the imported NCP file will be saved under the VMP installation directory. 

 When Device pack is selected, the imported NCP file will be saved in the LED controller's storage space. 

Step 3 Select one or more NCP files to be imported from the local computer and click Add. 

After the file is selected, you can click Delete to delete the uploaded file. 

You can also click Refresh to refresh the NCP file list. 

Export NCP File 

Step 1 Select one or more (up to 40) NCP files on the Manage Packs screen and then click Export. 

For batch export, multiple files will be compressed as a .zip file and exported. 

Step 2 Select a local directory and click Save. 

Figure 17-3 Successful export 

 

Packaging NCP File 

Step 1 Select one or more NCP files on the Manage Packs screen and then click Packaging. 

Step 2 Choose a packaging method. You can select either Individual Files or Merge Export. 

 If you choose Individual Files, multiple individual NCP files will be exported. 

 If you choose Merge Export, the selected cabinet files from multiple NCP files will be reorganized into a single 

new NCP file. 
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Step 3 Select one or more files you need to package and click Packaging. 

Step 4 Select a local directory and click Save. 

Figure 17-4 Packaging NCP file 

 

Sync NCP File 

 Sync NCP files between the device and local computer 

Select the files to be synced (multiple files can be selected), and click . 

 

 Sync NCP files between devices 

a. Select the files to be synced (multiple files can be selected), and click Sync NCP. 

b. On the displayed window, select the devices to which the files are synced (multiple devices can be 

selected). 

c. Click Sync. 
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Check NCP File Information 

Select an NCP file, and the information about all the cabinets that use this NCP file will be displayed in the 

Cabinet List area below. The information includes application status, cabinet type, resolution, maximum frame 

rate, receiving card type, release status, version and revision. 

 

17.3 Check for Version Updates 

Prerequisites 

 Only supported on V1.5.0 or later. 

 Ensure that the computer is connected to a network to automatically check for updates. It is recommended 

to use a wired connection. 

Notice 

If the controller version does not match the VMP version, VMP cannot be used. 
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Operating Procedure 

When you run VMP, the system will automatically check the current version information of VMP and the 

controller. If a new VMP version is available, a notification window will pop up. For non-mandatory updates, you 

can choose to skip the new version. However, you can still check for updates during the use of the current version 

by following these steps: 

Step 1 From the menu bar, select Help > Check for Updates to see if VMP is up to date. 

Step 2 If a new version is available, click Update to begin the download and update process. 

Important updates for VMP will be enforced automatically. 

Figure 17-5 Check for updates 

 

Update Steps 

VMP V1.5.0 must be paired with LED display controller V1.5.0. First, update VMP to V1.5.0. Then, using VMP, 

update the controller to V1.5.0. Ensure you check the current version of the controller before updating VMP. 

 Controllers with version V1.4.0 support direct updates to V1.5.0. 

 Controllers prior to V1.4.0 require sequential updates as detailed below. 

Product 

Type 

Product 

Model 

Update Steps 

Software VMP Directly install the V1.5.0 software package. 

Controller MX6000 Pro 1. Before updating to V1.5.0, the firmware must be at V1.4.0. 

2. If the firmware is an earlier version than V1.4.0, first update to V1.4.0 using 

VMP (V1.4.0). 
MX2000 Pro 

MX40 Pro 1. Before updating to V1.5.0, the firmware must be at V1.4.0. 

2. If the firmware version is at V1.2.3, first update to V1.4.0 using VMP (V1.4.0). 

3. If the firmware is an earlier version than V1.2.3, first update to V1.2.3 using 

VMP (V1.2.3). Then, use VMP (V1.4.0) to update the controller to V1.4.0. 

4. For systems running version B14, use VMP (V1.2.3) to update the controller to 

V1.0.0, and then proceed to update to V1.2.3 and V1.4.0. 

MX30 1. Before updating to V1.5.0, the firmware must be at V1.4.0. 
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2. If the firmware version is at V1.1.0, first update to V1.4.0 using VMP (V1.4.0). 

3. If the firmware is an earlier version than V1.1.0, first update to V1.1.0 using 

VMP (V1.2.3). Then, use VMP (V1.4.0) to update to V1.4.0. 

MX20 1. Before updating to V1.5.0, the firmware must be at V1.4.0. 

2. If the firmware is an earlier version than V1.4.0, first update to V1.4.0 using 

VMP (V1.4.0). 

KU20 1. Before updating to V1.5.0, the firmware must be at V1.4.0. 

2. If the firmware version is at V1.2.1, first update to V1.4.0 using VMP (V1.4.0). 

3. If the firmware is an earlier version than V1.2.1, first update to V1.2.1 using 

VMP (V1.2.3). Then, use VMP (V1.4.0) to update to V1.4.0. 

CX40 Pro 1. Before updating to V1.5.0, the firmware must be at V1.4.0.B5. 

2. If the firmware version is at V1.1.0, first update to V1.4.0.B5 using VMP 

(V1.4.0.CTM0210). Then, perform a factory reset on the controller and select "Full 

Reset." 

3. If the firmware is an earlier version than V1.1.0, first update to V1.1.0 using 

VMP (V1.2.3). Then, use VMP (V1.4.0.CTM0210) to update to V1.4.0.B5. When 

updating to V1.1.0, please ensure that the receiving card CA50E is updated to 

V1.3.0.0 or later. 

Note: 

After upgrading the controller, it's generally advised not to downgrade, as it might cause device issues. Try to 

avoid this action during use. If you have questions or encounter problems, feel free to contact NovaStar technical 

support for assistance. 

17.4 Check User Manual 

From the menu bar, choose Help > User Manual to open and check the VMP user manual. 

17.5 Check Software Information 

From the menu bar, choose Help > About and check the software information. 

17.6 Check Keyboard Shortcuts 

From the menu bar, choose Help > Shortcuts and check the commonly used software operation shortcuts. 
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Figure 17-6 Shortcuts 
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